Font issue in Qt applications

I have this EXACTLY same problem: Text not visible in Qt applications, I tried the steps in the answer that are maked as “solution” but it didn’t work for me, no matter what theme I chose in Kvantum, the problem is the same, when I select some light theme, the problem diminishes, but the font is still having a problem. I also tried to change de presets of Kvantum as it listed here: Some qt based applications are showing theming problem as a solution, but nothing happens either.

So, I tried another solution listed here: How to change weird application background color?, so I installed qt5ct as soon as I open the program, it says it is not configured correctly, the message is:

Please remove the ’QT_STLYE_OVERRIDE' environment variable (current value: kvantum).
The environment variable QT_QPA_PLATAFORMTHEME is not set correctly, (current value: gnome, required value: qt5ct) tried to change the theme and absolutely nothing happens again.

I don’t know if this has anything to do with it, but the font scaling factor in gnome I left it set to 0.92, figured that might cause some problem, so I tried 1.00 and restarted the system, but the problem persisted, I tried to do this while changed the theme too and I didn’t have any success.

inxi -Fxz
  Kernel: 5.10.59-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  Desktop: GNOME 40.3 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: ASUSTeK model: PRIME B450M-GAMING/BR v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 2006 date: 11/13/2019 
  Info: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ 
  rev: 2 cache: L2: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 81467 
  Speed: 1729 MHz min/max: 1550/3400 MHz boost: enabled Core speeds (MHz): 
  1: 1729 2: 3742 3: 1373 4: 1375 5: 1586 6: 1372 7: 1375 8: 1375 9: 1729 
  10: 3770 11: 1580 12: 1374 
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  vendor: XFX Pine driver: amdgpu v: kernel bus-ID: 08:00.0 
  Device-2: A4Tech REDRAGON Live Camera type: USB 
  driver: snd-usb-audio,uvcvideo bus-ID: 3-2:2 
  Display: x11 server: X.Org 1.20.13 driver: loaded: amdgpu,ati 
  unloaded: modesetting resolution: 1920x1080~70Hz 
  OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.40.0 
  5.10.59-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.1.6 direct render: Yes 
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  vendor: XFX Pine driver: snd_hda_intel v: kernel bus-ID: 08:00.1 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus-ID: 0a:00.3 
  Device-3: A4Tech REDRAGON Live Camera type: USB 
  driver: snd-usb-audio,uvcvideo bus-ID: 3-2:2 
  Sound Server-1: ALSA v: k5.10.59-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: f000 
  bus-ID: 07:00.0 
  IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 447.13 GiB used: 112.86 GiB (25.2%) 
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB 
  ID-1: / size: 48.97 GiB used: 37.94 GiB (77.5%) fs: ext4 dev: /dev/sda2 
  ID-2: /boot/efi size: 269.5 MiB used: 312 KiB (0.1%) fs: vfat 
  dev: /dev/sda1 
  ID-3: /home size: 389.64 GiB used: 74.92 GiB (19.2%) fs: ext4 
  dev: /dev/sda3 
  ID-1: swap-1 type: file size: 1024 MiB used: 12.5 MiB (1.2%) 
  file: /swapfile1 
  System Temperatures: cpu: 45.8 C mobo: N/A gpu: amdgpu temp: 41.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1112 
  Processes: 334 Uptime: 2h 58m Memory: 15.62 GiB used: 3.23 GiB (20.7%) 
  Init: systemd Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1304 
  Shell: Zsh v: 5.8 inxi: 3.3.06 

Let me first state that I do not use Gnome but from what I have been told on these forums is that QGnomePlatform is the preferred way to handle QT apps in Gnome, at least in Manjaro. It is in the Official Community Repository. Let us know if it works.

Mate, I can’t install QGnomePlataform. I tried

$ pacman -Ss qgnomeplataform
$ pacman -Ss gnome plataform
$ yay -Ss QGnomePlataform
$ yay -Ss gnome plataform

but there’s no result…

It’s qgnomeplatform which is installed by default.

Well, did you click the Information button and follow the instructions? :wink:

Yes. The info button says exactly what I typed:

But I don’t know what I do with that informations…

Is there anyway to access it and change the theme?

I managed to fix the problem specifically in VLC, in the interface part I selected the “Adwaita-Dark” theme but I don’t know how to do that in other Qt applications, as they don’t have the interface option in the settings.

I figured I could do this by installing “Adwaita-Dark” Theme in Kvantum, so I downloaded the theme from the KDE store and when I try to install it says “This is not a Kvantum themes folder.”

See Environment variables - ArchWiki

You’ll need to change the values in /etc/environment (system-wide) or ~/.profile (per-user).

If you want to use the Adwaita-dark theme on GNOME, there’s nothing you need to do out of the box because QGnomePlatform is installed and ready to go. Neither Qt5ct nor Kvantum is required.

However, if you want the Manjaro theme (Maia) accents with Adwaita-maia-dark, you’ll need to use Qt5ct to set the custom Adwaita-maia-dark color scheme.

1 Like

Thanks for pointing me to the right direction. Changing QT_QPA_PLATFORMTHEME to the value qt5ct solved the font problem, but now, the icons of the Qt applications do not follow the icon theme.

You can set the icon theme to match in Qt5Ct on the Icon Theme tab.

FYI, the Matchama Kvantum theme has had no development it well over a year, it may have issues.

1 Like