[Testing Update] 2022-12-16 - Kernels, Pipewire, XFCE 4.18, Mesa 22.3.1, Plasma-Mobile, Thunderbird

Hello community,

Another testing branch update with some usual package updates for you.

Recent News:

Notable Package Updates:

  • Some of our Kernels got updated
  • Pipewire is at 0.3.63
  • XFCE got finally updated to 4.18
    • it is recommended to replace any nocsd packages with the regular ones to avoid issues with this XFCE update. See also troubleshoot post!
  • Mesa is at 22.3.1
  • Plasma-Mobile got renewed to 22.11
  • Thunderbird is at 102.6.0
  • Usual KDE-git, Haskell and Python updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Info about GNOME 43

GNOME 43 is here! :partying_face:

New in Manjaro GNOME:

Lonely leftover orphan packages that have been removed from the Arch / Manjaro repositories:

  • adwaita-maia
  • dynamic-wallpaper-editor
  • firefox-gnome-theme-maia
  • gtkhash-nautilus
    (Not compatible with Nautilus 43)
  • manjaro-dynamic-wallpaper
  • manjaro-gdm-tweak
  • nautilus-terminal
    (Not compatible with Nautilus 43 & EOL)

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.


Our current supported kernels

  • linux419 4.19.269
  • linux54 5.4.227
  • linux510 5.10.159
  • linux515 5.15.83
  • linux60 6.0.13
  • linux61 6.1.0
  • linux515-rt 5.15.79_rt54
  • linux60-rt 6.0.5_rt14

Package changes (Fri Dec 16 07:07:37 CET 2022)

  • testing community x86_64: 409 new and 408 removed package(s)
  • testing core x86_64: 19 new and 19 removed package(s)
  • testing extra x86_64: 191 new and 259 removed package(s)
  • testing kde-unstable x86_64: 341 new and 341 removed package(s)
  • testing multilib x86_64: 13 new and 13 removed package(s)

A list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

6 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2022-12-16

dbus-11 demoted to AUR

dbus-x11 was installed out of the box on some flavors of Manjaro as of a year ago, but is no longer needed. If you have it installed, please replace it with dbus using the following:

sudo pacman -Syu dbus
XFCE becomes unusable if libxfce4ui-nocsd is still installed

So far XFCE Classic project didn’t update yet to 4.18 series. We pushed 4.17.0 version of the package, but don’t know if that helps in that situation. It is recommended to install the regular libxfce4ui package to avoid issues and comment on this issue: libxfce4ui 4.18.0 released · Issue #15 · Xfce-Classic/libxfce4ui-nocsd · GitHub

2022-12-04

python-cairo 1.23.0-2 update requires manual intervention

The python-cairo package prior to version 1.23.0-2 was missing the compiled python module. This has been fixed in 1.23.0-2, so the upgrade will need to overwrite the untracked pyc file that was created. If you receive this error

python-cairo: /usr/lib/python3.10/site-packages/cairo/__pycache__/__init__.cpython-310.pyc exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/python3.10/site-packages/cairo/__pycache__/\*

to perform the upgrade.

2022-11-08

Pop Shell issues with Xorg session with Mutter 43.1 (fixed with mutter 43.1-1.0)

Gnome 43 (X11) GTK4 windows failed to render · Issue #1541 · pop-os/shell · GitHub

Windows not updated after non-interactive resize on X11 (#6054) · Issues · GNOME / gnome-shell · GitLab

2022-10-28

signature from "Manjaro Build Server <build_at_manjaro_dot_org>" is unknown trust

Seems our signing key for our Build Server had the 2022-10-28 as expire date set when generated. This is now fixed for chroot builds and fresh as also current existing installs via manjaro-keyring 20221028-4 Simply update your system to get that package, which got pushed to all our branches.

2022-10-27

Kernel 6.1-rc# might break backlight control on old/weird laptops

2022-10-18

Firefox 106.0 may have issues with screen sharing on GNOME with Wayland

2022-09-23

Nvidia 3060RTX cards may have issues with the 515.76 driver (fixed with 520.56.06)
Removing python2 from the repositories

2022-09-23 - Jelle van der Waa

Python 2 went end of life January 2020. Since then we have been actively cutting down the number of projects depending on python2 in our repositories, and we have finally been able to drop it from our distribution. If you still have python2 installed on your system consider removing it and any python2 package.

If you still require the python2 package you can keep it around, but please be aware that there will be no security updates. If you need a patched package please consult the AUR, or use an unofficial user repository.*

Arch Linux - News: Removing python2 from the repositories

* Note: Unofficial user repositories are not supported

2022-08-27

Changes with Back In Time packages
  • backintime has been renamed to backintime-qt
  • backintime-cli has been renamed to backintime

After replacing backintime-cli with backintime, you will need to install backintime-qt manually if you want the Qt frontend installed again.

2022-08-23

electron12, electron13, electron14 & electron16 have been dropped to the AUR

Unsupported Electron packages have been dropped from the official repos to the AUR. They no longer receive security updates and nothing in the repos depend on them.

If you have AUR packages depending on those versions, install the binary version from the AUR to replace them; i.e., electron16-bin.

See FS#75490 - electron12, electron13, electron14, electron16 are unsupported and vulnerable packages

End of Support for 15.x.y and 16.x.y

Electron 15.x.y and 16.x.y has reached end-of-support. As per Electron’s new 8-week cadence, we were supporting the latest four versions of Electron until May 2022. With this Electron 19 release, we’ll return to supporting the latest three major versions, as well as the alpha, beta, and nightly releases.

Release electron v19.0.0 · electron/electron · GitHub

2022-08-12

element-desktop dependency error (fixed with 1.11.4)
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (20.0.0-1) breaks dependency 'electron19' required by element-desktop

The upstream package was already flagged out of date (it needs to be rebuilt against latest electron).

Workaround for now:

sudo pacman -Syy electron electron19 --asdeps
sudo pacman -Su

2022-08-04

Glibc 2.36 update will break EasyAntiCheat within Proton (should be fixed with glibc 2.36-2)

Temporary workaround for now is to use the flatpak version of steam:

sudo pacman -S flatpak --needed --noconfirm
sudo flatpak install com.valvesoftware.Steam -y

You can use flatseal (another flatpak app) to grant it access to your existing game library so you don’t have to re-download your games (add the game library install path under “Other files” under “Filesystem”).

sudo flatpak install com.github.tchx84.Flatseal -y

For advanced users (not recommended by us): patched glibc and lib32-glibc are available here. They remove the commit that broke EAC.

2022-07-27

Fixed: Pamac shows archlinux-keyring (20220713-2) and manjaro-keyring (20220514-2) as orphans
sudo pacman -D --asexplicit archlinux-keyring manjaro-keyring

Resolved: w/ base 3-2 Revert changes:

sudo pacman -D --asdeps archlinux-keyring manjaro-keyring

2022-07-16

wxWidgets 3.2 update may need manual intervention

Packages have been renamed from wxgtk- to wxwidgets-. The GTK2 frontend is no longer provided. If you have wxgtk2 installed, the upgrade will fail with:

In such case, uninstall wxgtk2 first and then proceed with the upgrade.

2022-07-13

Linux518: could not insert 'amd_pstate': No such device

With Kernel 5.18.11 there was added a regression to AMD P-State driver preventing it from loading.

2022-07-08

Wireplumber 0.4.11 may crash for GDM users

Currently there is an issue with 0.4.11 and GDM crashing on boot-up. More in the upstream bugtracker issue: wireplumber segfault: system boot and could see in my dmesg (#305) · Issues · PipeWire / wireplumber · GitLab

2022-06-07

Locale file changes

C.UTF8 locale is now included in glibc:

Credits @diabonas for this change. Systemd wants us to include C.UTF8 by default and it seems the locale may be in included by glibc upstream in the future. To fix building and avoid nasty fixing in devtools, we include the locale in the package. See systemd/systemd#23252 (comment) FS#74864 : [systemd] >= 251 breaks devtools' locale

There is a pacsave for /etc/locale.conf as it has been removed from the filesystem package.

UPDATE: With filesystem 2022.06.08-2, it will automatically restore /etc/locale.conf if it did not already exist.
Uploading: image.png…

There is a pacnew for /etc/locale.gen. Please review it and regenerate your locale if necessary.

1 Like

Even with this update I had the same issue again. This time I updated/upgraded from stable to testing. The only solution was to downgrade to stable and copy over the whole /boot from a backup to the boot-partition.
I’m beginning to get nervous about the transition from testing to stable. What should I do, when this problem will come to stable and I no longer can rely on downgrading to stable.

When trying to install, I am seeing the following error:


:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: gnome-shell-extension-gtk4-desktop-icons-ng and gnome-shell-extension-desktop-icons-ng are in conflict (gnome-shell-extension-desktop-icons). 
Remove gnome-shell-extension-desktop-icons-ng? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: installing db (6.2.32-1) breaks dependency 'db=5.3.28' required by lib32-db

Thoughts? Should I manually remove the gnome-shell-extensions-icons-ng package?

Thanks in advance!

The gnome-shell-extensions-icons-ng isn’t the problem. The error that stops the upgrade is the break of the dependency between db and lib32-db. The former shall be upgraded to a version the latter can’t use.
I had the same problem. For me it was easy to solve, because on my machine lib32-db had once been installed as a dependency of some package but this dependency didn’t exist anymore. So I could simply remove lib32-db.

3 Likes

That fixed it, thank you!

Remember to check and cleanup orphans from time to time:

1 Like

amd vaapi doesnt work for me

i reverted thunar: 4.18 would not autoupdate the display after a change like deleting a file

Why not report the issue to upstream? Issues · Xfce / thunar · GitLab

Dropping dbus-x11 package from repositories without an upgrade path to the regular dbus one, or at the very least a warning on an official announcement (unless I missed it?), seems to be a pretty risky move to me, considering that it is a core package and that many pieces of software depend on it.

I was lucky to notice that Pamac wanted me to upgrade dbus-x11 from the AUR, which was really weird. I manually made the switch on my system before it stops working properly.

4 Likes

switching to the plain dbus package fixed it.

i don’t remember why i’d initially switched to dbus-x11, but i DO remember that i did it on purpose to fix a specific problem, so i guess i’ll see what crops up…

1 Like

It was used to allow users to launch GUI applications as root. Not sure if there is any other uses.

3 Likes

I am so thankful that @Frog identified this issue and let the community know. I actually wrote a Topic in June on dbus-x11 because our automation toolchain failed. As long as dbus-x11 is in the AUR, we’ll install it. It looks like it involves a recompile of dbus with the configuration option of --enable-x11-autolaunch. My issue is not with Thunar, but with graphical applications in general.

This has been discussed last year at this time too:

Regarding the “list of all package changes” (LAPC) link in post 1. I’ll be honest, I have a hard time understanding the format and trying to apply it to a system update to catch package changes (i.e., packages removed from Manjaro Repos). One thing I noticed, the removal of dbus-x11 was not in this 2022-12-16 Testing Announcement (LAPC #825) , but was in the 2022-12-13 Testing Announcement (LAPC #824).

When Testing moves to Stable will the LAPC #825 and #824 get combined into one list for the Stable Announcement?

It would be extremely helpful if there was a simple list of all packages that are removed from Manjaro’s Repo’s in the Testing and Stable Announcemenst. The LAPC is not layed out for automation or to easily see what was removed from Manjaro’s Repo’s – A user has to scan the far right column for a single dash. I am assuming the single dash is removal. There is no legend.

Consider voting for this package in the archlinux AUR to give it some energy.

1 Like

Nothing depends on dbus-x11, they depend on dbus.

As put by Emmanuele Bassi, a GNOME developer: “there are no real, substantiated, technological reasons why anybody should run a GUI application as root. By running GUI applications as an admin user you are literally running millions of lines of code that have not been audited properly to run under elevated privileges; you are also running code that will touch files inside your $HOME and may change their ownership on the file system; connect, via IPC, to even more running code, etc. You are opening up a massive, gaping security hole […].[1]

Running GUI applications as root - ArchWiki

Normally that’s a good idea to increase the chance a package may be imported into the Arch repos, however in this case it will make no difference. Arch will never import it into the core repository.

Upgrading from XFCE 4.16 to XFCE 4.18 created major issues here -

ie: after reboot taskbar vanished along with all launchers & settings and was unrecoverable, many desktop shortcuts failed, settings manager became largely nonfunctional, terminal was unavailable… Manjaro became essentially unusable.

Over time I’ve customized XFCE and am using PCManFM instead of Thunar. This may have effected the failed upgrade.

Anyway, I always backup the OS, ~/.config, and data using SystemRescue prior to upgrades. So I easily restored the OS & ~/.config, rebooted, and all was good to go.

Was supposed to be fixed [Unstable Update] 2022-11-25 - Mkinitcpio, NVIDIA, Qt, Gtk, SDL, LibreOffice, Cinnamon - #64 by pheiduck

1 Like

Interesting, thanks. libxfce4ui is currently not installed on my system. I’ll install it and try another XFCE upgrade later.

EDIT: OK - noticed that long ago I’d installed libxfce4ui-nocsd 4.16.1-1. So I installed libxfce4ui 4.16.1-1 (which automatically removed libxfce4ui-nocsd) then upgraded XFCE. libxfce4ui was properly upgraded to v4.18.0-1 and all’s well!

Thank you omano!

3 Likes

Except that dbus-x11 provides dbus and conflits with dbus too. Both packages provides the same software with slight variations. Therefore, users that keep the old package are left with an obsolete DBUS that isn’t rebuilt as needed nor upgraded anymore.

My point is not about if it should be kept or not, it’s to warn people about a possible breakage that might occur later.

no dbus or dbus-x11 on my side…