Why isn't dbus-x11 being installed?

I try to read all Annoucements (Unstable, Testing, Stable, ISO) to keep track of these type of issues. Did I miss the announcement? Please point me to it.

I have an existing upgraded system (SystemA) and I have a new system created using the new Ruah ISO (SystemB).

The defaults installed using pacman -Ss ^dbus are:

  • SystemA had installed core/dbus-x11.
  • SystemB had installed core/dbus.

I ran into a number of problems on SystemB because the X11 support was missing. It is required when an application trys to use DBus and has to start the DBus daemon (i.e., dbus-launch).

I spent a number of hours trying to figure out why something worked on SystemA but not SystemB, and it turned out to be the missing x11 support in dbus-launch.

Autolaunch requested, but X11 support not compiled in.

They conflict and as the usecase of the dbux-x11 is lesser than dbus - then dbus is installed per default.

But a maintainer of a community edition may have chosen to use dbus-X11 and therefore it is possible that one edition uses the X11 package another doesn’t.

You can install it if you need it.

Three systems of different age? that will explain it. Since years it is forth and back. When it is implemented people complain, when not implemented people complain.
Honestly it is one of the first things I look for and install on my xfce’s.


It is always useful to hear from other users and their experiences, solutions, and actions. Your response was very helpful. It is on my list now too :slight_smile:

I just wish I knew so I could have taken the appropriate actions on my end. It would have saved a whole lot of time.

Was it documented some place and I just missed it? Users need something like the comparison below which appears on the Stable Announcements (appears above the poll, but for the ISO Announcements.

A detailed list of all changes can be found here.

Ahhh, maybe the answer is a comparison of /rootfs-pkgs.txt and /desktopfs-pkgs.txt from the current installed system (SystemA) to the new installed system (SystemB).


I know, you want to open thunar root for a easy (convenient) way for editing files.
So, in order not to anger the high priests, here is a better, still lazy and convenient way
to edit your files in the root directories.
Open thunar as normal user > Edit > Configure custom actions
…in the dialog:

Edit in Nano/Root

xfce4-terminal -x sudo nano %f

Appearence Conditions:

File Pattern: *

Appears if section contains: “Text Files” and “Other Files”

…and a nice red terminal icon. -Apply - done.
But careful, much power much damage.

xfce:thunar:custom-actions [Xfce Docs]


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.