[Testing Update] 2022-04-28 - Kernels, GNOME 42.1 & NVIDIA

Hello community,

Another testing branch update with some usual updates for you.

Don’t miss out on 10% discount on selected hardware by Star Labs. Visit their store today: Clearance – Star Labs®!

  • GNOME got updated to 42.1. More info about theme changes in the dedicated post of this update announcement!
  • NVIDIA production branch release driver updated to 510.68.02
  • Usual Haskell and Python package updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Annoucement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux49 4.9.312
  • linux414 4.14.277
  • linux419 4.19.240
  • linux54 5.4.191
  • linux510 5.10.113
  • linux515 5.15.36
  • linux516 5.16.20 [EOL]
  • linux517 5.17.5
  • linux518 5.18-rc4
  • linux515-rt 5.15.34_rt40
  • linux516-rt 5.16.2_rt19
  • linux517-rt 5.17.1_rt17

Package Changes (Thu Apr 28 19:48:08 CEST 2022)

  • testing community x86_64: 1282 new and 1278 removed package(s)
  • testing core x86_64: 31 new and 31 removed package(s)
  • testing extra x86_64: 215 new and 218 removed package(s)
  • testing kde-unstable x86_64: 9 new and 9 removed package(s)
  • testing multilib x86_64: 13 new and 13 removed package(s)

A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


:information_source: GNOME 42 has arrived! :partying_face:

Gtk 4 theming and Libadwaita
Unfortunately, there will be no custom theming available for Libadwaita applications. However, once the Libadwaita Recoloring API is implemented, we should be able to add Maia to the color palette.

I suggest installing the adw-gtk-theme from our community repo to make all Gtk applications have a matching theme. In Tweaks, set the Legacy Applications theme to Adw or Adw-dark. I recommend setting the Shell theme to Default or another shell theme you prefer that has GNOME 42 support.

To automatically switch the system theme and legacy application theme when toggling between the Light and Dark style in Settings, install the Legacy (GTK3) Theme Scheme Auto Switcher extension (gnome-shell-extension-legacy-theme-auto-switcher).

Qt application theming
For Qt application theming, we have switched back to QGnomePlatform for GNOME 42. qt5ct and qt6ct (Qt Configuration Utilities) may be marked as orphans. If you want to use QGnomePlatform with the Adwaita Qt style, you’ll need remove or comment the QT_QPA_PLATFORMTHEME variable in /etc/environment. You’ll want both qgnomeplatform and qgnomeplatform-qt6 for Qt 5 and Qt 6 applications.

New Adwaita folder icon style
If you want the new Adwaita folder icon style with Papirus, you can use papirus-folders to set it:

For example, with Papirus-Dark:

papirus-folders -C adwaita --theme Papirus-Dark

Manjaro COSMIC status
For those using the Manjaro COSMIC packages, you will need to remove them. I’ve dropped them from the repos. Once System76 finishes their new Gtk 4 applications for Pop!_OS, I’ll see about adding them.


If you’re not using GNOME

If you want to change the theme of Libadwaita applications on another Gtk desktop like Xfce or Cinnamon, you can use the following commands:

Light Adwaita theme:

gsettings set org.gnome.desktop.interface color-scheme default

Dark Adwaita theme:

gsettings set org.gnome.desktop.interface color-scheme prefer-dark

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2022-04-28


Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
  • Check the mirror you use is up to date:
sudo pacman-mirrors -f 5 && sudo pacman -Syyu 
  • If you use qt5-styleplugins (AUR), rebuild it:
pamac build qt5-styleplugins
FIXED? VPN via L2TP might not work anymore

See FS#74089 - networkmanager 1.36 breaks vpn with networkmanager-l2tp

You may need to downgrade to 1.34.0:

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst

FIXED? DSL/PPPoE may require downgrading 2 packages

See my-internet-connection-is-no-longer-working and FS#73948 - networkmanager 1.36.0 breaks DSL connection

Please check if 1.36.2-1.0 of NetworkManager improve things, else downgrade to 1.34.0:

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst


New warnings when building the fallback initcpio - Possibly missing firmware for module: bfa, qed, qla1280, qla2xxx

That’s due to the recent changes to the linux-firmware package. Note these are warnings, not errors. You only need those firmwares if you have Mellanox Spectrum switches, Marvell devices, Qualcomm SoCs, Cavium LiquidIO server adapters, QLogic devices and Broadcom NetXtreme II 10Gb ethernet adapters. if you have that hardware you can install linux-firmware-qlogic to get rid of those warnings. If you do not have that hardware you can safely ignore those warnings.

pamac install linux-firmware-qlogic


Python packages from PIP and AUR - how to upgrade them - detailed instructions

Read this post.


I just tried to install the update, before I mess up my system, I’m asking how to best resolve this dependency conflict:

sudo pacman -Syu                                                                                                                                                                                                                                                       
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (510.68.02-1) breaks dependency 'nvidia-utils=510.60.02' required by linux516-nvidia

I’m currently on the “Testing Update 2022-04-25” using GNOME.

Thank you very much :pray:


It worked, thank you so much :clap:


@Yochanan Unfortunately this update did not solve the problem of the Google Drive integration with nautilus stopped working. Maybe is it a local config file I need to remove? Regards.

Plasma and AMD Mesa driver here. Everything works for me, thanks.

1 Like

You can always try by yourself, by creating a test user, try on this fresh user, and see if the issue exists on this user, you’ll know if the issue is on the system or on your user.

I did what you recommended on two different PCs. But it still doesn’t work. Any guidance on how can I help to debug this? I would love to. I’m checking now their repository (gnome-control-center). Ah, I tried to use different kernels: 5.15.36-1, 5.16.20-2, 5.17.5-2, even the experimental 5.18rc4.

abr 29 01:55:24 B360M-i7 systemd[2085]: app-gnome-org.gnome.Settings-12184.scope: Consumed 3.087s CPU time.
abr 29 01:55:44 B360M-i7 xdg-desktop-por[2632]: Realtime error: Could not map pid: Could not determine pid namespace: Could not find instance-id in process's /.flatpak-info
abr 29 01:55:49 B360M-i7 gnome-control-c[12418]: Source ID 2935 was not found when attempting to remove it
abr 29 01:56:42 B360M-i7 dbus-daemon[466]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.280' (uid=1000 pid=12000 comm="/usr/bin/nautilus --gapplication-service")

Nice job and thank you guys! Bless your fingers :slight_smile:

1 Like

Since previous update, kipi-plugins, libkipi and libmediawiki were orphaned, and then relegated to AUR packages. I removed them. But now, if on an image I try to share->imgur from Dolphin or export->imgur from Spectacle, it crashes, and doesn’t send images to imgur website like it would before. What is weird is that the options to send to external services are still there, despite the kipi plugin and dependencies being removed. Something is not right.

@omano what you describe is working for me and I also uninstalled the kipi packages

OK thanks, I reinstalled the AUR packages to test and it is not working. I’ll try to debug the issue on my side then.

//EDIT: indeed issue was on my side, errors about OpenGL, reboot fixed it.

avril 29 16:32:56 omano-nvme dolphin[53619]: Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile)
avril 29 16:33:13 omano-nvme spectacle[69917]: Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile)

I had the same issue. I opened Settings > Online accounts and I re-entered usernames and passwords for the Google accounts. After that, Google drive works again in Nautilus.

1 Like

I finally found a solution that worked for my case. For some reason I didn’t have the package installed gvfs-google and pamac install gvfs-google did the trick. I checked the presence of gvfs-goa also and that was there. The weird fact is I had this same problem in 3 different machines.

Always check optional dependencies depending on your needs. With gvfs, there are quite a few. Not everyone needs all of them.

Optional Deps   : gvfs-afc: AFC (mobile devices) support
                  gvfs-smb: SMB/CIFS (Windows client) support
                  gvfs-gphoto2: gphoto2 (PTP camera/MTP media player) support
                  gvfs-mtp: MTP device support
                  gvfs-goa: gnome-online-accounts (e.g. OwnCloud) support
                  gvfs-nfs: NFS support
                  gvfs-google: Google Drive support
                  gtk3: Recent files support

Currently we include all of them on the GNOME ISO due to user feedback:


Had the exact same issue on nemo (running cinnamon) as well. Ssme fix worked for me as well

Why linux518-nvidia listed in orphans?

pamac list -o                                                                                                                                                                                        ✔ 
autoconf        2.71-1         core       2.3 MB
automake        1.16.5-1       core       1.7 MB
bison           3.8.2-4        core       2.7 MB
flashrom        1.2-3          community  1.8 MB
flex            2.6.4-3        core       994.3 kB
libcbor         0.9.0-1        extra      149.4 kB
libjcat         0.1.11-1       community  502.4 kB
libsmbios       2.4.3-5        extra      1.0 MB
linux518-nvidia 510.68.02-0.2  extra      49.1 MB  <---- What are you doing here
pkgconf         1.8.0-1        core       165.5 kB
protobuf-c      1.4.0-3        extra      321.6 kB
yarn            1.22.18-1      community  5.3 MB

Just a guess but it maybe because 5.18 kernel has not been released as stable yet.