[Testing Update] 2021-05-21 - Kernels, Systemd, LibreOffice, Mesa, Nvidia, Toolchain, KDE Gear

Hello community,

Another testing branch update with some usual updates for you.

Find out more about the latest control center by our partner TUXEDO Computers

  • Most of our Kernels got updated
  • LibreOffice is at 7.0.6
  • Mesa got updated to 21.1.1
  • Nvidia driver is now at 465.31. If you use Display-Port see also this!
  • Systemd is now at 248.3
  • Our toolchain got updated to gcc 11
  • KDE Gear got updated to 21.04.1
  • Lot of KDE-git package updates and removal from [community] repos
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.268
  • linux49 4.9.268
  • linux414 4.14.232
  • linux419 4.19.190
  • linux54 5.4.118
  • linux510 5.10.38
  • linux511 5.11.22
  • linux512 5.12.5
  • linux513 5.13-rc2
  • linux54-rt 5.4.115_rt57
  • linux59-rt 5.9.1_rt19

Packages Changes (Fri May 21 15:26:52 CEST 2021)

  • testing community x86_64: 1528 new and 1649 removed package(s)
  • testing core x86_64: 53 new and 54 removed package(s)
  • testing extra x86_64: 674 new and 668 removed package(s)
  • testing kde-unstable x86_64: 168 new and 161 removed package(s)
  • testing multilib x86_64: 19 new and 20 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

New issues:

  • Compiz packages like compiz-easy-patch got dropped from our repositories. Due to protobuf update you may need to rebuild that package locally on your end. Compiz-easy-patch removed from repos

  • Some Nvidia cards don’t work with the current 465.31 drivers when used with Display Port and/or 4k Monitors. More about the issue at the Nvidia Developer Forum. We recommend to switch to Nouveau driver as needed. If you however need the Nvidia driver, you can get the PKGBUILDs of the 460.73.01 version and build your driver locally with makepkg or use the pre-compiled packages: nvida-utils, dkms and lib32 + precompiled .

  • OS prober does not run and add other operating systems

    Please click the ► at the beginning of this line to view this solution

    To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

    For more information, see opening post in [Stable Update] 2021-03-08.

Recent Arch Linux news:

PHP 8.0 and PHP 7 legacy packages are available

PHP 8.0 and PHP 7 legacy packages are available

2021-01-28 - Pierre Schmitz

The php package has been updated to version 8.0. Please refer to the upstream migration guide. As some applications are not compatible with PHP 8 yet we provide a php7 package which can be installed alongside version 8. Packages that depend on PHP reflect this update and will require php7 if needed. You might need to update your configuration accordingly. PHP 7 binaries and configuration have the “7” suffix:

  • /usr/bin/php → /usr/bin/php7
  • /etc/php → /etc/php7
  • /usr/bin/php-fpm → /usr/bin/php-fpm7
  • /usr/lib/systemd/system/php-fpm.service → /usr/lib/systemd/system/php-fpm7.service
  • /run/php-fpm → /run/php-fpm7

We also provide third party modules compiled for PHP 7:

Note that support for php7 will be limited and likely be dropped in about a year depending on how soon the majority of applications will be compatible with version 8.


Chromium losing Sync support in early March

Chromium losing Sync support in early March

2021-02-03 - Evangelos Foutras

Google has announced that they are going to block everything but Chrome from accessing certain Google features (like Chrome sync) starting on March 15. This decision by Google is going to affect Arch’s chromium package a bit earlier, on March 2, when Chromium 89 gets released.

We know for sure that data syncing will stop working (passwords, bookmarks, etc.). Other features such as geolocation or enhanced spell check might continue to function for a bit longer. Extensions integrating with Google Drive might misbehave and LibreOffice will lose access to documents stored there.

Other distros such as openSUSE and Fedora have already removed the soon-to-be-limited API keys from their Chromium 88 packages. Fedora’s advisory provides a great deal of perspective on this and I also found this Hackaday post to be quite informative.


Older Issues

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Hi, I noticed these warning messages:

> warning: could not get file information for usr/lib/python3.9/site-packages/MarkupSafe-1.1.1-py3.9.egg-info/
> warning: could not get file information for usr/lib/python3.9/site-packages/MarkupSafe-1.1.1-py3.9.egg-info/PKG-INFO
> warning: could not get file information for usr/lib/python3.9/site-packages/MarkupSafe-1.1.1-py3.9.egg-info/SOURCES.txt
> warning: could not get file information for usr/lib/python3.9/site-packages/MarkupSafe-1.1.1-py3.9.egg-info/dependency_links.txt
> warning: could not get file information for usr/lib/python3.9/site-packages/MarkupSafe-1.1.1-py3.9.egg-info/top_level.txt
> warning: could not get file information for usr/lib/python3.9/site-packages/markupsafe/__pycache__/__init__.cpython-39.opt-1.pyc
> warning: could not get file information for usr/lib/python3.9/site-packages/markupsafe/__pycache__/_compat.cpython-39.opt-1.pyc
> warning: could not get file information for usr/lib/python3.9/site-packages/markupsafe/__pycache__/_constants.cpython-39.opt-1.pyc
> warning: could not get file information for usr/lib/python3.9/site-packages/markupsafe/__pycache__/_native.cpython-39.opt-1.pyc

Check if some is off with python-markupsafe package. Remove those files and reinstall that package.

Have an issue with certain apps on 5.12.x, 5.11.x works fine. Biggest issue is that inability to start openarena - the desktop crashes and restarts. It’s on an acer laptop with a old 2nd generation on-board intel gpu, i.e.
Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller

Happy to provide any information that you need to diagnose the issue.

About the issue with nvidia and DP: I am currently using an DP 1.2 → HDMI 2.0 dongle, and and it works.
My screen is always the DELL U3419W.

Could you try to start it via terminal and take a look at/post the output? If it is an AUR package it might need to be rebuilt.

That really is easier said than done because running it in any way restarts the whole of X giving me the login dialog again. Also, it’s not an AUR package - it’s purely downloaded from openarena.ws

This was in xorg.log

[  3303.494] (EE) 
[  3303.494] (EE) Backtrace:
[  3303.494] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x53) [0x557518eb9fd3]
[  3303.494] (EE) 1: /usr/lib/Xorg (0x557518d73000+0x151df5) [0x557518ec4df5]
[  3303.494] (EE) 2: /usr/lib/libc.so.6 (0x7f2d472e7000+0x3cda0) [0x7f2d47323da0]
[  3303.494] (EE) 3: /usr/lib/Xorg (0x557518d73000+0xc1fde) [0x557518e34fde]
[  3303.494] (EE) 4: /usr/lib/Xorg (0x557518d73000+0x1b9611) [0x557518f2c611]
[  3303.494] (EE) 5: /usr/lib/Xorg (0x557518d73000+0xd2a72) [0x557518e45a72]
[  3303.495] (EE) 6: /usr/lib/Xorg (0x557518d73000+0xd9241) [0x557518e4c241]
[  3303.495] (EE) 7: /usr/lib/Xorg (0x557518d73000+0xdabac) [0x557518e4dbac]
[  3303.495] (EE) 8: /usr/lib/Xorg (0x557518d73000+0xd72ec) [0x557518e4a2ec]
[  3303.495] (EE) 9: /usr/lib/Xorg (0x557518d73000+0x3a195) [0x557518dad195]
[  3303.495] (EE) 10: /usr/lib/libc.so.6 (__libc_start_main+0xd5) [0x7f2d4730eb25]
[  3303.495] (EE) 11: /usr/lib/Xorg (_start+0x2e) [0x557518dad5de]
[  3303.495] (EE) 
[  3303.495] (EE) Segmentation fault at address 0x20
[  3303.495] (EE) 
Fatal server error:
[  3303.495] (EE) Caught signal 11 (Segmentation fault). Server aborting
[  3303.495] (EE) 
[  3303.495] (EE)

Nothing to report, just wondering why Manjaro do not have his own control center :stuck_out_tongue:

Rig: Nvidia gtx1650 ryzen 3600
Kernels 510 and 512

Great job, thank you!

My locale settings were a bit messed up after this update. Reinstalling the language through MSM fixed that.

ok Ryzen 3600XT ( kernel 5.12.5 )
Xfce + Nvidia 465.31 + video( youtube 1080p in avc1 ) + Steam(OpenGl/Vulkan) for 1080p

Pushed some more packages:

:: Different sync package(s) in repository community x86_64

                             PACKAGE           2021-05-20           2021-05-21
                        ansible-lint              5.0.9-1             5.0.10-1
                             freehdl             0.0.8-10             0.0.8-11
                                 kup              0.9.0-1              0.9.0-2
                             pam-u2f              1.1.0-1              1.1.1-1
                     python-oslo-log              4.4.0-3              4.5.0-1
                      python-pikepdf             2.12.0-1             2.12.1-1
                      python-wcmatch              8.1.2-1                8.2-1
         v2ray-domain-list-community     20210519075125-1     20210521164504-1
                              websvn                2.5-1              2.6.1-1
              xdg-desktop-portal-wlr              0.3.0-1              0.3.0-2
                                 bup                    -               0.32-2

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE           2021-05-20           2021-05-21
                            libepoxy            1.5.7-1.0                    -

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2021-05-20           2021-05-21
                               atkmm             2.28.1-1             2.28.2-1
                          atkmm-docs             2.28.1-1             2.28.2-1
                             cairomm             1.12.2-4             1.14.3-1
                        cairomm-docs             1.12.2-4             1.14.3-1
                            libepoxy              1.5.7-1              1.5.8-1
                         qt5-wayland     5.15.2+kde+r22-1     5.15.2+kde+r23-1
                          atkmm-2.36                    -             2.36.1-1
                     atkmm-2.36-docs                    -             2.36.1-1
                        cairomm-1.16                    -             1.16.1-1
                   cairomm-1.16-docs                    -             1.16.1-1

:: Different sync package(s) in repository multilib x86_64

                             PACKAGE           2021-05-20           2021-05-21
                      lib32-libepoxy              1.5.7-1              1.5.8-1

There’s graphic glitches with kernel 5.12 running electron apps from Snap (like Signal) when pressing right click, for example to copy a link:


I’m not experiencing anything like that (I’m using nvidia proprietary drivers).

Updated moments ago , and noticed several problems ranging from being unable to boot with kernel 4.19.190-2 by getting systemd.udev errors …
All the new ( 5.x) kernels are “Bootable” though …

Another annoying detail is , for example unable to play any of the Steam games like :
“./StarConflict: /usr/lib32/libcurl.so.4: version `CURL_OPENSSL_3’ not found (required by ./StarConflict)”
Any ideas how to solve this one ? as yesterday everything was OK …

cannot boot into tty1, using tty2 instead

Using video-modesetting, going to video-linux may be OK but how to change that? The priority of video-modesetting is higher than video-linux

OS: Manjaro 21.0.4 Ornara
Kernel: x86_64 Linux 5.12.5-arch1-1-surface
Shell: bash 5.1.8
Resolution: 2736x1824
DE: KDE 5.82.0 / Plasma 5.21.5
WM: KWin
GTK Theme: Mojave-light-alt [GTK2/3]
Icon Theme: la-capitaine-icon-theme
CPU: Intel Core i5-8250U @ 8x 3.4GHz
GPU: Mesa Intel(R) UHD Graphics 620 (KBL GT2)

I have the same issue reported in the previous update, but I think I have found the responsible: systemd!
Here the steps I done before the update:

  • Tried to boot 4.19 without boot parameters, like suggested here by @GaVenga: system didn’t boot.
  • I switched to stable.
  • Downgraded all installed systemd packages to the stable version (247.7-1).
  • Rebooted pc and 4.19 booted up without problems.
  • Switched to testing again and done the last update: now I have the same issue I had before.

So, for those reasons I think that my problem with the 4.19 is systemd related.


I concour with @zomberman
All the hassle with this latest update is directly related to the systemd package .
If I downgrade manually to systemd version 247.7 the system executes and boots Kernel 4.19 correctly and none of the Steam errors appear …
Although if I simply downgrade to the systemd previous 248.2 version I still was not able to boot with kernel 4.19…

1 Like

So you have proven it perfectly. :wink: Verified!
Unstable is no option, systemd is the same version as testing at this time.
And: I run a different system, kernel 510 and 512 at unstable - everything fine…
Can be magic.