[Testing Update] 2021-01-08 - Kernels, Plasma 5.20.5, KDE Apps 20.12.1, Nvidia 460, AMDVLK, Firefox, Pamac

Hello community,

Another testing branch update with some usual updates for you. We hope you all celebrated 2021 good so far.


Get the latest Nibia Release! #stayhome, #staysafe, #stayhealthy

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest Manjaro Ornara 21.0 preview release! KDE, XFCE and Gnome


Our current supported kernels

  • linux44 4.4.249
  • linux49 4.9.249
  • linux414 4.14.213
  • linux419 4.19.165
  • linux54 5.4.87
  • linux59 5.9.16 [EOL]
  • linux510 5.10.5
  • linux511 5.11-rc2
  • linux54-rt 5.4.84_rt47
  • linux59-rt 5.9.1_rt19

Packages Changes (Fri Jan 8 18:01:31 CET 2021)

  • testing community x86_64: 1356 new and 1309 removed package(s)
  • testing core x86_64: 22 new and 22 removed package(s)
  • testing extra x86_64: 585 new and 576 removed package(s)
  • testing multilib x86_64: 10 new and 10 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

3 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      
      If proprietary drivers don't fix everything, please click the â–ş at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
        
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime
        

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width
        

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: Graphics & Display - Manjaro Linux Forum or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the â–ş at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:

For GRUB:

  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the â–ş at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      [Service]
      Type=notify
      Slice=-.slice
      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
      
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the â–ş at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName
    

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.


Older Issues


Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - SĂ©bastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.

https://www.archlinux.org/news/libtraceevent59-1-update-requires-manual-intervention/

OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

1 Like

i have twice preset applied
coming from nvidia-drm ?

lost color mini icons on launcher menus ( lock , change user , deconnect )
missing tray info nb updates ( lost number and only in english )

( 9/23) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux510.preset: 'default'
  -> -k /boot/vmlinuz-5.10-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.10-x86_64.img
==> Starting build: 5.10.5-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.10-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux510.preset: 'fallback'
  -> -k /boot/vmlinuz-5.10-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.10-x86_64-fallback.img -S autodetect
==> Starting build: 5.10.5-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: aic94xx
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.10-x86_64-fallback.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'default'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64.img
==> Starting build: 5.4.87-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'fallback'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64-fallback.img -S autodetect
==> Starting build: 5.4.87-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: aic94xx
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64-fallback.img
==> Image generation successful
(10/23) Updating Kernel initcpios for Nvidia-DRM...
==> Building image from preset: /etc/mkinitcpio.d/linux510.preset: 'default'
  -> -k /boot/vmlinuz-5.10-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.10-x86_64.img
==> Starting build: 5.10.5-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.10-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux510.preset: 'fallback'
  -> -k /boot/vmlinuz-5.10-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.10-x86_64-fallback.img -S autodetect
==> Starting build: 5.10.5-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: aic94xx
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.10-x86_64-fallback.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'default'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64.img
==> Starting build: 5.4.87-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'fallback'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64-fallback.img -S autodetect
==> Starting build: 5.4.87-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: aic94xx
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64-fallback.img
==> Image generation successful
(11/23) Updating Grub-Bootmenu
Création du fichier de configuration GRUB…
Image Linux trouvée : /boot/vmlinuz-5.10-x86_64
Image mémoire initiale trouvée : /boot/amd-ucode.img /boot/initramfs-5.10-x86_64.img
Found initrd fallback image: /boot/initramfs-5.10-x86_64-fallback.img
Image Linux trouvée : /boot/vmlinuz-5.4-x86_64
Image mémoire initiale trouvée : /boot/amd-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
fait
(12/23) Reloading system bus configuration...
(13/23) Warn about old perl modules
(14/23) Copy Firefox Distribution Settings
(15/23) Updating fontconfig cache...
(16/23) Updating 32-bit fontconfig cache...
(17/23) Compiling GSettings XML schema files...
(18/23) Updating icon theme caches...
(19/23) Hiding redundant menu entries
(20/23) Updating the info directory file...
(21/23) Updating the desktop file MIME type cache...
(22/23) Updating the MIME type database...
(23/23) Updating X fontdir indices...
1 Like

Let’s clean this up a bit.
I updated through terminal, updates seemed to go fine, didn’t see anything strange (but didn’t have a firm eye on it). After update, the laptop did not want to reboot by going through the launcher, so I fired up a terminal and did sudo reboot (to get the changes).

After reboot, desktop looked fine, no problems, snappy.
Then I changed to Nvidia by using optimus-manager-qt (little icon in bottom panel). The log out was much faster than usual, but login was very slow. After putting in my password, the splash screen had a spinning circle underneath the plasma icon. After some time the circle stopped and the cursor came up, but computer was still on slpash screen. I gave this state few minutes but nothing happened (I could move the cursor).
I did TTY3 put in my username, and as I hit enter after putting in password, I was pulled back to TTY1 to the desktop seen below (I opened terminal though).


The bottom panel works, but right clicking on the black area results in nothing. Opening and closing a browser takes care of the “other” panel, but desktop still unresponsive.

I am able to TTY3 and startx. That gets me into a working environment with wallpaper, but no icon for optimus-manager-qt.

I am currently trying out the the broken tty1 to see if I can do any work. So far programs start and “work”, but are very sluggish.
I wonder what you would like to check, but to begin with, here is inxi -Fazzy

System:
  Kernel: 5.10.5-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=c815eb99-c4fe-44e6-9745-a703a1f11a87 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-cx0xxx 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 8478 v: 70.57 serial: <filter> UEFI: Insyde v: F.22 
  date: 04/21/2020 
Battery:
  ID-1: BAT1 charge: 24.6 Wh condition: 24.6/52.8 Wh (47%) volts: 12.8/11.6 
  model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> 
  status: Full 
CPU:
  Info: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: DE L2 cache: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 36812 
  Speed: 3722 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 3722 2: 3738 
  3: 3756 4: 3747 5: 3759 6: 3734 7: 3755 8: 3742 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard 
  driver: nvidia v: 460.32.03 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1c8d 
  Device-3: Cheng Uei Precision Industry (Foxlink) HP Wide Vision HD 
  Integrated Webcam 
  type: USB driver: uvcvideo bus ID: 1-5:5 chip ID: 05c8:03bc 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 
  driver: modesetting,nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1-1 res: 1920x1080 hz: 60 dpi: 142 
  size: 344x193mm (13.5x7.6") diag: 394mm (15.5") 
  OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.10.5-1-MANJARO 
Network:
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Hewlett-Packard driver: rtw_8822be v: N/A modules: rtw88_8822be 
  port: 4000 bus ID: 02:00.0 chip ID: 10ec:b822 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 05:00.0 
  chip ID: 10ec:8168 
  IF: eno1 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.6 TiB used: 660.63 GiB (40.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLW256HEHP-000H1 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: CXB73H1Q temp: 42.9 C 
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Toshiba 
  model: External USB 3.0 size: 931.51 GiB block size: physical: 512 B 
  logical: 512 B serial: <filter> rev: 5438 
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital 
  model: WD My Passport 0740 size: 465.73 GiB block size: physical: 512 B 
  logical: 512 B serial: <filter> rev: 1007 
Partition:
  ID-1: / raw size: 238.17 GiB size: 233.43 GiB (98.01%) 
  used: 57.63 GiB (24.7%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 58.0 C mobo: 29.8 C gpu: nvidia temp: 55 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 314 Uptime: 11m wakeups: 1 Memory: 15.53 GiB 
  used: 5.5 GiB (35.4%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.0.0 Packages: pacman: 1399 lib: 423 flatpak: 0 Shell: Zsh v: 5.8 
  running in: konsole inxi: 3.2.01 

Isn’t it how it always has been with Nvidia?

have you to backup this file and reboot ?
mv /etc/X11/mhwd.d/nvidia.conf /etc/X11/mhwd.d/nvidia.conf.old

have you also checked xrandr ?

i get twice mkinitcpio for same preset ( i have added nvidia in modules )

Do you want me to delete the onlynvidia.conf file after taking backup of it? (it only says

##
## Generated by mhwd - Manjaro Hardware Detection
##

)

…and “Isn’t it how it always has been with Nvidia?”. I think it is.

First is because Kernel packages got update.
Second is because Nvidia package got updated.

This always, as far as I remember, has been like that.

You got it twice because both kernel and nvidia got updated.

@stephane, that’s been bothering me too. it’s processing
/usr/share/libalpm/hooks/90-mkinitcpio-install.hook
and
/usr/share/libalpm/hooks/90-nvidia-utils.hook

at first glance it seemed like one could just add the target from the second file into the first, but the first is not just running mkinicpio -P, it is running an actual script i’m not comfortable touching.

No really a big deal but update broke megasync, a rebuild fixes it though

There is problem with amd vulkan driver, some games won’t start. I resolved by switching to radeon
vulkan driver.

pamac does not find updates at startup. No problem if forced by the menu item “refresh database”.

Same for me: pamac fails to find AUR updates (#930) · Issues · Applications / pamac · GitLab
(it occurs not only for AUR packages, but also for repo packages)

Yay, it seems Plasma update fixed buggy gtk window decorations.

1 Like

No issues with this update with optimus-manager setup. Switching GPUs works as intended, no further configs showed during the update so nothing had to be done. GPU drivers updated without a problem. All on kernel 5.9 because 5.10 is not mature enough.

For me this update didn’t break megasync, an earlier one did. I even couldn’t rebuild it because it threw some compilation error, so I grabbed the installation file from mega.nz site, and it works well.

2 Likes

Yes megasync broke for me on a previous update as well so I installed megasync git from the aur instead, which was working until todays update. But like I said a rebuild fixed it

Hello. Updated kernel to 5.10 and I lost my Nvidia Sync. It’s off now on the Nvidia control panel. Back to 5.9 and fixed. Hope this can fix soon

P.S: Fixed after the second try with new testing branch

@schinfo
.
/usr/lib/gdm-x-session[833]: (EE) AMDGPU(0): present flip failed>
/usr/lib/gdm-x-session[833]: (WW) AMDGPU(0): flip queue failed: Invalid argument
/usr/lib/gdm-x-session[833]: (WW) AMDGPU(0): Page flip failed: Invalid argument

is flooding (adding one entry in one second) journalctl - why?
.
EDIT: GNOME - only under x-org – not under wayland (as gdm-x-session says)
(Das Häkchen bei Anzeigeeinstellungen / Auflösung steht falsch, die Auflösung wird richtig angezeigt.)
The tick next to display settings / resolution is incorrect, the resolution is displayed correctly.
.
EDIT2:
**It only affects the kernel 511 (5.11.rc2.d0103.ge71ba94-1)

  • kernel 5.10.5-1 is o.K.**

I’m having this new issue that I can’t remember experiencing before. I’m on an Thinkpad T470 and using the 5.10.5 kernel.

Upon resuming from sleep, and logging back into KDE from SDDM, my wifi in KDE (I assume this is NetworkManager?) is getting stuck at “waiting for authorization” and never connect. My bluetooth mouse does not work either.

Upon clicking the “Application Launcher” button in KDE, it comes up, then KDE hangs. I can move my mouse but can’t click anything. Issuing a “sudo reboot” from a tty has the system stuck waiting for a 1 min 30 second timer to kill some user process.

I started booting my 5.4.87 kernel and I can’t seem to repeat this issue. My wifi connects every time after logging in from sleep. Not sure if this could be caused by the KDE updates, or the 5.10.5 kernel? But the 5.4.87 kernel so far seems OK. Could someone help me with grabbing logs to help debug this?