[Testing Update] 2020-12-07 - BREAKAGE EXPECTED - Kernels, Mesa 20.3, Python 3.9, Pamac 10

systemctl enable cups.service ?!

Maybe you missed previous updates notes about cupsd service being renamed to cups?

It does.


Fine. Was merely reporting packages flagged by checkrebuild as needing to be rebuilt, as per @philm request. Granted, libpurple and pidgin have been mentioned by others.


No worries. Thanks for reporting them, otherwise old, broken packages would have still been in the repos needlessly. :wink:


Hello, is there any chance to support video-hybrid-intel-nvidia-390xx-bumblebee in future 20.2 releases with 5.4 LTS kernel?

A post was split to a new topic: Issue with nvfancurve dependencies

If the packages are switched correctly (which they are not, check my post), then it will work just fine :man_shrugging:

Those have not actually been dropped, check the relevant post.

Poedit is broken since this update:

poedit: symbol lookup error: /usr/lib/liblucene++.so.0: undefined symbol: _ZN5boost16re_detail_10720019raise_runtime_errorERKSt13runtime_error

Had problems with Libreoffice too, but fixed those

With this “testing” update had problems with “Catfish” and “zeitgeist” as being in conflict …
Bluntly solved by removing " Catfish" for the time being …

maybe one of them needs rebuild against new python, that’s why they are in conflict

Hi, I understood that, but hardware detection selects video-linux instead of 390xx-bumblebee.

I had other things to do. Here is the missing part of switching the Nvidia drivers correctly:

@TotallyNotElite maybe review it.

1 Like

@TotallyNotElite maybe review it.

Will do.

@philm Tested, this does not work:

  1. manjaro-system script fails to copy the files, because they have not been installed yet. (Maybe this should be done in mhwd-db’s post update scripts?)
  2. Linux-latest still screws around with the nvidia packages
  3. After forcing the completion of this update by fixing the conflict, you end up with a franken-nvidia system:
    This happens because nvidia-utils does not replace the previous nvidia-utils packages, unlike lib32-nvidia-utils.
    For some reason, lib32-nvidia-utils is now no longer marked as explicitly installed.
  4. It also seems like there are quite a few more packages that need to be dropped from the repo.

So in short, this is a complete mess right now.

on lock Xfce screen ,
lost info user connecting with password

no solution

I hesitated with the update and waited till today, because I have hybrid graphics with optimus-manager.

I did the update today, then recompiled optimus-manager-git, rebooted and everything seems to be OK.
It’s possible I will find some breakages later, but so far, the system boots correctly, everything loads, Steam works, I can switch between GPU modes, Steam is showing correct drivers (intel, noveau or Nvidia - depending on the GPU mode).

So far so good.

I had some info about the lack of the folder:

grep: /etc/X11/mhwd.d/nvidia.conf: No such file or directory

but that’s expected on a proper optimus-manager install. This didn’t create any problems so seems like it worked well anyway.

1 Like

I had same or similar issue on unstable (xfce) posted journal there. It was light-locker related. No fix was found by me. Wound up removing light-locker and installed xfce-4 screensaver and enabled lock screen with that. No issues with screensaver. This was on a notebook with external monitor as Primary (lid in down position, HDMI connection)


What I reported initially.

Poedit works again with todays update