[Testing Update] 2020-12-07 - BREAKAGE EXPECTED - Kernels, Mesa 20.3, Python 3.9, Pamac 10

Hello community,

Another testing branch update with some usual updates for you. Remember that we expect possible breakage of your system with this update!

Find out what is new about Python 3.9! #stayhome, #staysafe, #stayhealthy

  • Most of the Kernels got updated. We removed linux57 and linux58 from our repositories. Switch to newer kernels as needed.
  • Python 3.9 update rolled in. We hope that we managed to rebuild all needed packages by now. If you use AUR packages, we recommend to install rebuild-detector before applying this update.
  • KDE-Git packages got updated as usual
  • We simplified Nvidia driver installation. This means we dropped legacy drivers. We recommend to switch over to Nouveau drivers as needed.
  • With the latest developer release of Mesa, we now should support RADEON RX 6800 out of the box.
  • Pamac 10.0-beta got further fixes

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest Manjaro Nibia 20.2 release! KDE, XFCE and Gnome

Our current supported kernels

  • linux44 4.4.247
  • linux49 4.9.247
  • linux414 4.14.210
  • linux419 4.19.161
  • linux54 5.4.81
  • linux59 5.9.12
  • linux510 5.10-rc7
  • linux54-rt 5.4.78_rt44
  • linux59-rt 5.9.1_rt19

:: Packages Changes (Mon Dec 7 09:28:30 CET 2020)

  • testing community x86_64: 2830 new and 2858 removed package(s)
  • testing core x86_64: 62 new and 70 removed package(s)
  • testing extra x86_64: 551 new and 628 removed package(s)
  • testing multilib x86_64: 26 new and 36 removed package(s)

A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

Older Issues

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.

Arch Linux - News: libtraceevent>=5.9-1 update requires manual intervention

OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Is this testing or unstable @philm? The heading is testing but you posted unstable in your op

Fixed the typo …

1 Like

I’ll see if the mirrors have synced yet and hopefully not too many breakages :crossed_fingers:

Let’s see how it goes.

Ave philm, mortuari te salutant!
Glück gehabt, funktionierte alles…

1 Like

Only vmware workstation and zoom showing as needing a rebuild after update according to rebuild-detector so that’s easy enough. :+1: :+1:


Cosmic issue, manjaro settings manager says I have open source drivers installed but prime-run glxinfo | grep OpenGL says I still have nvidia drivers

1 Like

For some reason searching in pamac or pamac-dev is very slow after this update. Plasma/linux59. (Something with opensnitch-git blocking aur search.)

Minimal Problem:
conflict between pulseaudio and pipewire-audio - solved by partial update with pamac, as in TTY problem
could not be solved. removed all AUR packages before really updating and reinstalled --> success.

Problem with pipewire now instead with pulseaudio…

Dez 07 13:41:46  pipewire-media-session[1623]: Register() failed: org.freedesktop.DBus.Error.ServiceUnknown
Dez 07 13:41:46  pipewire-media-session[1623]: core 0x5600390795f0: proxy 0x560039098e80 id:4: bound:-1 seq:4 res:-2 (No such file or directory) msg:"can't create device: No such file or directory"
Dez 07 13:41:46  pipewire-media-session[1623]: error id:4 seq:4 res:-2 (No such file or directory): can't create device: No such file or directory
Dez 07 13:42:11  pipewire-media-session[1623]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply

Audio works.

systemctl --user enable pipewire.socket
systemctl --user enable pipewire.service
systemctl --user enable pipewire-pulse.service

To Do:

---> pipewire[....]: Could not get portal pid: Argument 0 is specified to be of type "uint32", but is actually of type "string"
---> pipewire-media-session[....]: Register() failed: org.freedesktop.DBus.Error.ServiceUnknown

optimus-manager seems to be stuck at asking for sudo systemctl enable optimus-manager and sudo systemctl start optimus-manager even after doing these two things, with or without rebooting.

~ >>> optimus-manager --switch nvidia                                                              
Traceback (most recent call last):
  File "/usr/bin/optimus-manager", line 33, in <module>
    sys.exit(load_entry_point('optimus-manager==1.3', 'console_scripts', 'optimus-manager')())
  File "/usr/bin/optimus-manager", line 22, in importlib_load_entry_point
    for entry_point in distribution(dist_name).entry_points
  File "/usr/lib/python3.9/importlib/metadata.py", line 524, in distribution
    return Distribution.from_name(distribution_name)
  File "/usr/lib/python3.9/importlib/metadata.py", line 187, in from_name
    raise PackageNotFoundError(name)
importlib.metadata.PackageNotFoundError: optimus-manager

When trying to install video-hybrid-intel-nvidia-prime with manjaro settings gui you get the following error

Waiting for user input...


Error: config 'video-hybrid-intel-nvidia-prime' conflicts with config(s): video-hybrid-intel-nvidia-455xx-prime

So manual intervention is needed. Its no biggie but last time it happened the forum was spammed with repeat posts about nvidia drivers failing to install

No problem for me. I had to rebuild a few Python packages that came from AUR. (Most important: powerpill)
But a preceding install of rebuild-detector showed me which ones they were. Nicely done!

you didn’t specify, is that the version in the repo or is it from the AUR?

from Optimus Manager - Manjaro so I am guessing repo

Will probably reinstall optimus-manager again little later today.

Try installing git version from AUR that will compile with the newest packages and let us know how it worked.

Had to make rebuilds on 11 packages


Lighdm don’t work.

On my laptop HP with Nvidia / Intel, black screen on reboot with lightdm.

On TTY a startx is ok.

For temporary solve this: I installed sddm, and disable lightdm.

With sddm the boot is OK.


EDIT: the problem was optimus-manager . Solved with install optimus-manager-git and “sudo prime-switch”

I am guessing you want me to use version 1.5.1rc19??

Sorry, noticed that that is optimus-manager-qt-git

Installed optimus-manager-git from AUR as @michaldybczak suggested, and optimus-manager-qt 1.5.1 from AUR as well, rebooted, and tried it out.
Computer says I am running Nvidia now.

1 Like