System will not boot after installing kernel 6x, or clean install

Hello there!

I have a laptop with a 11th gen intel chip, and a NVIDIA graphics chip. I have not been able to get Manjaro on any kernel 6 (6.1, 6.2 or 6.3), i always drop to an emergency shell at startup. I’ve tried:

  • Using an image with kernel 5.15, upgrading to kernel 6.1: got dropped in the emergency shell (kernel 515 still works).
  • Install using the latest image from Manjaro (kernel 6.1): emergency shell. This option is a little strange, live ISO (linux61) does not see my SSD in disk, and chroot fails as it does not find a linux partition.

I’ve read that 11th gen causes some trouble with kernel > 5, so i tried putting ibt=off while on live iso (manjaro-chroot) on my grub, still no effect.
Tried upgrading all drivers as well, but the results are always the same, emergency shell.

Currently, i have a clean installation using the latest ISO from manjaro, and can only chroot it from a 515 live ISO, where i installed the nvidia package via pacman.
I’m a little lost on what to do, any help would be great!

Well you can provide the output of inxi -FSxx to have more info. hwinfo would give you more details about your PC. You can use services like pastebin to share the content here.

uname -r on the chroot session is showing kernel 5.15, but the installed system is manjaro 22.1.0 - Talos.
mhwd-kernel -li show runnig as 5.15 and installed lists linux61
The cat /etc/lsb-release shows:


how did you add ibt=off? did you updated grub afterwards?
post output from:
mhwd -l -li

in the /etc/default/grub on GRUB_CMDLINE_LINUX_DEFAULT
The ran sudo update-grub

so post logs from the failed boot:
journalctl -b-1 -p4 --no-pager

it returns:

No journal files found
Data from the especified boot (-1) is not available: No such boot ID in journal

i thought you are in chroot… so are you normally booted with 5.15 kernel now?

Well, i am in chroot O.o
The system still does not boot
The current status is a clean install of 21.1.0 (linux61). This does not boot.
i’m chrooting from a 515 majaro image, since the linux61 ISO does not find my boot ssd :confused:

well it should shown the logs from the failed boot…
try enable early loading:
nano /etc/mkinitcpio.conf
and edit the modules section to look like this:

MODULES=(i915 nvidia nvidia_drm nvidia_uvm nvidia_modeset)

save it with ctrl+x press ‘y’, then enter and update it:
mkinitcpio -P
if no errors, exit chroot, reboot and test if you can boot …

So is it right that you can install (and it fails to boot) but from liveUSB you can’t find the drive afterwards? It does not make much sense

No effect.
It generated with no problem, rebooted, but still it goes to the emergency shell.
It shows:

device UUID=<uuid> not found. Skipping fsck
mount: /new_root: can't find UUID=<uuid>
You are now being dropped into an emergency shell.
sh:can't acess tty; job control turned off

Yes, the liveUSB finds it if the SSD is formatted or with another system. After installing linux61, it vanishes from it. It still shows up on a linux515 liveUSB.

so there were here recently similar issues with cant find uuid, and downgrading mkkinicpio helped, so give it a try:

How do you check if the drive is available? Do you use btrfs as the bug that brahma points out?
I have a hard time believing that the drive completely/physically disappears depending on the file system of one of the partitions on it.
Use lsblk -f or fdisk -l to list drives and partitions when you are in the liveUSB with kernel 6.x

Downgraded to version 34 (current is 35.1), them to version 30. Still the same.

Well, i have two SSDs on this system, both PCIe. Only one shows up at a time. Right now the 512GB (The one with the linux) is showing up and i can even chroot into it. The 256 with the windows is absent. Last two times i booted with the liveUSB only the 256 showed up O.o

are you on raid or ahci? post output from:
inxi -R
post also the lsblk and fdisk outputs as requested above;

12Message No RAID data found

The other SSD is missing from those as well.

I just checked in bios as well, mode is set to AHCI