System will not boot after installing kernel 6x, or clean install

what lspci | grep memory shows?

The SSDs are the same model, different sizes (512 and 256)

Check the journal of the liveUSB to see if there is some error or information on the matter

journalctl -b


It should be much longer. You can upload entirely with:

journalctl -b | curl -F "sprunge=<-"


Ok. So don’t know why but you have this old problem. It seems that solution is to add:


as a kernel boot parameter

Just add to the grub file right?
If so, the system still does bot boot, and liveUSB does not see both disks :confused:

  1. chroot to your Manjaro: manjaro-chroot -a
  2. modify /etc/default/grub and add the boot parameter
  3. run update-grub
  4. reboot

The liveUSB has its own grub, kernel and parameters. You can edit boot parameters pressing letter e when you have one of the “Boot with …” entries selected. Actually the same can be done for your main system if you want (only affects that particular boot)

Exactly what i did, still no boot.

Ok. My bad. I looked too fast to the logs. It’s not the same problem that I mentioned. It seems to be something related to this other problem.

You also have two A-DATA drives, even if they are not exactly the same:

  Local Storage total 744.23 GiB used 9.19 GiB (1.2%)
  ID-1 /dev/nvme0n1 vendor A-Data model IM2P33F3A NVMe 512GB size 476.94 GiB speed 31.6 Gb/s
    lanes 4 serial <filter> temp 30.9 C
  ID-2 /dev/nvme1n1 vendor A-Data model IM2P33F3A NVMe 256GB size 238.47 GiB speed 31.6 Gb/s
    lanes 4 serial <filter> temp 28.9 C

And you have the same error in your journal:

May 15 18:39:29 manjaro-gnome kernel: nvme nvme1: globally duplicate IDs for nsid 1

But if this is really the problem I’m not still sure what’s the best approach to solve it. The only solution I found is to build your own kernel with a custom patch. Or to just use kernel 5.15. It’s going to be same with any other Linux distro.
It seems to be caused by a hardware vendor (A-Data) error.

1 Like

That did it man.

I pulled the 256 SSD out of the system, and it booted right up.
I also reinstalled the system to verify that it was not a combination of something we did and the lack of the other SSD. It works perfect now.
This laptop belongs to the company i work for, and i belive we have some Kioxia SSDs in our IT inventory, this should solve the issue for good.

Thanks very much sir! :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.