Syncthing and fstab mounts

I am trying to mount some disks automatically at start-up with UID=1000 and GID=1001, but my system goes into rescue mode if I have this in fstab:

UUID=xxxx /run/media/username/Data\040Drive ext4 defaults,UID=1000,GID=1001 0 4

but it works if I edit it to

UUID=xxxx /run/media/username/Data\040Drive ext4 defaults 0 4

why can I not specify the UID and GID?

Why would you want to specify uid and gid?

There is absolute no reason when the filesystem is ex4.

Perhaps you should define ext4 instead of ext - that doesn’t change the opion on the needles assignment of gid and uid.

Typo: it is actually ext4.

I want it because syncthing@$USER cannot access the disks. I have tried the following commands:

chown $USER:$USER /path
chmod 755 /path

but the syncthing@$USER keeps throwing a permission error.

PS: Godt at se du har det godt, @linux-aarhus. Lange siden sidst =))

you should only run the syncthing service as a user service - so whatever your user has access to the syncthing service as access to

systemctl enable --user syncthing.service

I am using syncthing to sync my app and backend to the production server


Hi @Centaro,

I use syncthing and all my partitions are ext4 mounted VIA systemd units but doesn’t have the GIS and UID options, so there’s something else amiss.

This is clearly an XY problem. To be able to help, we’d need to know what is the problem exactly. So please share the exact problem.

:bangbang: Tip: :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Those are intended for and supported only on filesystems which do not support UNIX file ownership and permissions, such as ntfs or vfat. Please read through the following tutorial and bookmark it… :point_down:

ext4 is a Linux-native filesystem and therefore it should not be mounted with those options — nor are they supported, as the system clearly refuses to mount them when you set those options.

I am not familiar with that software, but you should bear in mind that if the mountpoint is somewhere under the /run hierarchy, then those permissions will probably not be saved due to the fact that /run itself is a tmpfs — which is also explained in the above-linked tutorial — and therefore, the contents of /run do not persist across reboots.

Perhaps the following tutorial will also be of use to you… :point_down:



Solved the root problem in Syncthing it by going into Settings > General > Edit folder defaults > General > Folder path and setting the path to the mount point for the drive.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.