Syncing manjaro repos using pacman (timeout)

When I try to sync manjaro repos or install a package using pacman or yay

sudo pacman -Syu

outputs this error:

error: failed retrieving file ‘core.db’ from : Resolving timed out after 10000 milliseconds

I thought it was a mirrors problem, so I used

pacman-mirrors -g

to arrange mirrors list and the error is still showing
my internet connection is good, I verified it with ping
and also when I try to use pamac it works fine
so what is the problem ?

sudo pacman -Syyu to force a new package database.

1 Like

The mirror might be down.

sudo pacman-mirrors -c all && sudo pacman-mirrors -f 10 && sudo pacman -Syu

Same problem :frowning:

Same problem appears :frowning:

Same mirror and same error?

sudo pacman-mirrors -i

and choose decent mirrors.

Not same mirror, the mirror changed but the same error appears

In general this error says that there is a problem with the DNS. It cannot resolve the IP of the Domain. Check your Nameserver.

The content of /etc/resolv.conf is

# Generated by NetworkManager
search home

The mirror answers as expected.

I am 99.99% you are using an old 32-bit Manjaro - correct?

If you run below command and the output says i686 then you are using Manjaro32

uname -a

If so you will never be able to sync because Manjaro32 has been discontinued for good.

There is no repo - nothing - zero - zilch - nada.

Only option is to convert your Manjaro32 to Archlinux32.

This is the output of

$ uname  -a
Linux Lenovo-Z51-70 5.8.6-1-MANJARO #1 SMP PREEMPT Thu Sep 3 14:19:36 UTC 2020 x86_64 GNU/Linux

The opertions done by pamac is working, the problem is with pacman only

pamac update 

works fine

pamac is using the same mirrorlist as pacman

This is a valid architecture for Manjaro.

What is the content - if any - of

cat /var/lib/pacman-mirrors/custom-mirrors.json

What is the result of running

sudo pacman-mirrors -g

Just first three to seven lines

~ >>> sudo pacman-mirrors -g
::INFO Downloading mirrors from
::INFO Using custom mirror file
::INFO Querying mirrors - This may take some time

There is no custom-mirrors.json file

The result of

$ sudo pacman-mirrors -g 
::INFO Downloading mirrors from
::INFO Using default mirror file
::INFO Querying mirrors - This may take some time
  ..... Australia      :
  ..... Austria        :
  ..... Austria        :
  1.411 Austria        :
  ..... Bangladesh     :
  ..... Belarus        :
  ..... Belgium        :
  ..... Belgium        :
  ..... Brazil         :

You said that if pamac works then there is no problem in mirror list, right ?
@megavolt said it is a DNS problem how is that ?

You appear to be on a slow network connection as the default timeout of 2 seconds is not enough.

I don’t think so - the resolving of mirrors is OK even the dots - and only occational response time.

With your network connection it may be necessary to lower the bar - so to speak - as in increasing the timeout - e.g. use 5s instead of the default 2s

pacman-mirrors -g -t5

And to avoid doing the #! you could limit the query by using

pacman-mirrors --continent --timeout 5

Sorry this also didn’t work :frowning:

In /etc/resolv.conf, try to set directly the nameserver to
(or whatever DNS you like).

This is my resolv.conf:

# Generated by NetworkManager

Maybe your modem is not routing DNS requests properly.

I configured the resolv.conf file but this didn’t solve the problem :frowning:

How I can fix that

Have you reboot your machine, after you edited resolv.conf ?

And… If you click on this link in your browser:
does the site open?

When I rebooted, the resolv.conf reconfigured automatically by network manager

The website opened normally but redirected me to and I can manually go to the rest

Any help please ? :frowning: