Failed to synchronize all databases

I am actually using Manjaro for the first time via VM
As fresh start need to make some commands like :
‘sudo pacman -Syy’
‘sudo pacman -Syu’
but I encounter some problems I tried to give the maximum informations here throught this :
(tried to put all the logs but can’t post link tried to use a past link still cannot)
What Terminal shows and what are the Lasts mirrors I am using.
I have this follow error at the end
error: failed retrieving file ‘multilib.db’ from ‘LINK’ : Resolving timed out after 10004 milliseconds
error: failed to update multilib (download library error)
error: failed to synchronize all databases
Hoping somebody can help,
Thanks also for your time!

Do you have internet connectivity?

1 Like

Yes I verified by the command : ping (websites)

try sorting the mirrors first:

sudo pacman-mirrors -f && sudo pacman -Syyu

Back after this command so the actual results are :
error: failed retrieving file ‘multilib.db’ from LINK : Resolving timed out after 10000 milliseconds
error: failed to synchronize all databases

Can you show us a bit more … like which mirror is in use ?

Can’t i am not able to post link but actually using a lot and all of them have this same message and can’t post also a media for now

The first thing you need to do is establish your active pool of mirrors using

pacman-mirrors -c COUNTRY,COUNTRY…

To find a list of valid COUNTRIES

pacman-mirrors -l

Check the status of these mirrors go to The must be up to date. If not, either try again later or add more mirrors to your active pool.


The active pool of mirrors is located at “/var/lib/pacman-mirrors/custom-mirrors.json”. I like to refer to “/etc/pacman.d/mirrorlist” as the filtered run-time mirrorlist.

1 Like

Thanks for you answer too, yeah I just tried it still the same Error, I thought i couldn’t reach the servers so I pinged thoses and every server answered I did your manipulations but still Resolving Timed Out after …
Error: Failed to update
Error: failed to synchronize all databases
here is a link to the errors :

It seems you are only querying ftp mirrors?
Lets try again with resetting everything:

sudo pacman-mirrors --country all --api --protocols all --set-branch stable && sudo pacman -Syyu

I will try it I will keep you in touch in few of what’s happening

here you go, that didn’t work
Details :

  1. Edit “/etc/pacman-mirrors.conf”
  2. Uncomment Protocols and change it to Protocols = https
  3. Save it and run pacman-mirrors -c Austria,Germany,France
  4. Now run the commands that @cscs mentioned in #3

NOTE: Change the country list as you see fit. You can get a list of valid countries with the command pacman-mirrors -l or the long form pacman-mirrors --country-list. At this point limit the set of mirrors to a small number, just so focus can be brought to the problem.

My Snippet: pacman-mirrors -c Austria,Germany,France
  1.645 Austria        :
  1.607 France         :
  0.850 France         :
  1.173 France         :
  ..... France         :
  1.099 Germany        :
  1.020 Germany        :
  ..... Germany        :
  1.226 Germany        :
  2.326 Germany        :
  ..... Germany        :
  1.898 Germany        :
  ..... Germany        :
  0.892 Germany        :
  1.935 Germany        :
  0.920 Germany        :
  0.866 Germany        :
My Snippet: grep Server /etc/pacman.d/mirrorlist
Server =$repo/$arch
Server =$repo/$arch
Server =$repo/$arch
Server =$repo/$arch
Server =$repo/$arch
Server =$repo/$arch
Server =$repo/$arch
Server =$repo/$arch
Server =$repo/$arch
Server =$repo/$arch
Server =$repo/$arch
Server =$repo/$arch
Server =$repo/$arch
Server =$repo/$arch
Server =$repo/$arch

One thing I don’t understand. I’ll take one mirror from your output:

## Country : Ukraine
Server =

I assumed this was the content of your “/etc/pacman.d/mirrorlist”. But in my “/etc/pacman.d/mirrorlist”, it looks like:

## Country : Ukraine
Server =$repo/$arch

Where’s the stable/$repo/$arch go? :slight_smile:

I know this entry is old, but the original problem was Resolving timed out, or maybe this entry.

@thunder, in this forum (I searched for “resolving timed out”), found a solution:

There’s some hits in the archived forum too.

There is a wiki page, pacman troubleshooting, but unfortunately it doesn’t contain this issue.

@maminelahiala I can’t wait to hear what your final resolution turns out to be.