Syncing manjaro repos using pacman (timeout)

@thunder, I’m searching for a solution, but your problem is very peculiar.
I found this post on ubuntu forum.

You are right: etc/resolve.conf will be overwritten at every reboot.
Maybe you can edit /etc/systemd/resolved.conf and, at the beginning, decomment the line:


But, at first, please perform a system backup. This solution was for Ubuntu and has not tested in Manjaro.
I don’t have the linux skills yet to be able to guarantee that everything will be fine.

On my laptop, I would try. I like test and see whether or not it works.
It’s up to you. :innocent:

1 Like

To change only DNS, the easiest method is probably just this: How on earth do I set Manjaro to use Open DNS?

1 Like

Thank you for replay, I Changed the DNS from settings to and rebooted the system
/etc/resolv.conf output:

# Generated by NetworkManager

This also didn’t solve the problem :frowning:

Please post your:
cat /etc/pacman.conf

1 Like
$ cat /etc/pacman.conf
# /etc/pacman.conf
# See the pacman.conf(5) manpage for option and repository directives

# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
CacheDir = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg      = pacman glibc manjaro-system
# If upgrades are available for these packages they will be asked for first
SyncFirst    = manjaro-system archlinux-keyring manjaro-keyring
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

#IgnorePkg   =
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
# We cannot check disk space from within a chroot environment

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Manjaro Linux
# packagers with `pacman-key --populate archlinux manjaro`.

#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

Your pacman.conf is ok.

In this old thread in French, an user had your exact same problem as you.
Pamac was ok, but not pacman or yay.

Misteriously, after the next update (with Pamac), all was ok.
(Moreover, our @papajoke partecipated to that conversation)

I’m sorry, but I am out of ideas. :thinking:
You should wait someone to find some other solution, or wait to the next update e cross your finger. :wink:

1 Like

pamac and pacman are different

  • pamac use its own dload function which uses soup_session
  • pacman use its own dload() function which uses curl lib by default , have 1000 as timeout

why curl have a problem … :thinking:
it would be good to test an http server (without s)

ps: for view pacman config with mirrors , we have pacman-conf command :wink:

1 Like

I tried using http and it didn’t work :frowning:

I also tried to reinstall curl and did’t work too
Could I increase curl timeout or shift pacman to use something else ?

Finally, I was able to solve it by uncomment this line in /etc/pacman.conf file

XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u

But what is actually mean :sweat_smile:

I’m happy for you!
Whith that command, you use wget to download from the server.
Usually XferCommand doesn’t work very well (for me either).

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.