Stuck on login screen after running startx

This is somewhat of a silly problem. I wanted to change the directory to which my terminal defaults. A different thread stated to enter the directory, then run startx. I did so, not knowing the purpose of said command, and it sent me straight to the “Plasma by KDE” splash screen where it so froze. I shut down my pc, and attempted to restart. Manjaro boots normally and I’m prompted with a login screen, on which I enter my password and it freezes yet again. I’ve tried to look up a few threads on this issue before, but all seems to have installed a new kernel or update, which I have not. I’m booting off of a hdd, so at first I figured it might just be slow to boot, but trying to restart again the same problem presents itself. If it is of any help I’m able to access the terminal through ctrl+alt+F2. Any help would be appreciated!

1 Like

If you change to the terminal as you said(Ctrl+Alt+F2) you should be able to use startx to get back to your desktop. From there it will be easier to diagnose what could have happened.

I am not very familiar with how KDE Plasma works around startup, but maybe running startx while the xserver is running resets some defaults or something? In both Gnome and Cinnamon(which I have used) I have always gotten an error message when trying to run startx from a tty where xserver is running.

I’ve tried running startx from the terminal with mixed results. Usually it returns an error, one time it froze the terminal and one time it worked. I’m not sure what the command does, I just executed the command from the thread (learned my lesson, won’t do it again), but after some reading it seems to be starting some X11 server. It did give me trouble at first so I ran it as sudo and that’s when it crashed my desktop.

Okay, I understand.
startx starts the X11 server which I assume is the display manager you are using. I don’t understand how that would start your install form freezing on every login though.

Do you know what the default display manager for your system is? Is it Wayland or X11? you can check by running inxi -G and checking the output on the second line, after Display. Could you post your output from that command here?

Of course the two might very well be unrelated, and the freeze completely coincidental, but I thought to at least mention it, it being the last thing I changed before the freeze.

Line two returns some hardware specs, but on line 4 it says Display: x11 server: 1.20.11. I’m assuming this is what you were looking for?

I just remembered making a change in the grub config file as well, removing the “quiet” keyword from the boot command. This I did in the same session as I launched startx, but I can’t imagine it having an impact on this.

I just happened to reach the desktop (after running a series of commands ending with startx), but I don’t think it’s consistent. It seems my system doesn’t like it when I manually start the displaymanager, and so I’ve struggled to get it back to normal. Is there a way to reset x11 to system defaults or anything similar?

  • Restoring your last system backup is going to be easier to do by this time.

  • If you don’t have one, please start making one right now.

  • Next step would be to create a new user in TTY2 and log in there and see if that has the same problem. If it doesn’t, shout out!

  • If is does, remove the plasma desktop entirely and reinstall, all from a TTY:

    pamac --remove plasma-desktop
    pamac --install plasma-desktop
  • If even that doesn’t work, remove the plasma-desktop with all its config files by adding --no-save to the pamac

  • If even that doesn’t work:

    • wipe everything
    • reinstall
    • restore your data backup
    • make a new Cold System Backup.


Please excuse my ignorance, but how do I make a new login from tty2? It’s prompting me for login credentials, but I’m not sure how I can make new ones.

I do not have a backup, I’ll read the tutorial you posted. I know it’s stated the backup should be on a different drive, but as I only have two, whereas just one of them has free space, would a separate unmounted partition be sufficient? How big should this be?

Would removing the plasma desktop also wipe my saved data and settings?

Everything works after making a new user! How would I go about either fixing my old one, or giving the new one the exact same access as the first?

  • After pressing Ctrl+Alt+F2 and logging in there, execute:

     useradd nuddel2

    Where nuddel2 is obviously the new user name.

  • Verify that the new user has access to the same groups as your old one by executing groups and comparing the output of both users.

    groups nuddel
    groups nuddel2

    (Where obviously, nuddel is your old user and nuddel2 is your new one.)
    E.G. if nuddel is a member of operator and nuddel2 isn’t, execute:

    usermod --append --groups operator nuddel2
  • Ask one of your friends if they have an old HDD lying around and buy a 12€ SATA-USB converter. (they look ugly, but they’re dirt cheap).
  • Buy an external USB HDD

Maybe… That’s why I told you to back up and why you should have backed up in the first place! :innocent:

If you follow my instructions carefully, they won’t delete any user data in the above section, but looking at the situation you’re in, I’m not taking any responsibility for any mistakes you might make… :upside_down_face:

If adding a new user fixes the problem, follow this:

  • log into TTY2 as the new user (don’t forget the old user is borked)

  • Copy all data files from your old profile into your new one

    cp --verbose --recursive --preserve=timestamps /home/nuddel/Documents/* /home/nuddel2/Documents/

    If that worked and you had no errors, remove the documents from your old user:

    rm --recursive /home/nuddel/Documents/*

    repeat for:

    • Pictures
    • Videos
    • Music
    • .thunderbird
    • .mozilla/firefox/
    • Templates, and everything else that is important to you.
    • Linux games like Battle of Wesnoth have their game data stored under ~/.local/share/ E.G. ~/.local/share/wesnoth/
  • After everything has been copied over, disable the old user so you cannot accidentally log on to it any more:

    usermod --lock twitty
  • If you would have theming going on, don’t do everything in one day but do this at the rate of 1 application / theme / whatever per day and if the same issue crops up again, roll back your last change and thus you’ve now pinpointed the exact setting that made your old user misbehave. :thinking:

  • in 1 month delete the entire home directory of your old user, but don’t delete the user itself so that in 6 months time, files still owned by that user will still show up under its username.

  • If you ever migrate to a new machine, just don’t migrate the old user: only the new one.

  • From now on, start making backups so you can roll back and never have to do this again:


I’m sorry for continuing to bother you, but I ran into an issue. As already mentioned, making a new account worked wonders. I’m in the process of copying the data, but ran into a problem. First of, the command didn’t work. I figured, no biggie, looked it up and removed the hyphen in time-stamps. Great, the command works. I tried running it with sudo rights, but it returns that /home/myuser/Documents/* is no valid location. I tried replacing * with . which worked, but checking the contents of the Documents, the folder is empty. I’m really at a loss here, any suggestions?

  • My apologies for the - between time and stamps; that was a copy-paste error from my side.

  • I’ve just tried:

    cp --verbose --recursive --preserve=timestamps Documents/Admin/* /tmp/Admin/

    and that just works and:

    $ sudo cp --verbose --recursive --preserve=timestamps /home/fab-user/Documents/Admin/* /tmp/Admin/

    works too

so can you give me the full output of the command together with the directory you’re standing in?


I’m sorry, shouldn’t the account both from and to which I’m copying be specified? I’m doing this from the TTY2 prompt logged in as the old user, though I suppose I could do it from the terminal on the new. What are these Admin and tmp directories? I trust it to be working, but out of curiosity; in the first command, where are the users specified? How does the system know to copy from nuddel1 to nuddel2? And where do you specify that the contents of nuddel1/Documents should be copied to nuddel2/Documents? Again, I trust they work, just curios as to how they’re composed

Stop using that one! It’s borked! Sorry for not mentioning this before, updated now

They are directories on my machine that allow me to test the exact command you need to be typing and the original is working on my machine, so you should follow the original solution and adapt it to your specific needs as you never gave me the exact old and new usernames, so I can only give you multiple examples. :sob:

  • I used nuddel as that’s what you took as a username here on the forum… :man_shrugging:
  • If you: I can give you the exact command to type on your system.


I see, thank you. I ran both the commands (exactly as you wrote them) and this was the output:

[matsb2@mats-hppavilionnotebook ~]$ sudo cp --verbose --recursive --preserve=timestamps Documents/Admin/* /tmp/Admin/
cp: cannot stat 'Documents/Admin/*': No such file or directory
[matsb2@mats-hppavilionnotebook ~]$ sudo cp --verbose --recursive --preserve=timestamps /home/fab-user/Documents/Admin/* /tmp/Admin/
cp: cannot stat '/home/fab-user/Documents/Admin/*': No such file or directory

Thank you for taking the time to help me.

My apologies for confusing you!

From this:

I can see you need to forget about the Admin example and go back to the original and type this:

cp --verbose --recursive --preserve=timestamps /home/matts/Documents/* /home/mats2/Documents/

and then move onto Pictures, Videos, …

That’s what I tried at first, but this returned:

[matsb2@mats-hppavilionnotebook home]$ sudo cp --verbose --recursive --preserve=timestamps /home/matsb/Documents/* /home/matsb2/Documents/
[sudo] password for matsb2: 
cp: cannot stat '/home/matsb/Documents/*': No such file or directory

so if you did not verify and deleted already, then

is absolutely normal and why I said:


What is the output of:

du --human --max-depth=1 /home/matsb2/


I have not yet ran rm --recursive /home/matsb/Documents/*

You have been a great help to me so naturally I’m nothing but thankful and I do not blame you for anything that happens. Your help is greatly appreciated. The command returned this:

[matsb2@mats-hppavilionnotebook /]$ du --human --max-depth=1 /home/matsb2/
4,0K    /home/matsb2/Templates
43M     /home/matsb2/.mozilla
195M    /home/matsb2/.cache
864K    /home/matsb2/.local
1,4M    /home/matsb2/.config
32K     /home/matsb2/.kde4
4,0K    /home/matsb2/Pictures
4,0K    /home/matsb2/Documents
4,0K    /home/matsb2/Public
8,0K    /home/matsb2/Desktop
4,0K    /home/matsb2/Music
4,0K    /home/matsb2/Downloads
4,0K    /home/matsb2/Videos
240M    /home/matsb2/

I assume this is a way of checking the contents of a folder. If I run the same command, but for the old user, this is the output:

[matsb2@mats-hppavilionnotebook ~]$ sudo du --human --max-depth=1 /home/matsb/
[sudo] password for matsb2: 
4,0K    /home/matsb/Templates
210M    /home/matsb/.vscode
8,0K    /home/matsb/.oracle_jre_usage
47M     /home/matsb/.mozilla
56K     /home/matsb/.texlive
12K     /home/matsb/Arduino
852M    /home/matsb/.cache
1,6G    /home/matsb/.local
1006M   /home/matsb/.thunderbird
168K    /home/matsb/.java
392M    /home/matsb/.config
32K     /home/matsb/.kde4
76K     /home/matsb/.pki
12K     /home/matsb/.gnome
16K     /home/matsb/.steam
4,0K    /home/matsb/Pictures
4,0K    /home/matsb/Documents
4,0K    /home/matsb/Public
24K     /home/matsb/Desktop
12K     /home/matsb/.arduino15
118M    /home/matsb/.cpanm
408K    /home/matsb/.lyx
264K    /home/matsb/perl5
4,0K    /home/matsb/Music
387M    /home/matsb/Downloads
4,0K    /home/matsb/Videos
4,6G    /home/matsb/

Both seem to contain some folders. Every folder on the new user is empty, and I haven’t cleared any of the folders on the old user.

The Documents folder is empty on both users so I think it might be a bad example. If I try to copy a directory I know contains files, like the downloads folder, this is the result:

[matsb2@mats-hppavilionnotebook ~]$ sudo ls /home/matsb/Downloads/
arduino-1.8.15-linux64.tar.xz  discord-0.0.15.tar.gz  grub-customizer_5.1.0.tar.gz  Simplenote-linux-2.15.0-x64.tar.gz  yay-git  yui.png
[matsb2@mats-hppavilionnotebook ~]$ sudo cp --verbose --recursive --preserve=timestamps /home/matsb/Downloads/* /home/matsb2/Downloads/
cp: cannot stat '/home/matsb/Downloads/*': No such file or directory
[matsb2@mats-hppavilionnotebook ~]$ sudo ls /home/matsb2/Downloads/
[matsb2@mats-hppavilionnotebook ~]$
1 Like

OK, so in all the years I’ve been giving these commands to anyone, you’re the first one whose documents folder is empty (for matsb that is, so indeed: that’s a normal error as 4.0 KB = just the directory name itself)


So skip that continue with:


I.E. for the first one:

cp --verbose --recursive --preserve=timestamps /home/matsb/Desktop/* /home/matsb2/Desktop/

I can also see that you have an enormous amount of data for the following hidden directory:

210M    /home/matsb/.vscode

Are you still in need of that? (Firefox and Thunderbird etc are already in the original Solution)

I downloaded this system a few days ago so I haven’t had time to fill it up yet :P. I noticed the command sudo cp --verbose --recursive --preserve=timestamps /home/matsb/Downloads/. /home/matsb2/Downloads/ did exactly what I wanted it to (I just replaced the asterisk * with a period .). Thank you a lot for all the help you’ve given me! Truly a lifesaver! Just a tiny note at the end, it wouldn’t be a problem to remove the --verbose keyword in the command, right? Some directories contain a lot of files and they spam my terminal. No big problem, but I’d like not having to list the directories of the old user every time I need to check what’s left to copy. Thank you!