Still Splash Screen: Unable to proceed to login screen

Screenshot Link:

Prior Actions: I was editing a file (and the computer kept on getting hotter and the fan spinned exhaustively) and then after finishing my file I saved it but I was unable to do so because an error appeared telling me that the disk is readonly. So I turned it off then on, after that I can only see a splash loading screen that does not continue to the login screen.

Solutions taken: Took the battery off and placed it back in and then turned on the laptop but the splash screen still persists. I also tried booting and tried entering the manjaro setting using F12 on boot but I am unable to go to the Manjaro settings screen and continues only to the splash screen.

Related Error Messages: I am unable to provide error messages since whenever I turn it on the only thing I can see is an infinite splash loading.

System Information:
Architecture: 64bit
Distribution: Manjaro lxce

Thank you and I aplogize for my earlier post because I am new to this forum. <3


Did you decide to share that link in that format as a revenge to the community of this forum? :upside_down_face:

Please read this

Edit your post and share the information accordingly.


I apologize for my mistake, I am new here and I have not yet read the terms and policies here so I am very sorry. I have updated my post to suit the forum’s guidelines. Thank you!

in the login screen can you enter TTY by pressing: ctrl+alt+f2, if f2 doesnt work, try f1-f6 keys instead of f2

Hello, I am unable to proceed to login screen. After turning on the machine it can only go as far as the splash screen and till there nothing happens. Thank you.

with splash creen you mean the logo of your pc? after the logo you get stuck in a black screen?

Yes the one with a Manjaro logo and a loading icon. It persists like forever, it does nothing but show the splash screen. Could you check on the screenshot I shared? Hope it could be of help to find out the issue. Thank you for the quick response!

so in the manjaro logo and a loading icon try entering TTY by pressing: ctrl+alt+f2, if f2 doesnt work, try f1-f6 keys instead of f2
the screenshot shows your bios boot settings, not really helpfull…

1 Like

I can actually use the BIOS setting and switch between them, and tried checking my ram and hdd for some errors as seen on my the screenshot I sent but I am not really good at them. Thanks btw for the help.

thats ok that you can switch, but that will not help you to boot into manjaro… so did you checked your hard disk for errors, as you mentioned above?

I’m unsure about it but I think my second HDD is corrupt because no name was shown after it so I kind of doubt it. Please advise. Thank you

If you installed the system in UEFI mode, then you should select the first entry in BIOS boot menu, that is the Manjaro. Booting from HDD1 i guess uses legacy boot if i’m not mistaken.

Once you select the Manjaro, try to press Shift and can you then select a different kernel from GRUB menu, or select the advanced option of fallback initramfs? Or maybe even press e to edit the boot and replace quiet with single then press F10 to save and continue booting. Once in TTY you should be able to perform a full system update, eventually startx as your user…

1 Like

Screenshot link:

Screenshot link on F12:

I made manjaro the primary boot order but I still don’t know why nothing works as of the moment. Shift and pressing e does not give any response :frowning: . Thank you !

  1. what exactly did you did, what file were you editing etc…?
  2. try repeatedly tapping esc during boot and see if that gets you into grub menu
  3. in the manjaro splash press ctrl+alt+f2, if f2 doesnt work, try f1-f6 keys instead of f2
1 Like

I am actually a web designer so I was editing text files like css. I forgot to mention them. Thanks for informing and the ESC key did the work now I am on the Manjaro setting screen. How should I proceed? Thank you very much!


so try selecting a different kernel in advanced options, if you dont have try the fallback one … then press E and replace quiet with single, then press f10 to save and boot… if you get stuck on the splash screen press: ctrl+alt+f2, if f2 doesnt work, try f1-f6 keys instead of f2
also take a picture of the logs and post it here

1 Like

Thank you very much for the help. After clicking f2 on splash screen I’m redirected to the console with logs. I was able at first get to the ui version but now I can’t instead I get this. Please guide.


Tried running fsck /dev/sda2


you cant enter into tty according to logs
your file system got corrupted, run this command as it suggest in the logs:
fsck /dev/sda2/

1 Like

did you pressed ‘y’ yes during the check?