Stange flickering of the whole session, and periodic dimming of the display's backlight: Acer nitro 5 (ryzen 4000 + nvidia)

Specs: Acer Nitro 5 AN515-44
OS: Manjaro Linux x86_64
Host: Nitro AN515-44 V1.01
Kernel: 5.8.16-2-MANJARO
Shell: zsh 5.8
Resolution: 1920x1080, 1920x1080
DE: Plasma 5.19.5
WM: KWin
CPU: AMD Ryzen 5 4600H with Radeon Graphics (12) @ 3.000GHz
GPU: AMD ATI 05:00.0 Renoir (integrated GPU)
GPU: NVIDIA 01:00.0 NVIDIA Corporation TU117M (nvidia GeForce GTX 1650, with the proprietary driver: video-hybrid-amd-nvidia-455xx-prime)

I am experiencing some very weird screen flickering issues, that happen periodically about every 2 seconds. I have recoded it with my phone in slow motion to help me debug it better, as to my eyes it looks like a quick flicker.

To me this looks like the Xorg session spazzing out, and simultaneously the screen’s backlight dims for a brief moment.

This is happening with the default config that mhwd set up, as well as the live usb, although right now I have set up optimus-manager to be able to switch to the nvidia GPU only, as the HDMI output only works in this mode.

The weirdest behaviour is that this happens always when it’s running from the integrated graphics only, and in hybrid mode, and more often than not in the nvidia only mode as well.
However, if I reboot a couple times to the nvidia-only mode sometimes it fixes itself, if not, then when I plug in my second monitor, then it fixes itself, and if still not, then a reboot to the hybrid mode and then again to the nvidia mode, then it’s fine like 3 of 5 times.
And when it’s working, then it words fine… until I turn the laptop screen off, and then back on (either by it timing out or closing the laptop lid), then even in nvidia-only mode, the flicker is back, until I go through the rebooting trial and error bit again.

This was happening with the 450 nvidia drivers, as well as the new 455 drivers.

I have checked out a few more distros, to see if this is a manjaro-only problem, and I have found that while on Linux Mint there is no weird flickering, I can not adjust the screen brightness, and it’s stuck to max value.
EndeavourOS has the same issues as manjaro

I’m not sure how even I would go about debugging this.

I’m reasonably tech and linux savvy, but I don’t know what log files I would need to have a look at.

$ mhwd --listinstalled
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-amd-nvidia-455xx-prime            2020.10.04               false            PCI
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Also, when trying to switch from nvidia-only to integrated-only or hybrid mode, the screen is just black, and when switching to the second TTY, it says this: Imgur link:

[   285.136172] [drm:dpcd_set_source_specific_data [amdgpu]] *ERROR* Error in DP aux read transaction, not writing source specific data

I’d appreciate some guidance with this.

:+1: Welcome to Manjaro! :+1:

Have a look at my profile and then try video-hybrid-amd-nvidia-440xx-prime first and video-nvidia-440xx next.

Please feed back after that…


Unfortunately they both exhibit the exact same behaviour as 450 and 455.

xrandr output when it’s happening, please?

First two are from when it’s working, last 2 from when it’s not:





  • So it’s happening on both monitors when they’re connected or just one of them?
  • Can we have a xrandr --verbose or the brand and type of both monitors?
  • Can you unplug the second monitor from power and see if it still happens on the first one?


1 Like

Internal screen is probably the AMD, so can you try 2 things:

  1. Install kernels 5.4 LTS and 5.9
  2. If the above didn’t change anything, try the same frequency as the external monitor: 60Hz and the highest resolution I can find that has the same frequency is 1440x810 60Hz.

You unplugged the external monitor from the power socket, right? (HDMI connection doesn’t matter)

This is a weird problem.

  1. On 54, sddm fails to start, systemctl status: sddm crash linux54 -
    On 59, the problems are the same as 58.
  2. when I try to set the refresh rate of the laptop display (after boot when the external display is connected it is already set to 60hz [IIRC that’s because Xorg can’t mix refresh rates? is that right?]) when I set it up to 144 nothing seems to happen, but when I set it back down to 60hz it gets messed up: Imgur: The magic of the Internet
    the second monitor is not messed up, and I can use t to set the laptop display back up to 144hz, that fixes it
    although I suspect it’s lying and when it says 144, it’s not actually 144, at least when the external monitor is connected.
    When I tried to change the resolution of the laptop display it just turned off, and I needed the second monitor to disable and then re-enable the laptop display in KDE’s Display settings.

the flickering is sill there after changing the refresh rates about.

I did unplug the second monitor from the power outlet yes.

One last favour and then I’m all out of ideas:

  • Create a new user
  • log in there
  • see if it happens there too.


Yeah that didn’t work unfortunately
It also happens there, as well as sometimes sddm.

1 Like

I’m throwing my hands in the air, my apologies I’ve been of absolutely no help…

:sob: :man_shrugging:

thanks for trying anyway.
Maybe someone else has a clue

1 Like

There has been a development

I have discovered that turning the screen off and then back on again with

xset dpms force off
xset dpms force on

fixes the issue, but this has to bee done every time it starts flickering, so after most reboots, and after closing and opening the laptop; so this is a relatively good workaround, at least no more rebooting sagas are needed to get it working.

Also, I just updated to the latest stable update ([Stable Update] 2020-11-04 - Kernels, Nvidia 455.38, LibreOffice, Plasma5, Frameworks, Apps, Gnome 3.38, Deepin), but that did not resolve it unfortunately.

1 Like

Try setting your “close lid” action to “nothing” because that sounds like that button malfunctioning…


Hello, I just got the same laptop, and the same situation happens to me, I’m using XFCE. I noticed that, when the laptop it’s working on battery mode, the flickering and dimming stops. Does this happens to you too? maybe it’s a power management thing.

another thing off topic, did you manage to update the bios?. when it starts. the acer screen stays longer than before installing linux, sometimes in the loggin screen I type the password, hit enter, and the loggin appears again, blank. wierd.

sometimes in the loggin screen I type the password, hit enter, and the loggin appears again, blank. wierd.

Exactly the same problem on my Acer Nitro 5 AN515-44! If you can find a solution, please text it to me, too :blush:
Although if I have some free time - I’m going to create a new topic for this problem with login.

For me running from the battery does not appear to stop the blinking unfortunately.

I did not know there was a BIOS update until now, so I haven’t tried it, but as far as I know these .exe BIOS updaters don’t go down well on linux, but correct me if I’m wrong on this.

I have figured out however, that the acer screen is shown while the GRUB bootloader waits out it’s 10 second timer, and can be shown by pressing esc on the acer screen, where you can boot other installed kernels for example. you can change the 10 second wait time, I have set it ti 1 second, so if I need GRUB I can still get to it, without wasting 9 seconds doing nothing;

If I remember correctly I changed a line in /etc/default/grub




then did a

sudo update-grub

Unfortunately this didn’t work either

I have since discovered, that turning the screen on and off, like I described above, when it is working correctly, makes it not work correctly, and it exhibits the same behaviour as when I described in the first post.
Turning the screen off/on repeatedly once again, fixes it after 1-3 tries.

Hello. I tried other kernels, and the issue stays the same, sometimes the laptop is ok, but when de screen is off and then back on, or when it’s on battery, and plugged in to the charger, the flickering appears… looks like there’s nothing else to do right now.

By the bios front, the update doesn’t fix the flickering, already tried, installed the latest but nothing.