Stable update feedback

Hi,

this Update produces many problems and unnecessary work - I´m more than disappointed (test on 4 machines).
No sound (pulseaudio), Grub resolution back to native, suddenly closed (crashed) apps, stops with blackscreen within shutdown, and so on - stable? Never - see above: 20% Users have issues,…!
What´s going on with manjaro?

Sorry my bad English, Rest native @ philm:

Hallo Philip, nicht jeder ist ein Linux-Nerd, freut sich aber, eine freundliche und stabile Alternative zu Windows gefunden zu haben… bisher hat das auch überwiegend gut funktioniert. Wenn jetzt ca. 20% der User Update-Probleme haben, ist das einfach zuviel. Wenn schon 440 Rückmeldungen da sind, teilweise mit identischen Fehlern, warum gibt es vom Development kein Feedback und Hilfe. Bespiel Pulseaudio: auch ich habe an zwei Rechnern keinen Sound mehr… downgrade pulseaudio hat nicht geklappt, die etc/pulse/default.pa erschliesst sich mir nur unzureichend… ?

Ich hab jetzt schon Stunden investiert, muß ich mich nach Alternativen “umsehen”?

Kann es sein, das der Aufwand mit ARM und PinePhone die Sorgfalt mindert?
Die Basis für den Erfolg von Manjaro ist m.E. PC und Notebook. Zum Thema Konvergenz ist doch Ubuntu Unity ein Lehrstück, oder?

Sorry wegen der Kritik, aber vielleicht besser als kein Feedback.

Gruß Michael

Sorry, aber ich antworte Dir auch mal, der Einfachheit wegen, in Deutsch.

Wenn 99% der Rückmeldungen keine vernünftigen Infos enthalten, ist uns das einfach zu viel.

Nur mal zu Dir - welche DE benutzt Du - welchen Kernel - welche Hardware hast Du … ?
Darüber hast Du kein einziges Wort geschrieben.

Installiere Dir hw-probe und starte es mit sudo hw-probe --all --upload
Dann schickst Du uns den Link, der Dir angezeigt wird und wir haben eine vernünftige Grundlage, um Dir helfen zu können.

Mit Sicherheit nicht, aber leider wird die Qualität der Rückmeldungen immer schlechter.
Mit Aussagen wie “Pulseaudio geht nicht mehr” können wir wenig anfangen.

Linux ist nicht Windows - es braucht schon etwas an Grundlagen-Wissen, damit das System stabil funktioniert.

1 Like

Vielleicht ist das die Ursache - ich habe schon weit mehr als 100.000 Stunden vor Computern verbracht :wink:

If your using Gnome GNU, Change the GTK3 Theme to some new 3.36 compatible or higher, as i had this problem, first i had the keyboard lag on some Apps/Programs then i changed my GTK3 theme that fixed the Keyboard Lag but then i had Apps closing for no reason, tried another GTK3 Theme and all seems okay now, Apps are stable now and Keyboard Lag is gone, i’m using a theme from Gnome look Org and the theme is called " Yaru-Colors".

But do have the Black screen flashing cursor with over 2 mins shut down time.

Also ich kann das grundsätzlich nachvollziehen, hier geht es ja nicht um Michaels Probleme mit pulseaudio, sondern schlicht darum, dass ein stable Update (mal wieder) für viele User ein “Downer” war. Das war in der Vergangenheit auch nicht anders, da war hin und wieder immer mal ein “Stinker” dabei und im Prinzip gab es jedes Mal in etwa die gleiche Diskussion. Meist unnötig emotional aufgeladen …

Ich nehme an, die Gründe sind immer noch die genau gleichen wie eh und je, eine super motivierte aber einfach zu kleine Schar benutzt testing (bitte bitte: das ist KEINE Kritik, einfach eine Feststellung), ob es automatisierte Test mittlerweile gibt, weiß ich nicht, oder ob es in den letzten 2 Jahren Änderungen am Ablauf gegeben hat. Ich weiß auch nicht, ob und was genau man bei einem Rolling Resease Modell sinnvoll an Q&A implementieren kann.

Für mich ist Manjaro stable immer ein “best effort” und ich nehme es wie es kommt, ich kann aber durchaus verstehen, dass jemand wenn er “stable” liest und einem ein “stable” Update hier und da einen digitalen Scherbenhaufen unterschiedlicher Größe hinterlässt den Begriff “stable” IMHO zu Recht hinterfragt.

@MichaelP: Manjaro ist IMMER bleeding edge, für eine stabile stabile stabile Arbeitsumgebung gibt es Alternativen …

1 Like

I understand the complexity of today’s combinations of hardware, software and options to configure an OS like Manjaro. So maintaining an OS like Linux/Arch/Manjaro can’t be that easy to begin with.

However, as far as the response to pulseaudio is concerned comparably a lot of people seem to struggle with it. So without knowing that much about what’s behind the entire audio-thing I guess that the problem comes from a more general part of it, which leads me to believe that it should be able to be fixed without too much individual pinpointing.

Personally I haven’t upgraded to 2020-11-04 because I already had my fair share of not working sound after an update several years ago that I finally fixed by completely reinstalling the OS. And there are already comments that downgrading to a previous version (don’t know which libraries are meant) doesn’t solve it. Seriously, I don’t want that to happen again to me.

I just hope to hear (pun?) that the problem got fixed in the near future :slight_smile:

Maybe we go for the stable release of Pulseaudio, which is still 13.0 and the older Pipewire 0.3.13-3, similar to the ARM versions, which needed to be hold back due to similar audio issues on the PinePhone.

FS#68485 - [pipewire] 0.3.14 breaks audio

Comment by AaronP (Bellum) - Tuesday, 03 November 2020, 09:32 GMT

Probably fixed by cherry-picking 6962c27af98c31374e8b349b8962b3b8a2b66be8

Comment by Ilya Fedin (ilya-fedin) - Saturday, 07 November 2020, 17:14 GMT

This is still valid, workaround is to change the last line of /etc/pipewire/pipewire.conf to exec /usr/bin/pipewire-media-session -d alsa-acp,alsa-seq

Please test pipewire 0.3.15-1 to see if that fixes your issue with audio.

Is a reboot required after upgrading to pipewire-0.3.15-1-x86_64?

Yes, a reboot is required as the system needs to load the proper libraries for that particular version.

Hi all,

thanks for understanding :relaxed:

@schinfo native: wegen der 100.000 Stunden hab ich sehr gelacht, o.k. - deine Entscheidung.
Ich denke aber, ich bin auch von Dir verstanden worden, ich hab mehrere Stunden nur in die Suche einer Lösung für die Pulse-Soundausgabe investiert - ansonsten sitze ich natürlich auch mehr, oft zuviel am PC.

Zur Qualität der Rückmeldungen
Ja, sicherlich sind die Meldungen oft für Devs unzureichend - aber der Audio-Ausfall tritt bei mehreren Rechnern auf und ist doch von anderen Usern sehr intensiv gemeldet worden…

Exemplarisch mal ein paar HW-Facts zu einem(!) meiner betroffenen Systeme:

AMD Ryzen 7 1700X
Board Gigabyte GA-AX370-Gaming 5
mit Soundchip Realtek Dual ALC 1220
Grafikkarte NVIDIA GTX 1080

Getestet hab ich zunächst die Soundausgabe nach Update mit Kernel 5.9.3, danach mit 5.8.x und zuletzt mit LTS 5.4 - einzige Wiedergabe-Option immer(!) Dummy-Output.

Final hab ich an diesem System testweise das aktuelle Live Image vom USB-Stick gebootet und Updates gestartet, selbst da keine Soundausgabe über den ALC1220, angeboten wurde nur HDMI3 (über NVIDIA - ist aber kein Speaker im Monitor :roll_eyes:).

Gruß Michael

Wir hoffen, den Fehler gefunden zu haben, da er nur stable betroffen hat.

Please test pipewire 0.3.15-1 to see if that fixes your issue with audio.

@schinfo:

hab die /Partition neu aufgesetzt, alle Updates eingespielt, Pipewire 0.3.15-1 ist installiert.
Sound, leider nein, Lautstärke bietet wie zuvor als Output nur HDMI3 der NVIDIA Karte an.

Die Systemeinstellungen zeigen noch Family17 HD Audio Controller an, ist aber nicht aktivierbar.

Hab HW-Probe installiert und ausgeführt, anbei der Link:

https://linux-hardware.org/?probe=db3db2dc65

Ist das so o.k.?

Gruß Michael

If you look at the mixer log, you see that all internal soundcard ports are turned off: https://linux-hardware.org/index.php?probe=db3db2dc65&log=amixer See also here: Lei Mao's Log Book – Ubuntu 18.04 LTS No Sound Fix

@philm: Thanks, but what is to do now?

in Alsamixer I could select the Soundcard (F6 - HD-Audio Generic) and activate all the sliders (set from MM to a concrete volume, for me S/PDIF is necessary) - but nothing happens.

In Audio (Lautstärke 1.0.0) there is only one Output slider for HDMI3 and in the register “Erweitert” the Familiy 17 HD Audio Controller is “Aus”, nothing else could select.

Gruß Michael

@philm: I look for Lei Maos Link, no functional workaround (switch desktop speaker)…
I could unmute and increase all output sliders in Alsamixer, and I save them with alsactl.
Nothing helps :hot_face:

I made a snapshot, but upload it seems not allowed.

Greetings Michael

The onboard audio device has the same Vendor and Product ID [1458:a0b8] as the audio device on motherboard GA-AX370 Gaming 5 mentioned in this forum discussion: No sound after upgrade

The device has a kernel patch for the dual codecs
ALSA: hda - Support Gigabyte Gaming board with dual Realtek codecs - Patchwork
The patch mentions a Use Case Manager configuration
check if package alsa-ucm-conf is installed to provide the UCM configuration file /usr/share/alsa/ucm2/HDA-Intel/HDAudio-Gigabyte-ALC1220DualCodecs.conf

The Lei Mao blogpost ‘Successful Solution’ was to edit file /usr/share/pulseaudio/alsa-mixer/paths/analog-output-lineout.conf
But the mixer path configuration files are in a different location on Manjaro
The configuration file from package alsa-card-profiles is located at /usr/share/alsa-card-profile/mixer/paths/analog-output-lineout.conf

@nikgnomic:

thanks for response!

alsa-ucm-conf is installed in version 1.2.4-2.
alsa-card-profiles is installed in version 13.99.3-1.

I look into /usr/share/alsa-card-profile/mixer/paths/analog-output-lineout.conf,
but im not sure, what to do, most elements are switch = off or mute (…and, I need S/PDIF).

In Alsamixer the same elements I set to 51% and saved.
I see the correct sets 51% volume in /usr/share/alsa-card-profile/mixer/profile-sets/default.conf.

I’m a little confused about the patch April 2017. My Audio-Output was functional the last years in Manjaro and stopped after last manjaro stable update 2020-11.

Greetings Michael

Nachtrag Screenshot Alsamixer und Lautstärke: