Stable update feedback

The headset patch and suggested fix for analog line-out are probably not relevant if you are trying to use the onboard audio S/PDIF optical output

Both of the S/PDIF settings in alsamixer are turned on [OO]

But the PulseAudio Profile for onboard audio audio device is set to ‘Aus’ (Off)

Is there a Profile: Digital Stereo (IEC958) Ausgabe available for ‘Family 17h (Models 00h-0fh0) HD Audio Controller…’ device in Audio settings ?

If you are not sure about the PulseAudio Profiles, please post response to

pacmd list-cards

that will show all available Profiles and if they are available

Hi nikgnomic,

thanks … and you are right.

Alsamixer
Possible to select “Family 17h…” turn on/off the channels.
I set the values to 51% for testing and to control in
/usr/share/alsa-card-profile/mixer/profile-sets/default.conf.
There the config (could see 51%) seems o.k.

In Plasma - Audio Einstellungen the “Family 17h…” is Aus (Off) and no possiblty of any change.

pacmd list-cards shows correct:

alsa.card = “1”
alsa.card_name = “HD-Audio Generic”
alsa.long_card_name = “HDAudio-Gigabyte-ALC1220DualCodecs”
alsa.driver_name = “snd_hda_intel”

but
profiles:
HiFi: Default (priority 8000, available: no)
off: Aus (priority 0, available: unknown)
active profile: off

No Profile Digital Stereo (IEC958) is available, analog or S/PDIF :unamused:

Greetings Michael

This will not do much good as the file will either get replaced when package alsa-card-profiles is updated, or system will create a .pacnew folder and not update the file

PulseAudio will not use the ‘Hifi’ Profile if it is detected as not available
The Profile is probably not available because the ports (sinks (outputs) and sources (inputs) ) are also not available

so pacmd list-sinks may be showing the SPDIF output sink iec958-stereo-output but it is probably shown as ‘available:no’

please post full response to

sudo dmesg | grep snd

to check if the onboard audio device outputs are correctly detected in ALSA

and also

amixer --card=1

to see settings for ALSA controls

Hi nikgnomic,

sorry for the late response, but now it’s time & weekend :slightly_smiling_face:

pacmd list-sinks shows only HDMI, nothing like S/PDIF or iec958-stereo-output.

Output from sudo dmesg | grep snd:

[    5.425670] snd_hda_intel 0000:08:00.1: Disabling MSI
[    5.425681] snd_hda_intel 0000:08:00.1: Handle vga_switcheroo audio client
[    5.521307] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC1220: line_outs=3 (0x14/0x15*/0x16/0x0/0x0) type:line
[    5.521309] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.521310] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.521311] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[    5.521312] snd_hda_codec_realtek hdaudioC1D0:    dig-out=0x1e/0x0
[    5.521313] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[    5.521314] snd_hda_codec_realtek hdaudioC1D0:      Rear Mic=0x18
[    5.521315] snd_hda_codec_realtek hdaudioC1D0:      Line=0x1a
[    5.541435] snd_hda_codec_realtek hdaudioC1D1: autoconfig for ALC1220: line_outs=1 (0x14/0x0/0x0/0x0/0x0) typ
e:hp
[    5.541438] snd_hda_codec_realtek hdaudioC1D1:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.541440] snd_hda_codec_realtek hdaudioC1D1:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.541442] snd_hda_codec_realtek hdaudioC1D1:    mono: mono_out=0x0
[    5.541444] snd_hda_codec_realtek hdaudioC1D1:    inputs:
[    5.541446] snd_hda_codec_realtek hdaudioC1D1:      Front Mic=0x1a
[    8.010793] usbcore: registered new interface driver snd-usb-audio

and
amixer --card=1

Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 66 [76%] [-15.75dB] [on]
  Front Right: Playback 66 [76%] [-15.75dB] [on]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 0 [0%] [-65.25dB] [off]
  Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control 'Front Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Front-Panel',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 0 [0%] [-17.25dB] [off]
  Front Right: Capture 0 [0%] [-17.25dB] [off]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 66 [76%] [-15.75dB] [on]
  Front Right: Playback 66 [76%] [-15.75dB] [on]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 66 [76%] [-15.75dB] [on]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 66 [76%] [-15.75dB] [on]
Simple mixer control 'Line Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 2 [67%] [20.00dB]
  Front Right: 2 [67%] [20.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958 Default PCM',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 0 [0%] [-17.25dB] [off]
  Front Right: Capture 0 [0%] [-17.25dB] [off]
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Rear Mic' 'Line'
  Item0: 'Rear Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Rear Mic' 'Line'
  Item0: 'Rear Mic'
Simple mixer control 'Rear Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Rear-Panel',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 0 [0%] [-17.25dB] [off]
  Front Right: Capture 0 [0%] [-17.25dB] [off]

I am rather at a loss, cause the same phenomen produce a Gigabyte B550I Board.

Thanks and Greetings Michael

The digital output is detected in ALSA, but it is not shown as S/PDIF

There are 2 ALSA controls listed for digital audio as IEC958 instead of S/PDIF

There is no mention of digital output in the HiFi profile for ALC1220 Analog (Card:1 Device:0)
ALC1220 Digital audio playback is probably Card:1 Device:1 and can probably be added to PulseAudio

please post response to

aplay -l

to confirm the correct device/sub-device numbers

Hi nikgnomic,

aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: NVidia [HDA NVidia], Gerät 3: HDMI 0 [HDMI 0]
Sub-Geräte: 1/1
Sub-Gerät #0: subdevice #0
Karte 0: NVidia [HDA NVidia], Gerät 7: HDMI 1 [HDMI 1]
Sub-Geräte: 1/1
Sub-Gerät #0: subdevice #0
Karte 0: NVidia [HDA NVidia], Gerät 8: HDMI 2 [HDMI 2]
Sub-Geräte: 1/1
Sub-Gerät #0: subdevice #0
Karte 0: NVidia [HDA NVidia], Gerät 9: HDMI 3 [HDMI 3]
Sub-Geräte: 1/1
Sub-Gerät #0: subdevice #0
Karte 0: NVidia [HDA NVidia], Gerät 10: HDMI 4 [HDMI 4]
Sub-Geräte: 1/1
Sub-Gerät #0: subdevice #0
Karte 0: NVidia [HDA NVidia], Gerät 11: HDMI 5 [HDMI 5]
Sub-Geräte: 1/1
Sub-Gerät #0: subdevice #0
Karte 0: NVidia [HDA NVidia], Gerät 12: HDMI 6 [HDMI 6]
Sub-Geräte: 1/1
Sub-Gerät #0: subdevice #0
Karte 1: Generic [HD-Audio Generic], Gerät 0: ALC1220 Analog [ALC1220 Analog]
Sub-Geräte: 1/1
Sub-Gerät #0: subdevice #0
Karte 1: Generic [HD-Audio Generic], Gerät 1: ALC1220 Digital [ALC1220 Digital]
** Sub-Geräte: 1/1**
** Sub-Gerät #0: subdevice #0**
Karte 1: Generic [HD-Audio Generic], Gerät 4: ALC1220 Analog [ALC1220 Analog]
Sub-Geräte: 1/1
Sub-Gerät #0: subdevice #0

Greetings Michael

Archwiki suggests using this command (but I only found this today and not sure if/how it works)

iecset -c1 audio on

I know a solution that works to add an analog output that is not automatically detected in PulseAudio
I can add a digital output sink on my system but I do not have any spdif hardware to confirm 100% it is working, but it appears to work no problem

pacmd load-module module-alsa-sink device=hw:1,1 sink_name=alsa.output.digital-stereo sink_properties=device.description=SPDIF

The module is not persistent and will not be reloaded if system (or PulseAudio) is restarted
If it works for you, the PulseAudio configuration can be customised to have module always loaded (and set to be the default-sink for audio)

If you want more than a stereo output (surround sound or DTS/AEC compression) the command will need additional options for module-alsa-sink

1 Like

Hi nikgnomic,

Great job! Many thanks!!!

My Yamaha Reveicer plays again :slightly_smiling_face: :upside_down_face: :slightly_smiling_face: :grin:!!!

Stereo Output is perfect (like sources) and the Yamaha Soundprocessor pushed it to DTS Neo:6.1 :relaxed:
To be able to make it persistent would be perfect.

Greetings Michael

1 Like

Making the sink output persistent sink is no problem now it is confirmed to work

First copy the default module configuration to your home folder
(keep the system configuration file unmodified as a backup)

cp  /etc/pulse/default.pa ~/.config/pulse/default.pa

Edit this line (probably line 22)

#load-module module-alsa-sink

to this

load-module module-alsa-sink device=hw:1,1 sink_name=alsa.output.digital-stereo sink_properties=device.description=SPDIF

sed 's/'#load-module module-alsa-sink/load-module module-alsa-sink device=hw:1,1 sink_name=alsa.output.digital-stereo sink_properties=device.description=SPDIF/g' ~/.config/pulse/default.pa 

To set SPDIF to be default sink add a line to the end of the file

echo -e '\nset-default-sink alsa.output.digital-stereo' >>  ~/.config/pulse/default.pa 

And restart PulseAudio to load the new custom profile (or reboot system)

systemctl --user restart pulseaudio

I also suggest you check if the new sink is configured OK in

pacmd list-sinks

PulseAudio might not be using the optimal ‘sample spec’ for your Yamaha Soundprocessor, but that can be reconfigured too

1 Like

Hi nikgnomic,

S/PDIF is no permanent after reboot - perfect - thanks for the whole work!

Greetings Michael

1 Like