[Stable Update] 2024-06-10 - Kernels, Systemd, NVIDIA, Mesa, Qt5

That’s unfortunate. The latest stable update (2024-06-10) finally made KWin Wayland usable on my setup. Since the revert (550.90.07-2 → 550.90.07-3), my Kwin Wayland setup is broken again. With broken I mean: I can log in and I see a mouse cursor, an app (evolution) autostarts successfully but is scaled like 300% and that’s it. No menu, no wallpaper, no keybinding, I can’t click anything.

For the time being I just switch back again to Kwin X11.

My setup: Kernel 6.6 LTS + AMD Ryzen + Nvidia GTX 1060

  Host: yeee Kernel: 6.6.32-1-MANJARO arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.5 Distro: Manjaro Linux
  Info: 6-core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP cache: L2: 3 MiB
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 550.90.07
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
    loaded: nvidia gpu: nvidia resolution: 2560x1440~60Hz
  API: EGL v: 1.5 drivers: kms_swrast,nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.90.07
    renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2
  API: Vulkan v: 1.3.279 drivers: nvidia surfaces: xcb,xlib

But besides: I appreciate all your hard work. Been using Manjaro for years on the same system successfully. With the help of these nice curated stable update posts, updating is smooth with Manjaro. Thanks guys!

Well, then what you need to do to fix it is add the parameters which were present with 550.90.07-2:

set the modeset=1 kernel module parameter for the nvidia_drm module.

Additionally, with the driver version 545 and above, you can also set the experimental nvidia_drm.fbdev=1 parameter, which is required to tell the NVIDIA driver to provide its own framebuffer device instead of relying on efifb or vesafb , which do not work under simpledrm .

NVIDIA - ArchWiki

One can also create a custom config file; i.e., /etc/modprobe.d/nvidia.conf containing:

options nvidia-drm modeset=1 fbdev=1

Thank you so much for the simple solution and explanation. Happily replying from a perfectly smooth running KWin Wayland :slight_smile: Awesome!


I am currently using 6.7_rt6-3
6.9 kernel does not have a RT

Thank you. Your reply is helpful. I gave you a like.

Do you mean no virtual keyboard shows even when there is one properly installed and configured? Or, it just doesn’t support it at all?

I imagine so, for as long as the need exists. As you are no doubt aware, these kernels are a little less frequent that the mainstream kernels.

Use your existing kernel until the next RT is released;
it’s only a question of time.

Music production isn’t the only use case for a real-time kernel; albeit the most commonly highlighted. I might question the need for it too, in some cases, but there’s usually a good reason, whether perceived or actual.

It has no graphical interface, is console based, is not supported and I doubt it ever will be.

linux67-rt kernel has not been marked as EOL yet, probably because a later RT kernel has not been released yet

Options in /etc/modprobe.d/ folder are simpler to implement (or modify) than editing GRUB boot options

sudo tee /etc/modprobe.d/nvidia.conf <<< 'options nvidia-drm modeset=1 fbdev=1'

and reboot. update-grub not needed

1 Like

It will not work ( Talk:NVIDIA - ArchWiki ), grub options are needed in kernel 6.6.x, in kernel 6.9.x it is also necessary to add to /etc/mkinitcpio.conf : MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm), and without fbdev=1 it will not work.

The best way for Wayland is kernel 6.6.x, simply add to grub nvidia_drm.modeset=1 and optionally nvidia_drm.fbdev=1 and this will make it possible to log in Wayland and x11 without problems.

I have tested kernel 6.10rc3 and it is the same case as 6.9.x.


Well, I guess that sums it up. Thanks.

After upgrading to the fixed package -3 now nothing works again and cant get it working.

I am able to start KDE using startx, but sddm-greeter crash on boot

I am observing the issue that my lockscreen gets stuck after hibernation. Both on X11 and Wayland session. I can not switch to tty, so I have to use the off switch coldly. On X11 at least, the session is killed (I guess) and I’m back at sddm to log in.

I’m using a slideshow of tons of pictures, in subfolders, too. Will report on discuss.kde and also report back here as well, have not loo(c)ked into it more deeply for now.

Solution was to install normal Nvidia Drivers instead of DKMS

1 Like

I keep getting this error when trying to update

error: failed retrieving file 'gcc-libs-14.1.1+r58+gfc9fb69ad62-1-x86_64.pkg.tar.zst.sig' from mirror.freedif.org : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'archlinux-appstream-data-20240526-1-any.pkg.tar.zst' from mirror.freedif.org : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: failed to retrieve some files
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

How do I fix it ?

Use a different mirror.

I’ve been having issues with LibreOffice fresh, programs freeze when saving or inserting images into documents. I noticed this after upgrading to Plasma 6.

For interested people: tty font changes with setting fbdev=1.

Just out of curiosity; what is the benefit if fbdev is used?
In Arch-Wiki there is only a info, what it does: ...to tell the NVIDIA driver to provide its own framebuffer device... (NVIDIA - ArchWiki)

1 Like

Does session Restore (On Last Logout or Save Session) work for anyone on Plasma 6.0.5?
On X11 it should work afaik, Wayland adds it in 6.1

AFAIK setting fbdev=1 should allow you to have higher resolution and faster console, especially when using high resolution screen, by NVIDIA running its own framebuffer device (and framebuffer not being run by CPU). The downside is that when this framebuffer device fails for some reason, console may not display at all. I think both intel and amd drivers are running their own framebuffer devices by default

And remember to set fbdev=1 only on systems where NVIDIA is your primary GPU. It won’t work for dual-gpu (in terms of iGPU + dGPU) systems


Ok thanks. So in short “just” hardware acceleration for tty. :stuck_out_tongue_winking_eye:

CUDA is broken after 2024-05-29 update, which updated cuda to 12.5, but the nvidia kernel driver is still 12.4 now, so if you compile a cuda program and run it, then it will throw an error “the provided PTX was compiled with an unsupported toolchain.”