[Stable Update] 2024-05-29 - Kernels, Plasma 6.0.5, GNOME 46.2, Mesa

Hello community,

Here are the latest updates from the last couple of weeks.

We are also still looking forward to your feedback on our stable install medias of Manjaro 24.0 Wynsdey. New 24.0.1 ISOs are coming along shortly…

Current Promotions

  • Find out all about our current Gaming Laptop the Hero with Manjaro pre-installed from Spain!
  • Protect your personal data, keep yourself safe with Surfshark VPN: 3 mo. EXTRA: From 4.98 2.19 USD/mo

Recent News

Previous News
  • Manjaro Team member @romangg has a new library project with a guest post on Phoronix.
  • Some Manjaro team members attended FOSDEM 2024 and we showed off a prototype of the upcoming Orange Pi Neo Handheld Gaming Console!
  • Check out the new Manjaro Slimbook Hero!
  • Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!

Notable Package Updates

Additional Info

Python 3.12 info

:information_source: You will need to rebuild any AUR Python packages that install files to site-packages or link to libpython3.11.so. :information_source:

Print a list of of packages that have files in /usr/lib/python3.11/ :

pacman -Qoq /usr/lib/python3.11/

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.11)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.

Use rebuild-detector to see if anything else needs to be rebuilt:

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.315
  • linux54 5.4.277
  • linux510 5.10.218
  • linux515 5.15.160
  • linux61 6.1.92
  • linux66 6.6.32
  • linux68 6.8.11
  • linux69 6.9.2
  • linux610 6.10-rc1
  • linux61-rt 6.1.83_rt28
  • linux66-rt 6.6.30_rt30
  • linux67-rt 6.7_rt6

Package Changes (Mon May 27 23:48:09 CEST 2024)

  • stable core x86_64: 85 new and 82 removed package(s)
  • stable extra x86_64: 3116 new and 3236 removed package(s)
  • stable multilib x86_64: 46 new and 47 removed package(s)

A list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2024-05-29

:warning: Linux 6.8 is EOL

Linux 6.8 is EOL and will - at some point - be removed from the repo.

If you use Linux 6.8 and Nvidia or inside a virtual machine, it is of great importance, that you install Linux 6.6 or Linux 6.9 to avoid driver problems.

sudo mhwd-kernel -i linux66


No plasma interface with kernel 6.9 + Nvidia gpu + Wayland

If you encouter a black screen with no inteface after login in, it’s probably a problem with simpledrm loading.

To solve it add nvidia_drm.fbdev=1 to /etc/default/grub
in the line begining with GRUB_CMDLINE_LINUX=" .
Verify that you also have nvidia_drm.modeset=1 in the same line.
Then exec sudo update-grub

Also, verify that you have nvidia_drm in /etc/mkinitcpio.conf in the MODULES= or HOOKS= line.
Exemple :

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

If it was not present, then run sudo mkinitcpio -P after adding it.

:arrow_right: 2024-05-13

:warning: Linux 6.7 is EOL
Linux 6.7 is EOL and will - at some point - be removed from the repo.

If you use Linux 6.7 and Nvidia or inside a virtual machine, it is of great importance, that you install Linux 6.6 to avoid driver problems.

sudo mhwd-kernel -i linux66
Python interpreter upgrade

If you have a lot of pip/AUR packages to upgrade to Python 3.12, read this.

If you installed python312 from the AUR, you need to uninstall it before running this update.

Qemu: MacOS is not bootable with 9.0

Due to a bug MacOS is not bootable with 9.0: [9.0.0] qemu breaks mac os vm (#2334) · Issues · QEMU / QEMU · GitLab
Workaround: remove virtio-serial and org.qemu.guest_agent.0 from libvirt XML until bug will be fixed.

If you use KDE you better logout of your session and do the update via Pacman or Pamac in tty.

Helper script to reset plasma Manjaro-Plasma-Reset/manjaro-plasma-reset.sh at main - wonky/Manjaro-Plasma-Reset - Codeberg.org @liinux-aarhus
Also I would, before the update:

  • make a Timeshift snapshot if you ain’t got no recent one.
  • ( export content of widgets like your radio stations in Advanced Radio Player or your Podcasts in Kasts or any podcatcher as a backup )
  • make a fresh boot, but before that even:
  • System Settings > Appearance > Global Theme > set to Breath and tick both options for defaults
  • You might go to the hamburger menu in System Settings and look what changes you made away from default by selecting: Highlight Changed Settings and see if you want to make the effort to get back more defaults
  • System Settings > Workspace > Startup and Shutdown: SDDM defaults and Desktop Session: Start with empty session
  • disable all user-installed widgets that are still on your desktop, panels and even lock screen or wallpaper (e.g. Active Blur)
  • Export your custom shortcuts or mouse gestures in SS> Workspace > Shortcuts
  • Reboot, Timeshift snapshot, reboot
  • then do not log in, do the update via tty (CTRL+ALT+F3, same with F2 gets you back)
  • reboot, login, check through System Settings
  • reboot again
  • enjoy 8)


  • look for Plasma 6 replacements for your widgets after the install
  • in case you have Github-installed theming: uninstall the KDE5-version of klassy, install the Plasma 6 version of klassy, maybe reinstall lightly

(greetings, @1efaf7d71a8637c6800a , PS: these are just my thoughts; I didn’t do this update yet!)

How to fix `plasma-firewall` error in System Settings GUI when running `ufw`

Open /usr/lib/kde_ufw_plugin_helper.py and change the first line from #!/usr/bin/python3.11 to #!/usr/bin/python3.12. This fixed the issue for me immediately and makes sense since Manjaro is currently on Python 3.12.

Xfce has inconsistent themes for Qt applications

Qt 6 is now default but some apps are still using Qt 5
To restore the look of QT apps after this update

pamac install kvantum-qt5

Manjaro-settings-manager has light theme instead of dark


DKMS fails for v4l2loopback on 6.8 kernel

DKMS fails for v4l2loopback on 6.8 kernel (#2) · Issues · Arch Linux / Packaging / Packages / v4l2loopback · GitLab

issues with auto-mount of ntfs filesystem using Kernel 6.8

The kernel changed default ntfs driver from FUSE one to ntfs3.
These two are not fully compatible, mainly as far as mount options go. If you have custom mount options in the fstab (or any other application, such as VeraCrypt) they need to be changed.

Mount fails with: Device or resource busy
DMesg reports: Can't open blockdev

Migrate your mount options. For me the changes were:

  • allow_otherumask=000
  • default_permissions → [drop]
  • user_id=1000uid=1000
  • group_id=1000gid=1000


gnome-keyring: ssh component is not included

ssh component is not included (#3) · Issues · Arch Linux / Packaging / Packages / gnome-keyring · GitLab


plymouth update may cause black screens

With a newer version of plymouth than 22.02.122 you may experience an unbootable system with a black screen. This might be due to not having early KMS enabled. If you have an Nvidia GPU you could set nvidia_drm.modeset=1 nvidia_drm.fbdev=1 to the kernel parameters in your bootloader config to avoid the need of KMS. However, with Wayland around the corner, KMS will be needed.

To “fix” the current problem, we have downgraded plymouth once again to have more time to find a proper solution to migrate most of your installations to a working state with newer plymouth versions.

sudo pacman -Syuu

Those who don’t have issues can enjoy the newer version of plymouth.

Directions for adding kms to your system configuration and how you can help troubleshooting by providing some sysinfo, read more → Black Screen with Plymouth - Cause and Solution

polkit update might remove your local modified config

With polkit 124-1 there were changes made to etc/pam.d/polkit-1. So check if you made local changes to the file. See also: https://www.reddit.com/r/archlinux/comments/19bnj0i/comment/kit2v33/

bashrc-manjaro is now merged into bash
  • Yes, replace bashrc-manjaro with bash
  • Please also compare your:
    with the generated
    and retrofit all of your customisations as there was no .pacnew file generated.
  • Same goes for /etc/skel/.bashrc
pacman and pacman-contrib changes

pacman-contrib is now split out from pacman. If you have anything installed that depends on pacman-contrib, update (after you finished the Release Update) with:

sudo pacman -Syu pacman-contrib


Initramfs image can be bigger on 6.7 kernel due to Nvidia GSP Boot firmware

We all known that kernel 6.7 is very feature rich. One of the features is the inclusion of Nvidia’s GSP Boot firmware into Initramfs. However this will increase your image by 150 MB and the fallback image might be 240 MB in size. A way would be to remove kms from mkinitcpio.conf and redo your initramfs images. A discussion regarding that can be found at Arch Gitlab: kms hook increases the initramfs size heavily starting with 6.7 kernel (#238) · Issues · Arch Linux / Mkinitcpio / mkinitcpio · GitLab

To reduce size add fallback_options="-S autodetect -S kms" to /etc/mkinitcpio.d/linux67.preset

Making dbus-broker our default D-Bus daemon

2024-01-09 - Jan Alexander Steffens

We are making dbus-broker our default implementation of D-Bus, for improved performance, reliability and integration with systemd.

For the foreseeable future we will still support the use of dbus-daemon, the previous implementation. Pacman will ask you whether to install dbus-broker-units or dbus-daemon-units. We recommend picking the default.

For a more detailed rationale, please see our RFC 25.

Arch Linux - News: Making dbus-broker our default D-Bus daemon

In some cases, however it is better to keep the legacy way. Here are some examples: Dbus-broker warnings


grub update

grub 2.12 may need manual post install by the user

With GRUB 2.12 out it is recommended to also install grub to your master boot record or EFI partition. On Manjaro grub gets only installed when you install it to your harddrive the first time. Only advanced users also keep their MBR/EFI in-sync as every package update of grub doesn’t update the installation on your MBR/EFI.

Depending on your system hardware and setup this may could cause an unbootable system on rare cases due to incompatibilities between the installed bootloader and configurations. After a grub package update it is advised to run both, installation and regeneration of configuration:

grub-install [plus the needed options depending of been EFI or BIOS]
grub-mkconfig -o /boot/grub/grub.cfg

For more specific information on grub-install, please refer to this guideline: [root tip] [How To] Primer on handling a grub package update

Additional information to that topic can be found here:


Broken Wifi with 6.1.66 and 6.6.5 kernels

Some users report broken Wifi driver support with the latest 6.x kernel series, mostly based on Realtek drivers, either from the AUR or provided by the kernels itself. It is also reported that linux515 and linux67 kernel series don’t have those issues. So if you have a potential Wifi driver problem, consider to install those kernels before updating your system. Older kernels can be found here:

Possible issues reported upstream

The Author of the original patch Johannes Berg had reviewed Léo Lam’s patch by now. So everybody who had tested 6.6.5-3 or 6.1.66-2 should reply to the upstream mailing list with a Tested-by tag as described here: [Stable Update] 2023-12-10 - Kernels, Plasma, Phosh, Systemd, Cinnamon, Gnome, libpamac - #95 by philm


  • IMPORTANT → Linux 6.5 is EOL

    Linux 6.5 is EOL and will be removed from the repo.

    If you use Linux 6.5 and Nvidia or as virtual machine, it is of great importance, that you install Linux 6.6 to avoid driver problems.

    sudo mhwd-kernel -i linux66


Blender 4.0 may fail on AMD GPUs

The current native ALPM package of Blender provided by our mirrors may fail with AMD GPUs. As an alternative you may want to use Blender-Bin from the AUR, flatpak version, snap version or load it directly from Blender. More infos here: 17:4.0.1-2 Segfault on start (#2) · Issues · Arch Linux / Packaging / Packages / blender · GitLab


mkinitcpio needs base hook

With the update of mkinitcpio 37 make sure you have the base hook in your /etc/mkinitcpio.conf file, unless you use systemd hook instead. See also wiki for all hook documentation.


Changes in JDK / JRE 21 packages may require manual intervention

2023-11-02 - Frederik Schwan

We are introducing a change in JDK/JRE packages of our distro. This is triggered from the way a JRE is build in modern versions of Java (>9). We are introducing this change in Java 21.

To sum it up instead of having JDK and JRE packages coexist in the same system we will be making them conflict. The JDK variant package includes the runtime environment to execute Java applications so if one needs compilation and runtime of Java they need only the JDK package in the future. If, on the other hand, they need just runtime of Java then JRE (or jre-headless) will work.

This will (potentially) require a manual user action during upgrade:

  • If you have both JDK and JRE installed you can manually install the JDK with pacman -Sy jdk-openjdk && pacman -Su and this removes the JRE related packages.
  • If you have both JRE and JRE-headless you will need to choose one of them and install it manually since they would conflict each other now.
  • If you only have one of the JDK/JRE/JRE-headless pacman should resolve dependencies normally and no action is needed.

At the moment this is only valid for the upcoming JDK 21 release.

Arch Linux - News: Incoming changes in JDK / JRE 21 packages may require manual intervention


Powerdevil fails in KDE Plasma

In KDE Plasma, Powerdevil fails and energy settings (Power save v Normal v Performance) are unavailable. See:
Powerdevil fails, Energy settings unavailable

Restarting gnome-shell using Alt+F2 and entering R, causes a crash

FS#79884 : [gnome-shell] Restarting gnome-shell using Alt+F2 and entering R, causes a crash

GNOME Extensions that target older GNOME versions will not work in GNOME 45

It is recommended to remove all third-party extensions before updating, then install the compatible versions after updating and rebooting. All Most extensions in the Manjaro repos are already updated.

kpeoplevcard update requires manual intervention

A “newer” version of kpeoplevcard accidently existed, so to install the current version, either update with sudo pacman -Syu kpeoplevcard or sudo pacman -Syuu.

Previous stable update threads:

They were all saying that I should check the update announcements before doing updates but I just had a large 400+ stable package update. I came to look at the announcement first before updating but I could not find anything? The last stable KDE update was on the 18th according to the announcement section.

I did a disk image first and updated anyhow.

1 Like

Yes, @philm did a stable update snap and started creating new ISOs, however has not yet created a new topic as I imagine he went to bed right after.

EDIT: Apparently it was my job to do it. Sorry for the delay!


I got this conflict error when I tried to apply the update (AUR is not enabled and never was, if that matters)


You essentially made them run on xorg instead of wayland.
The only common QT application that I know of that has an open bug regarding this is smplayer.
In fact I have QT_QPA_PLATFORM="wayland;xcb" in my /etc/environment so the opposite is applied system-wide (and okular opens fine).

But if its a gnome thing then its a gnome thing. :person_shrugging:

Does not change the fact that the package you have installed is not in the repos. It might have used to have been. In any case you should not need it any longer.

Well, I voted. It said to write about any problems that this update caused. I have never had anything quite like this before soooo…

I have had about a week to find problems and try to sort them out. I ended up doing a full reinstall and then doing its Plasma 6 update directly after. So this is a “clean” blank system.

  • Trackpad. No synaptic trackpad settings any more. Please don’t take the synaptic driver away as my external trackpads do not work properly without it.
  • Calendar. I lost Event-Calendar so I’m back to hunting for a calendar that works.
  • CopyQ scripts no longer work. As the link title says.
  • No printer ink levels any more. I am going to just have to use it until the ink ends, or guess.
  • USB Bluetooth device does not reconnect automatically any more. The internal M.2 one does, but not the external USB one. I have ended up writing some systemd timer script to check and connect to my BT devices if its not already connected.
  • OpenVPN problem. I have not had a chance to even take a second look at this just yet, but it does seem that others have mentioned it already.
inxi -bz
  Kernel: 6.6.32-1-MANJARO arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.5 Distro: Manjaro Linux
  Type: Desktop System: Dell product: OptiPlex 7050 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 055H3G v: A01 serial: <superuser required> UEFI: Dell
    v: 1.26.0 date: 08/20/2023
  Info: quad core Intel Core i7-7700 [MCP] speed (MHz): avg: 1423
    min/max: 800/4200
  Device-1: Intel HD Graphics 630 driver: i915 v: kernel
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
    loaded: modesetting dri: iris gpu: i915 resolution: 3840x2160~60Hz
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.8-manjaro1.1
    renderer: Mesa Intel HD Graphics 630 (KBL GT2)
  Device-1: Intel Ethernet I219-LM driver: e1000e
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
  Local Storage: total: 1.84 TiB used: 301.98 GiB (16.0%)
  Memory: total: 16 GiB available: 15.49 GiB used: 4.75 GiB (30.7%)
  Processes: 218 Uptime: 1h 46m Shell: fish inxi: 3.3.34

This has been covered a dozen times.
There is no longer any GUI interface for configuring xf86-input-synaptics in the plasma system settings. There is not going to be. This does not stop you from using synaptics. It just wont give you GUI options.

Deprecated/abandoned/incompatible/out-of-date software is not really the fault of KDE or Manjaro or the update.

Isnt this a thing that requires special steps if you want to use it under wayland?
Wasnt this also covered in other threads?

We cant even really begin to know what this means.

1 Like

Firefox should be the latest version because of this issue:


Yea and i am grateful that it does still use synaptic. It was that it is looking like they are getting ready to remove it all together.

Yea, does not help, was working now its not. Would be ok if there was a proper calendar that worked with plasma.

I don’t use Wayland specifically because copyq said it did not work under wayland last time i looked.

I see the printer ink levels got missed out ^^ :stuck_out_tongue:

I know these have “mostly” been covered as i posted the individual posts. I read this update thread. It said to vote and then it said to post about your problems with the update. So i am. Also bringing them all together in one list, so to speak.

So lets see…Did the May 18th Stable update without problems. 'Couple hours ago got a lert that there was an update…checked pacman and there are 468 packages pending. Currently on 6.1.90-1 kernel and 6.0.4 Plasma. Checking here I dont see any announcement for this update nor do I see evidence of this on Manjo Telegram channel… curious about whats up and I am not updating anything until I see something here. Just sayin. Anyone??

1 Like

Aye, i was wondering the same thing:-

1 Like

I dont use this feature and dont know anything about it.
Do you want me to guess?

I also notice you did not expand on your ‘broken openvpn’.

Thanks both of you for this. Given the wild wild west internet where I live in Ecuador…and that I run stable as a production environment, I didnt chance it. Going to be interesting to see when the announcement and Telegram hit. Again thanks to you both. I am going to wait a bit to see. Jack if your computer grows a small dragon out of its 3rd eye as a result take a pic and let us know :slight_smile:

1 Like

I have the same error, but I don´t know how to fix it.

Do you mean gcc12?

pacman -Qi gcc12 | grep 'Required By'

If it is not required by anything then remove it.

sudo pacman -Rns gcc12

Nothing happens

And without grep?

pacman -Qi gcc12
1 Like
Name                     : gcc12
Version                  : 12.3.0-6
Beschreibung             : The GNU Compiler Collection - C and C++ frontends
Architektur              : x86_64
URL                      : https://gcc.gnu.org
Lizenzen                 : GPL3  LGPL  FDL  custom
Gruppen                  : Nichts
Stellt bereit            : Nichts
Hängt ab von             : gcc12-libs  binutils>=2.28  libmpc  zstd
Optionale Abhängigkeiten : Nichts
Benötigt von             : Nichts
Optional für             : Nichts
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Installationsgröße       : 152,91 MiB
Packer                   : Frederik Schwan <freswa@archlinux.org>
Erstellt am              : Do 18 Apr 2024 10:08:57 CEST
Installiert am           : Di 14 Mai 2024 02:13:34 CEST
Installationsgrund       : Installiert als Abhängigkeit eines anderen Pakets
Installations-Skript     : Nein
Verifiziert durch        : Signatur

Well that would explain the blank grep.
But you can read your own language, right?