[Stable Update] 2024-05-18 - Linux-Firmware, PHP, Gitlab, Qt6

“If something can go wrong, it will.” :woozy_face:

3 posts were merged into an existing topic: Update requests for packages imported from Arch Linux

sorry, I meant to say “community post”, which is the second after the stable update announcement… it’s editable by the commuity thats why I called it a “wiki post”

1 Like

I just now realized we can add stuff to this post, thank you


Something in this release seems to have broken pamac-manager.
Whenever I do anything that would need authentication (such as installing/removing software or opening the preferences dialogue) it immediately pops up “Error Authentication failed”, but doesn’t prompt for the password.

Running from the command line, there are no error messages.

It’s evidently not pamac-manager itself at fault, as I’ve tried downgrading pamac-gtk with no results. The only way at present I can do anything with it is to run it using sudo, which probably isn’t a good idea.

This is a KDE Plasma system, now running Plasma 6.


Fixed In next 6.0.5
bugs.kde - polkit-kde-agent crashes with nullptr

ps: for me, in stable, no bug found with polkit since plasma6

EDIT : 6.0.5 is in testing


My experience so far with update 2024-05-13 + 2024-05-18 (KDE + nvidia + x11):
Over all updating went without any major complication.

My findings:

  • the animation for maximizing and stick to edges of windows seemed kinda laggy → disabling floating panel resolved it for me.
  • I forgot to remove kde5 widgets (e.g. modern clock) → at first not really a problem; I just removed the broken ones in edit mode. But after a few days I wanted to add some of them again via the download wizard. Which resulted in a bugged download GUI (Install-button did not work) → to get it working again I moved/removed the corresponding widgets folders from ~/.local/share/plasma/plasmoids
    (Edit: removing the widget via GUI also did not work.)

The external monitor connection options now no longer woks. My current external monitor connection type (during the update) was “extend to right”. After update, changing it to any other types, for example to “switch to laptop screen” if I want to disconnect my second monitor, does not change anything. This morning, I just unplugged my second monitor, is that safe?

UPDATE: The unresponsive display configuration change only affects the keyboard shortcut for changing display configuration. Changing the configuration from the icons at the panel bar works, but much less inconvenient than being able to access it just by pressing a button.

After the 5/13 update, logging into the Plasma Wayland session produces a black screen with no visible shell. Most keystrokes (e.g., Ctrl+Alt+T to open Konsole) still work but I cannot access programs or menus. Programs on autostart appear. The X11 session works fine.

I’ve tried clearing my ~/.cache to no avail.

Still trying to diagnose why.

1 Like

If nvidia … see the nvidia notes :point_up:

1 Like

Yes, Nvidia. Just reread the thread but I don’t see any notes besides downgrading kernel. (I’m already on 6.6.) Are there other notes I should be aware of?

Oh - it looks like it was something some of the users added to the Testing Announcements.

But heres what it was mimicking;

Thanks. Will test tomorrow.

EDIT: Can confirm this fixed it. Adding to the wiki here.

1 Like

Can confirm. TV via HDMI: Meta+P does nothing.
I disabled internal laptop screen in system settings to show picture only on TV.
This led to an additional problem: System hang on “shutdown now” (2 times in a row now; swiched back to internal screen… shutdown works)

I downloaded the source files from “GitHub - MacTavishAO/nautilus-admin-gtk4: Extension for Nautilus to do administrative operations” (which is out dated and no updates, so i guess it’s dead) and altered the code to only use gedit, so yeah kind of fixed for me now, as the source was an older version i changed to just editing the nautilus-admin.py :arrow_down:

You can just edit “/usr/share/nautilus-python/extensions/nautilus-admin.py”

Under “NAUTILUS_PATH=”/usr/bin/nautilus""


at the very bottom change the line from “subprocess.Popen([text_editor, admin_uri])” to
“subprocess.Popen([GEDIT_PATH, admin_uri])” with out quotes.

and that fixes the issue for me.

What do you mean? The latest commit was a couple months ago and the repo package is up to date.

Why? It already uses the default text editor, there should be no need.

Again, I cannot reproduce your issue. I have Gedit set as my default text editor and it works fine.

I’m not sure why it stopped working for me and opening all text files, (.conf, .cfg, blank file type, etc) with Gnome’s Video player, all file types work and open fine with normal double click, open, etc, but not for “edit with admin” and i know it was working before the update (2024-05-13), so that’s why i opted for this quick fix that works for me.

4 posts were split to a new topic: Restoring PipeWire and Wireplumber settings to default

I installed the 5-13 update just before going on a 7-day holiday… just got back today and found these updates to install.

pacman.log updates
[2024-05-21T19:56:01-0500] [ALPM] transaction started
[2024-05-21T19:56:01-0500] [ALPM] upgraded amd-ucode (20240409.1addd7dc-1.0 -> 20240510.b9d2bf23-1)
[2024-05-21T19:56:01-0500] [ALPM] upgraded linux-api-headers (6.7-1 -> 6.8-1)
[2024-05-21T19:56:02-0500] [ALPM] upgraded discord (0.0.53-1 -> 0.0.54-1)
[2024-05-21T19:56:02-0500] [ALPM] upgraded libpamac (11.6.4+1+g3fe0f42-1 -> 11.6.4+2+g1421283-1)
[2024-05-21T19:56:02-0500] [ALPM] upgraded libpamac-flatpak-plugin (11.6.4+1+g3fe0f42-1 -> 11.6.4+2+g1421283-1)
[2024-05-21T19:56:05-0500] [ALPM-SCRIPTLET] error: Can't load uri https://flathub.org/repo/flathub.flatpakrepo: While fetching https://flathub.org/repo/flathub.flatpakrepo: [7] Couldn't connect to server
[2024-05-21T19:56:05-0500] [ALPM-SCRIPTLET] 
[2024-05-21T19:56:06-0500] [ALPM] upgraded qt6-base (6.7.0-5 -> 6.7.0-6)
[2024-05-21T19:56:06-0500] [ALPM] upgraded libplasma (6.0.4-1 -> 6.0.4-1.1)
[2024-05-21T19:56:06-0500] [ALPM] upgraded linux-firmware-whence (20240409.1addd7dc-1.0 -> 20240510.b9d2bf23-1)
[2024-05-21T19:56:07-0500] [ALPM] upgraded linux-firmware (20240409.1addd7dc-1.0 -> 20240510.b9d2bf23-1)
[2024-05-21T19:56:07-0500] [ALPM] upgraded pcsclite (2.2.0-4 -> 2.2.1-1)
[2024-05-21T19:56:07-0500] [ALPM] upgraded plasma-firewall (6.0.4-1 -> 6.0.4-2)
[2024-05-21T19:56:07-0500] [ALPM] upgraded spectre-meltdown-checker (0.46+23+g0f2edb1-1 -> 0.46+26+gbd0c7c9-1)
[2024-05-21T19:56:07-0500] [ALPM] transaction completed

Post install/reboot, I have the following issues:

  1. my external DP monitor is no longer sensed/used on my laptop. I believe I’m keeping 3 versions of packages… should I try “downgrading” amd-ucode or linux-firmware? if so, what would be the proper way to do that?
    EDIT: Perhaps this journal entry is related and sheds some light?
    kwin_x11[1155]: kwin_core: parsing edid failed
  2. Conly is not refreshing properly… each update is written over top the old data creating a mess of overlapping font text
journal entries when conky launched
May 21 22:38:04 AMD-Ryzen9-7940HS systemd[1049]: Started conky.
May 21 22:38:05 AMD-Ryzen9-7940HS plasmashell[5729]: conky: desktop window (600028) is subwindow of root window (560)
May 21 22:38:05 AMD-Ryzen9-7940HS plasmashell[5729]: conky: window type - normal
May 21 22:38:05 AMD-Ryzen9-7940HS plasmashell[5729]: conky: drawing to created window (0x6000001)
May 21 22:38:05 AMD-Ryzen9-7940HS plasmashell[5729]: conky: drawing to double buffer
May 21 22:38:05 AMD-Ryzen9-7940HS plasmashell[5729]: conky: can't parse X color '-l' (2)
May 21 22:38:05 AMD-Ryzen9-7940HS plasmashell[5729]: conky: can't parse X color '-t' (2)
May 21 22:38:05 AMD-Ryzen9-7940HS plasmashell[5729]: conky: forked to background, pid is 5733

EDIT: Solved my Conky issue!

My conky solution

Remembered I had previously wanted to change my conky so it was not transparent.

Initial transparent settings were…

  own_window_transparent = false,   -- set transparency:
  own_window_argb_visual = true,
  own_window_argb_value = 175,

My revised settings to try kill the transparency that worked in 5-13 and earlier were…

  own_window_transparent = true,   -- set transparency:
  --own_window_argb_visual = true,
  --own_window_argb_value = 175,

But after this 5-18 update, flipping that (likely erroneous) true to false corrected my overlapping font issue…

  own_window_transparent = false,   -- set transparency:
  --own_window_argb_visual = true,
  --own_window_argb_value = 175,

System details

inxi -Fazy
inxi -Fazy                                                                                     ✔ 
  Kernel: 6.6.30-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=0e2d6c29-a2a6-4fd2-a472-78713cd43975 rw udev.log_priority=3
    amdgpu.runpm=0 sysrq_always_enabled=1
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Laptop System: Framework product: Laptop 16 (AMD Ryzen 7040 Series)
    v: AJ serial: <superuser required> Chassis: type: 10 v: AJ
    serial: <superuser required>
  Mobo: Framework model: FRANMZCP09 v: A9 serial: <superuser required>
    part-nu: FRAGACCP0J uuid: <superuser required> UEFI: INSYDE v: 03.02
    date: 01/23/2024
  ID-1: BAT1 charge: 50.8 Wh (60.0%) condition: 84.7/85.1 Wh (99.5%)
    volts: 16.1 min: 15.5 model: NVT FRANDBA type: Li-ion serial: <filter>
    status: charging cycles: 4
  Device-1: hid-28:05:2e:c5:33:2a-battery model: Targus Fullsize Bluetooth
    Keyboard serial: N/A charge: N/A status: discharging
  Device-2: ps-controller-battery-ac:36:1b:3f:f3:1e model: N/A serial: N/A
    charge: N/A status: full
  Info: model: AMD Ryzen 9 7940HS w/ Radeon 780M Graphics bits: 64 type: MT MCP
    arch: Zen 4 gen: 5 level: v4 note: check built: 2022+ process: TSMC n5 (5nm)
    family: 0x19 (25) model-id: 0x74 (116) stepping: 1 microcode: 0xA704103
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 649 high: 1397
    min/max: 400/5423:5263:5743:6228:5903:6067:5583 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 1397 3: 400
    4: 400 5: 400 6: 400 7: 400 8: 400 9: 1397 10: 400 11: 400 12: 400 13: 1396
    14: 400 15: 1397 16: 400 bogomips: 127792
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS; IBPB: conditional;
    STIBP: always-on; RSB filling; PBRSB-eIBRS: Not affected; BHI: Not
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 33 [Radeon RX 7700S/7600/7600S/7600M XT/PRO W7600]
    vendor: Framework driver: amdgpu v: kernel arch: RDNA-3 code: Navi-33
    built: 2023+ pcie: gen: 4 speed: 16 GT/s lanes: 8 ports: active: none
    empty: DP-1,eDP-1 bus-ID: 03:00.0 chip-ID: 1002:7480 class-ID: 0300
  Device-2: AMD Phoenix1 vendor: Framework driver: amdgpu v: kernel
    arch: RDNA-3 code: Phoenix process: TSMC n4 (4nm) built: 2023+ pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: eDP-2 empty: DP-2, DP-3, DP-4,
    DP-5, DP-6, DP-7, DP-8, DP-9 bus-ID: c5:00.0 chip-ID: 1002:15bf
    class-ID: 0300 temp: 44.0 C
  Device-3: Realtek Laptop Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1:2 chip-ID: 0bda:5634
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1680x1050 s-dpi: 96 s-size: 444x277mm (17.48x10.91")
    s-diag: 523mm (20.6")
  Monitor-1: eDP-2 mapped: eDP-1 model: BOE Display 0x0bc9 built: 2022
    res: 1680x1050 hz: 165 dpi: 124 gamma: 1.2 size: 345x215mm (13.58x8.46")
    diag: 407mm (16") ratio: 16:10 modes: max: 2560x1600 min: 640x480
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: radeonsi device: 2 drv: swrast surfaceless: drv: radeonsi x11:
    drv: radeonsi inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.6-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
    gfx1103_r1 LLVM 17.0.6 DRM 3.54 6.6.30-2-MANJARO) device-ID: 1002:15bf
    memory: 500 MiB unified: no
  API: Vulkan v: 1.3.279 layers: 8 device: 0 type: integrated-gpu name: AMD
    Radeon Graphics (RADV GFX1103_R1) driver: mesa radv v: 24.0.6-manjaro1.1
    device-ID: 1002:15bf surfaces: xcb,xlib device: 1 type: discrete-gpu
    name: AMD Radeon RX 7700S (RADV NAVI33) driver: mesa radv
    v: 24.0.6-manjaro1.1 device-ID: 1002:7480 surfaces: xcb,xlib
  Device-1: AMD Navi 31 HDMI/DP Audio vendor: Framework driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8 bus-ID: 03:00.1
    chip-ID: 1002:ab30 class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio vendor: Framework
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: c5:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Framework
    driver: snd_pci_ps v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
    snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci, snd_rpl_pci_acp6x,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh pcie: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: c5:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-4: AMD Family 17h/19h HD Audio vendor: Framework
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: c5:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Device-5: Sony DualSense wireless controller (PS5)
    driver: playstation,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-2.3:5 chip-ID: 054c:0ce6 class-ID: 0300
  API: ALSA v: k6.6.30-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 05:00.0
    chip-ID: 14c3:0616 class-ID: 0280
  IF: wlp5s0 state: down mac: <filter>
  Device-2: Sony DualSense wireless controller (PS5)
    driver: playstation,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-2.3:5 chip-ID: 054c:0ce6 class-ID: 0300
  Device-3: Realtek USB 10/100/1G/2.5G LAN driver: r8152 type: USB rev: 3.2
    speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 6-1:2 chip-ID: 0bda:8156
    class-ID: 0000 serial: <filter>
  IF: enp199s0f3u1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager,systemd-timesyncd
  Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:9 chip-ID: 0e8d:e616
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11 status: discoverable: no pairing: no class-ID: 6c010c
  Local Storage: total: 1.84 TiB used: 793.82 GiB (42.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:5 vendor: Western Digital model: WD PC
    SN740 SDDPTQD-1T00 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 73110000 temp: 40.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital
    model: WD BLACK SN850X 1000GB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 620361WD temp: 39.9 C scheme: GPT
  ID-1: / raw-size: 100 GiB size: 97.87 GiB (97.87%) used: 16.85 GiB (17.2%)
    fs: ext4 dev: /dev/nvme1n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1
  ID-3: /home raw-size: 791.01 GiB size: 777.52 GiB (98.29%)
    used: 358.1 GiB (46.1%) fs: ext4 dev: /dev/nvme1n1p3 maj-min: 259:3
  Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
    zswap: yes compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 40 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme1n1p4 maj-min: 259:4
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  GPU: device: amdgpu temp: 44.0 C mem: 55.0 C fan: 0 watts: 0.00
    device: amdgpu temp: N/A V: 5.00
  Memory: total: 32 GiB note: est. available: 30.55 GiB used: 4.34 GiB (14.2%)
  Processes: 378 Power: uptime: 12m states: freeze,mem,disk suspend: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume
    image: 12.2 GiB services: org_kde_powerdevil, power-profiles-daemon,
    upowerd Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1368 libs: 435 tools: pamac pm: flatpak pkgs: 0
    Compilers: clang: 17.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9 default: Bash
    v: 5.2.26 running-in: konsole inxi: 3.3.34

EDIT: Some positive news regarding this update, it does appear to resolve a couple of my issues with the 5-13 release…

fixes from 5-13 release
  1. Desktop icons failed to retain their place on reboot. This is an issue under both Wayland and X11
  2. “KCM => Wifi & Networking => Firewall” (plasma-firewall) is not prompting for credentials, nor displaying proper uwf status/policies in effect like the previous version, and suggests the firewall is disabled. If I try check the box to enable the firewall, it prompts for credentials, passes, and tosses and error Error enabling firewall: An error occurred in command 'setStatus':

I had the same issue, but for me it is easily resolved by manually enabling my external monitor in the system setting: system settings > display & monitor > display configuration. In the last window that appears, select your external monitor from “Device” drop-down list, and then check Enabled. This should be a temporary (although valid) solution though because the external monitor configuration should be accessible through Meta+P keyboard shortcut, which used to work, but no longer does after the latest update. So yeah, this has to be a bug.