Switching to TTY from GUI yields a black screen without any text or login prompt

This issue occurred before the recent update on May the 14th and persists until now even after the update, if I try switching to a TTY with control+alt+F3/F4/F5 etc… it switches but the screen goes black and stays that way. There is no login prompt or any text just a black blank screen… The only thing I can do at this point is press control+alt+F2 to go back to the GUI. I tried waiting for several minutes to see if the text or login prompt would appear in the TTY but still nothing happens.

If anyone knows how to diagnose or fix this problem I would really appreciate it…

Output of inxi --admin --verbosity=7 --filter --no-host --width :

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "en_GB.UTF-8",
        LC_NAME = "en_GB.UTF-8",
        LC_MONETARY = "en_AE.UTF-8",
        LC_PAPER = "en_GB.UTF-8",
        LC_IDENTIFICATION = "en_GB.UTF-8",
        LC_TELEPHONE = "en_GB.UTF-8",
        LC_MEASUREMENT = "en_AE.UTF-8",
        LC_TIME = "en_AE.UTF-8",
        LC_NUMERIC = "en_GB.UTF-8",
        LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_GB.UTF-8").
  Kernel: 6.6.30-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=02464895-dc4c-472d-b07a-41ae11fd7d2a rw nvidia-drm.modeset=1
    apparmor=1 security=apparmor udev.log_priority=3 intel_iommu=on iommu=pt
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Desktop System: ASUS product: All Series v: N/A
    serial: <superuser required>
  Mobo: ASUSTeK model: Z97I-PLUS v: Rev X.0x serial: <superuser required>
    part-nu: All uuid: <superuser required> UEFI: American Megatrends v: 2302
    date: 11/04/2014
  Message: No system battery data found. Is one present?
  System RAM: total: 16 GiB available: 15.57 GiB used: 2.77 GiB (17.8%)
  Message: For most reliable report, use superuser + dmidecode.
  Array-1: capacity: 16 GiB slots: 2 modules: 2 EC: None
    max-module-size: 8 GiB note: est.
  Device-1: DIMM_A1 type: DDR3 detail: synchronous size: 8 GiB
    speed: 1867 MT/s volts: curr: 2 min: 2 max: 2 width (bits): data: 64
    total: 64 manufacturer: Kingston part-no: KHX1866C10D3/8G serial: <filter>
  Device-2: DIMM_B1 type: DDR3 detail: synchronous size: 8 GiB
    speed: 1867 MT/s volts: curr: 2 min: 2 max: 2 width (bits): data: 64
    total: 64 manufacturer: Kingston part-no: KHX1866C10D3/8G serial: <filter>
  Info: model: Intel Core i5-4690K bits: 64 type: MCP arch: Haswell gen: core 4
    level: v3 note: check built: 2013-15 process: Intel 22nm family: 6
    model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 3049 high: 3900 min/max: 800/3900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 900 2: 3900 3: 3900
    4: 3498 bogomips: 27994
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht ibpb ibrs ida invpcid lahf_lm lm mca mce md_clear mmx
    monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good
    sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
    tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic
    xsave xsaveopt xtopology xtpr
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines; IBPB: conditional; IBRS_FW;
    STIBP: disabled; RSB filling; PBRSB-eIBRS: Not affected; BHI: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: ASUSTeK driver: nvidia
    v: 550.78 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
    (as of 2024-04; EOL~2026-12-xx) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-2019 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: none off: DVI-I-1 empty: DP-1,DVI-D-1,HDMI-A-1
    bus-ID: 01:00.0 chip-ID: 10de:13c2 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 120 s-size: 406x229mm (15.98x9.02")
    s-diag: 466mm (18.35")
  Monitor-1: DVI-I-1 note: disabled model: BenQ XL2430T serial: <filter>
    built: 2014 res: 1920x1080 dpi: 92 gamma: 1.2 size: 531x298mm (20.91x11.73")
    diag: 609mm (24") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce GTX 970/PCIe/SSE2
    memory: 3.91 GiB
  API: Vulkan v: 1.3.279 layers: 8 device: 0 type: discrete-gpu
    name: NVIDIA GeForce GTX 970 driver: nvidia v: 550.78 device-ID: 10de:13c2
    surfaces: xcb,xlib
  Device-1: Intel 9 Series Family HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8ca0
    class-ID: 0403
  Device-2: NVIDIA GM204 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fbb class-ID: 0403
  Device-3: KEF X300A Speaker driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:4
    chip-ID: 27ac:1002 class-ID: 0300
  API: ALSA v: k6.6.30-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
    status: active 2: pipewire-media-session status: active 3: pipewire-alsa
    type: plugin 4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli
  Device-1: Intel Ethernet I218-V vendor: ASUSTeK driver: e1000e v: kernel
    port: f040 bus-ID: 00:19.0 chip-ID: 8086:15a1 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Broadcom BCM4352 802.11ac Dual Band Wireless Network Adapter
    vendor: ASUSTeK driver: wl v: kernel modules: bcma pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 14e4:43b1 class-ID: 0280
  IF: wlp3s0 state: down mac: <filter>
  Info: services: NetworkManager,systemd-timesyncd
  WAN IP: <filter>
  Device-1: ASUSTek BCM20702A0 driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-11:5 chip-ID: 0b05:17cf
    class-ID: fe01 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 2.73 TiB used: 2.37 TiB (87.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000BX500SSD1
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 056 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD2003FZEX-00Z4SA0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: 1A01 scheme: GPT
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GH24NSC0 rev: LK00
    dev-links: cdrom
  Features: speed: 12 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 771.09 GiB size: 757.92 GiB (98.29%)
    used: 649.55 GiB (85.7%) fs: ext4 dev: /dev/sda5 maj-min: 8:5 label: N/A
    uuid: 02464895-dc4c-472d-b07a-41ae11fd7d2a
  ID-2: /boot/efi raw-size: 400 MiB size: 399.2 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/sda4 maj-min: 8:4 label: NO_LABEL
    uuid: ABB8-0FB2
  ID-3: /run/media/name/9CCEA022CE9FF2AE raw-size: 159.91 GiB
    size: 159.91 GiB (100.00%) used: 149.03 GiB (93.2%) fs: ntfs dev: /dev/sda3
    maj-min: 8:3 label: N/A uuid: 9CCEA022CE9FF2AE
  ID-4: /run/media/name/New Terra raw-size: 1.82 TiB size: 1.79 TiB (98.37%)
    used: 1.59 TiB (89.1%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: New Terra
    uuid: 8e60aed3-da3e-4fe9-bb3c-a34cdcc1361e
  Alert: No swap data was found.
  ID-1: /dev/sda1 maj-min: 8:1 size: 100 MiB fs: vfat label: N/A
    uuid: DA9B-6C6C
  ID-2: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  Hub-1: 1-0:1 info: full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-2: 1-1:2 info: Intel ports: 6 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s)
    lanes: 1 mode: 2.0 chip-ID: 8087:8009 class-ID: 0900
  Hub-3: 2-0:1 info: full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Hub ports: 8 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 8087:8001
    class-ID: 0900
  Hub-5: 3-0:1 info: hi-speed hub with single TT ports: 14 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 3-2:2 info: SteelSeries ApS Kana v2 Gaming Mouse type: HID,mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 100mA chip-ID: 1038:137a class-ID: 0301
  Device-2: 3-5:3 info: Cooler Master Storm Quick Fire TK 6keys
    type: keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 1.1
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 100mA
    chip-ID: 2516:0011 class-ID: 0300
  Device-3: 3-10:4 info: KEF X300A Speaker type: audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 1.1
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 100mA
    chip-ID: 27ac:1002 class-ID: 0300
  Device-4: 3-11:5 info: ASUSTek BCM20702A0 type: Bluetooth driver: btusb
    interfaces: 4 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1
    chip-ID: 0b05:17cf class-ID: fe01 serial: <filter>
  Hub-6: 4-0:1 info: super-speed hub ports: 6 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 52.0 C mobo: N/A gpu: nvidia temp: 63 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 34%
  Processes: 247 Power: uptime: 4m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.18 GiB services: org_kde_powerdevil,upowerd
    Init: systemd v: 255 default: graphical tool: systemctl
  Packages: 1737 pm: pacman pkgs: 1629 libs: 445 tools: pamac pm: flatpak
    pkgs: 108 Compilers: clang: 17.0.6 gcc: 13.2.1 alt: 11/12 Shell: Bash
    v: 5.2.26 running-in: yakuake inxi: 3.3.34

1 Like

Just to eliminate a variable, what if you change the locale values for


to en_GB.UTF-8 (in KDE system settings, I assume)?

en_AE.UTF-8 does not seem to be one of the available locales in my /etc/locale.gen. I seem to recall reading posts where locale issues manifest in weird ways.


Thanks for replying! So I changed the locale values in KDE system settings as you suggested and restarted for it to take effect… (above is the output of locale in terminal after the changes) but still no TTY screen, it remains black… at least we got one thing out of the way I guess…

Maybe check the logs with

journalctl -b _COMM=agetty

and after you have tried to switch to tty and back.

1 Like

Hi cscs :wave:

Hope all is well with you.

This is the output: agetty[1628]: failed to open credentials directory

Thanks, you too.

That can be ignored.

Have you enabled KMS?

This would probably have been handed down in pacnews, but here is the guide:


Make sure that kms is included in the HOOKS and nvidia nvidia_modeset nvidia_uvm nvidia_drm is included in the MODULES of /etc/mkinitcpio.conf

Additionally for DRM KMS set nvidia_drm.fbdev=1 on the CMDLINE in /etc/default/grub.

After both both of those configurations run

sudo mkinitcpio -P
sudo grub-mkconfig -o /boot/grub/grub.cfg

And reboot.


If its true you have not managed your pacnews here is the wiki for that:


Woooohoooo~!!! IT WORKED!!! :partying_face: :tada:


You sir… really are Batman! :bat:


These were correct as you said I checked the mkinitcpio.conf and all the Hooks and modules were already there exactly as you mentioned…

HOWEVER! (The plot thickens…)

^ This!!! This was the culprit! before it was nvidia-drm.modeset=1 instead and changing this line to what you said above fixed things.

Aye I just done this recently with help and guidance from Aragorn… :blush: :metal:

THANK YOU :index_pointing_at_the_viewer: so much kind sir! You have made my TTY shine bright again like the Manjaro constellation in the night sky! (Dunno any constellation names but I guess Manjaro would be a nice name for one :grin:)


Ah, so you did have it set. Just with the slightly older DRM kernel mode setting.

Pretty much if you are on nvidia driver 545+ then you can use the nvidia_drm.fbdev=1.
Its technically experimental, but if nothing goes wrong then huzzah.
(All the more likely on 550+ which you have)

Extra note. The new parameter should actually be in addition to the old one.
But dont fret - the one you removed is already set in the module config files in /etc/X11 provided by mhwd.

Im glad it all worked out.
Happy penguins.


Thank you once again for your time and efforts as well as all the relevant links you posted that explains what’s what and who’s who… :+1:

May you live long and arch linux… :vulcan_salute:

1 Like