[Stable Update] 2024-05-13 - Kernels, Plasma 6, Gnome 46, LxQT 2.0, Nvidia, Pacman

XFCE updated fine, followed upgrade to Python 3.12, which is good since I messed up the proper maintenance of python packages for 3.8, 3.9, 3.10 and now have those directories with packages that I don’t know how to deal with.
So far no issues, and Linux 6.9 seems to be stable and isn’t causing the high CPU temps like in 6.7

I confirm that plasma-firewall thinks ufw is disabled although I verified it is enabled using systemctl status ufw.

When I try to “enable” the firewall using plasma-firewall in the System Settings GUI I get an error:

Error enabling firewall: An error occurred in command 'setStatus':

How to fix `plasma-firewall` error in System Settings GUI when running `ufw`

Open /usr/lib/kde_ufw_plugin_helper.py and change the first line from #!/usr/bin/python3.11 to #!/usr/bin/python3.12. This fixed the issue for me immediately and makes sense since Manjaro is currently on Python 3.12.


This fixed the issue for me, too.

1 Like

May I ask what is a total noob question? I’m use BTRFS and a snapshot is automatically taken prior to any update/upgrade. If I perform this latest system update and things go completely south, is it really as easy to recover as I think?

  1. Reboot computer
  2. At Grub menu, reboot from a snapshot
  3. Once the snapshot boots, run Timeshift and restore the same snapshot.
  4. Reboot
  5. From Grub menu, select the normal Manjaro boot option.
  6. Computer boots successfully in pre-update state and I give a sigh of relief.

I’ve done some searching on this and have not found a ton of clarity on restoring from a BTRFS snapshot, and I just want to be prepared. I acknowledge that I should probably know this already as I deliberately chose BTRFS for its recovery capabilities.

Thank you, and happy updating.

Ah, great! There already was an update to libplasma, looks like it fixed the problem.

195 posts were split to a new topic: Sublime text does not detect the dark theme on GNOME

7 posts were split to a new topic: Multiple issues with stable update

I’m getting this error, too. I try installing the 6.6 or 6.8 kernel as suggested and I keep getting this error message so the whole process stops. Do I need to uninstall the nvidia driver first?

hi! I have the same problem. did you manage to solve it?

1 Like

Im on Manjaro KDE and I can’t even load the tty in the first place. I press control,alt,F3 or any other function Key and all I get is a black background. This is the first time this happens and I don’t even know where to begin.

This is before updating anything. I want to go into the tty to do the update as is recommended for this update.

1 Like

No issues at all from a month old install of Gnome. thanks for all the work over the years. I really appreciate it!


Hello everyone,

I would like to express my gratitude. Before the update, I tried everything to achieve the same sound quality I had on Windows with my Astro A40. After the update, the quality improved significantly. Thank you very much!


All pretty smooth on my KDE Plasma system. Although I had a number of now unsupported Plasma widgets, they didn’t actually cause problems.

Just a pity I now need to roll my own replacement for the extremely useful popup launcher, which I have half a dozen instances of.

1 Like

No big issues so far on my installation. I went down the risky route of not resetting Plasma settings, just logged out, logged in through a tty, created a snapshot, removed some eventually-problematic AUR packages like linux-firmware-git, ran pacman -Syu and rebooted. (Also updated the kernel to 6.9.0-1 later on)

Things that I encountered:

  • Window Title Widget didn’t work anymore. Replaced it with a Plasma 6 port.
  • Font in Konsole got reset to a non-nerd-font (already mentioned here in the thread). Needed to re-set fixed-width-font in System Settings to what I had before (Hack Nerd Font).
  • Some python venv of mine wasn’t able to find packages anymore (somebody posted a similar error here in the thread) Not sure how python updates are usually handled but I would expect pip-packages to be re-installed or if possible - copied over from the previous version.
  • Found quite some orphaned packages and selectively removed all connected to kde/plasma

Overall, based on what I read here I was already nervous but seems like I got lucky today :smiley:

Update: Had to remove all links since it’s my first post but it should still be easy to find out what I’m referring to


Ok a crazy thing happened, I was actually able to do the system update (KDE) logged in normally without the tty. I know it was a big risk but it somehow worked out… Miraculously nothing is broken so far as I can see.

However I still can’t access the tty, neither before updating nor after. It just gives a blank screen when I try. Anyone have any ideas what could be causing this?

1 Like

A nooby answer to that too: In the default case, yes. There is however a daily max for the number of Timeshift snapshots, so if you made some snapshots today already, this may get skipped.

There should be some pop up message: “You are running a snapshoft. Do you want to restore it?”

If you can still boot normally you can also restore a snapshot from the Timeshift gui. It will inform you that it’s going to boot into this snapshot on the next reboot.

Thank you, hope this will work to my liking :slight_smile:

1 Like

I had the same problem. I started to reinstall with one package, suprisingly it solved the problem for most other packages…

sudo pamac reinstall firefox


I’m a little bit confused about the multiple information concerning AUR and Python 3.12. The first post says in ‘Python 3.12 info’ you should

pacman -Qoq /usr/lib/python3.11/
pamac build $(pacman -Qoq /usr/lib/python3.11)

In Post #2Python interpreter upgrade’ links to [HowTo] Python upgrade: reinstall AUR and pip packages where it says:

pip freeze --user > OLD_PIP_pkgs.txt
pacman -Qmq $(pacman -Qoq /usr/lib/python3.${OLD}/site-packages) > OLD_AUR_pkgs.txt

pacman -Qoq /usr/lib/python3.11/ in Post #1 results in 210 files while pacman -Qmq $(pacman -Qoq /usr/lib/python3.${OLD}/site-packages) returns only on AUR package.

What’s the right thing to do?

3 systems, respectively running kernel 5.15, 6.1 and 6.6, all on Xfce, all good.

As always, thank you very much Manjaro developers.

Are you on a laptop? CTRL+ALT+F3/4/5/6
Should work on desktops. On laptops maybe try to mess with Fn (function key) a bit?