[Stable Update] 2024-01-13 - Kernels, Systemd, Qt5, Mesa, Dbus, Firefox, Thunderbird

Exactly, its also not the first time i had saw this error.

i ended up keeping it,update went fine.

Your use of “original” is confusing.

My suggestion: “Original” file is the one in the old package version. The “current” file is the original modified by the user or some util. The pacnew is then… well the file in the new package version.

The Steam client had an update yesterday.
Since that the display issue is also gone.

Only to you, it seems. In context, the original is that which is to be modified; the file in situ; and the new file – the .pacnew – contains the new information.

You could think of that

  • old original file → The default file that would exist if it was current and never changed by the user.
  • local file → The file that was on this PC immediately before the update
  • suggested file → This is the suggestion to switch to after its changes have been reviewed

I don’t mean to say that my suggestions are the best. Choosing good names can help prevent misunderstandings. :footprints:

1 Like

After applying this update, xfwm4 freezes a minute after logging in and starting Firefox. If I’m lucky, I can login in with Ctrl-Alt-F2 and run pkill -9 xfwm4 and then Ctrl-Alt-F7 to get an unfrozen terminal. Sometimes I am not lucky and the system freezes and requires a hard power cycle.

Can you help me localize this behavior? I am not sure what commands to run to test this.

I’ve now updated mkinitcpio to 37.2-1.6, which fixes the extramodules situation and also kms hook for kernels older than 5.17.


Did anyone update mkinitcpio to 37.2-1.6? On 2024-01-16 I received an update to 37.1-4 and has worked fine.

EDIT: I installed it, rebooted, and everything is ok.

1 Like

Yeah I noticed sleep, in my case, auto hybrid-sleep, issues with KDE (no more display output after waking up) before this update so I hope the issue will be wiped after this update.

@philm @Yochanan do you have any tips for me to fix the problem? i still can’t install the update :confused:
Thanks in advance

Please create a Support topic if you need further assistance.

was this fix already?

I updated to mkinitcpio 37.2-1.6 and the next day my pc wouldn’t pass the boot screen so I had to downgrade it

is it safe to update again?

![Screenshot from 2024-01-18 21-21-15|690x388](upload://ak6CZQHWbchiJsLk3WqvUSPIIEL.png)

Recently had an issue where anytime I try to unmount my external drive, it prompts me to put in my sudo password when it didn’t used to do that. It works when I put it in, and it’s only been the case with my external drive when it’s hooked up on boot, as opposed to plugging it in after boot. And it only asks for it the first time after a boot up, but I still don’t know what caused it when it didn’t always do this.

EDIT: Just to add on, this isn’t my system drive, it’s just an external with a bunch of files for more storage, and this wasn’t used on Windows either, this started happening a couple days ago.

EDIT: Further testing, this happened on multiple external drives, including a fresh one I just got, and disabling “mount at system startup” and rebooting stopped it from prompting me for a password, on both mount and unmount, but I still don’t know what caused this in the first place.

Screenshot from 2024-01-18 21-17-07

1 Like

I have the same issue even on drives that auto-mount from KDE.
This issue started today and for now it occurs only on local drives that are neither the root drive nor the primary drive.

I have this too when mounting LUKS partitions. This one is an NVMe, so isn’t even ‘external’.

Same problem here (KDE) after installing manjaro-hotfixes 2024.1-2.

1 Like

Yes, the recent update of manjaro-hotfixes is indeed the reason why the authentication prompt suddenly appears now when trying to mount a drive!

It was supposed to delete obsoleted and deprecated config options by removing those 2 files:

$ pamac list -f manjaro-hotfixes

Discussion where the decision was made: https://forum.manjaro.org/t/stable-update-2024-01-13-dbus-broker-units-has-broken-light-display-manager/155093/14

The problem is that in the second file, there was also the rules needed to mount a drive/partition as a normal user…

So anybody who wants to solve this and get the old behavior just need to add:

polkit.addRule(function(action, subject) {
    if (action.id.indexOf("org.freedesktop.udisks2.") == 0 && subject.isInGroup("wheel")) {
        return polkit.Result.YES;

in a file in the /etc/polkit-1/rules.d/ directory. You can name it as the old one that was deleted (99-manjaro.rules) or anything else following the same syntax (I’m using 10-admin.rules on my other Linux systems) and after a reboot, it should be solved.


Yes , this did the trick. For me this fixed the issue.
Thank you.