[Stable Update] 2024-01-13 - Kernels, Systemd, Qt5, Mesa, Dbus, Firefox, Thunderbird

No luck, maybe a server down?

$ pamac update --force-refresh
Synchronizing package databases...
Refreshing core.db...                                                                                                         
Refreshing extra.db...                                                                                                        
Refreshing multilib.db...                                                                                                     
Refreshing core.files...                                                                                                      
Refreshing extra.files...                                                                                                     
Refreshing multilib.files...                                                                                                  
Failed to synchronize AUR database                                                                                            
Nothing to do.
Transaction successfully finished.

If it was pacman, you could reset the mirror list:

sudo pacman-mirrors -c all && sudo pacman -Syu

That would not help in this case as the trouble seems to be with the AUR database.

Excluding the AUR should allow it to complete without error; and again that only confirms it’s AUR related.

pamac update --no-aur --force-refresh

I suspect it might be certificate related.
Do you have yay installed? Try with that.


After this update my system hanged on boot on either kernel 6.6.10-1 or 6.1.71-1.
By unsetting “quiet splash” in the kernel parameters at boot I could see the error

Failed to start Samba NMB

similarl to this topic Boot stuck on [FAILED] SMB/NMB after 20220123 upgrade .

Suspecting something else I disabled nvidia_drm.modeset=1 and the system started booting again.
So I can boot and the system works as expected, but without this parameter my laptop’s 2060 consumes a ton of power.

Does anyone have a solution or a similar problem ? The system worked fine before the update.

1 Like

After the update of telegram-desktop to 4.14.4-1, it no longer launches. The error it gives on the terminal is

telegram-desktop: symbol lookup error: telegram-desktop: undefined symbol: XXH64_reset

I think it happened only on my Manjaro KDE setup, I don’t remember having this problem on my other Manjaro GNOME machine which I think I’ve updated earlier.

Hit the numlock key right after seeing Manjaro with the three large dots to then get the login screen. Otherwise, the Manjaro with the three large dots disappears and is replaced with three small dots requiring a CTRL-ALT-DELETE to reboot.

I solved the problem with

==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'xhci_pci'

by installing upd72020x-fw and linux-firmware-qlogic.
but I still can’t log in after the update. Nevertheless, I cannot log in after the update. This error message appears when booting up, see screenshot.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Have the login problem on the machine where the kernel was upgraded from 6.1 to 6.6. The machine that has a clean install with kernel 6.6 does not have this login problem.

Fixed with gnome-shell 1:45.3-1.

1 Like

Looks like mkinitcpio-37.2 got downgraded to mkinitcpio-37.1 a few minutes ago.
It happened while I was downloading :

error: failed retrieving file 'mkinitcpio-37.2-1-any.pkg.tar.zst' from gsl-syd.mm.fcix.net : The requested URL returned error: 404

After I looked at a few other mirror sites in a browser, it seemed to be a downgrade,
so I ran pacman -Sy again, and then pacman -Suuw was able to finish OK.

1 Like

correct, as we are working on this issue: Mkinitcpio update 37.2-1 break the System


Strictly speaking, that’s not true. The /boot directory and the EFI partition are both only accessed by maintenance utilities such as grub-install, update-grub and mkinitcpio.

The system itself does not access either /boot or /boot/efi during the boot process.

  • In the event of a legacy BIOS boot, the BIOS reads the MBR, which loads the first stage of GRUB, and GRUB itself will then either read the raw blocks of the /boot partition (on MSDOS-style partitioned drives) or of the unformatted bios_grub partition (on GPT-style partitioned drives) in order to load its intermediary stage. This intermediary stage then contains a filesystem driver and will then mount the /boot partition as its own root partition. Upon manually or automatically choosing a GRUB menu entry, the compressed kernel image and the initramfs are read into RAM and decompressed. From that point onward, /boot is no longer being accessed by the system.

  • In the event of a native UEFI boot, the UEFI reads the chosen or default EFI executable into RAM and executes it. The UEFI-native version of GRUB installs such an executable in the EFI system partition — both in /boot/efi/EFI/boot and in /boot/efi/EFI/manjaro — and from there on, GRUB will, by way of a filesystem driver, mount /boot as its own root filesystem and load the (chosen or default) compressed kernel image and the initramfs into memory. Once again, as soon as the kernel image is decompressed and begins booting, it no longer accesses either the ESP or the /boot directory.


For 2. VNC output only 4:3 and cut off:

Uninstalling Krfb, deleting the config file (/home/user/.config/krfbc) and reinstalling the package solved this issue…

Still no clue about the Steam display issue though.

The error just vanished 20min ago, before it also appeares on my my second device.
Maybe it was a server issue.

I also think it was mainly related to AUR.

Thanks anyways.

I always do, so I can see there the fails pop up, I remove quiet and splash…good luck

1 Like

Hey, I have mkinitcpo 37.2-1 installed. And my system boots.
Just a silly question I know → should I downgrade just to be save?
Or should I don’t touch something which seems to be fine :smiley:

Thanks in advance.

I have found my answer:

1 Like

That was always likely. Though I since found Failed to synchronize AUR database (albeit a year old) which might have been related.

As if by magic!

Exactly, its also not the first time i had saw this error.

i ended up keeping it,update went fine.

Your use of “original” is confusing.

My suggestion: “Original” file is the one in the old package version. The “current” file is the original modified by the user or some util. The pacnew is then… well the file in the new package version.

The Steam client had an update yesterday.
Since that the display issue is also gone.