[Stable Update] 2024-05-13 - Kernels, Plasma 6, Gnome 46, LxQT 2.0, Nvidia, Pacman

Hello community, here we are for our massive first Year 2024 update. After two months of work we are happy to finally release Manjaro 24.0 Wynsdey to the world. This package includes over 8166 package updates in multiple areas. For desktop environments we have now Plasma 6, Gnome 46 and LxQT 2.0 to name a few. Another cool thing is that we are the first distro shipping Linux 6.9 Kernel as default option. Those who rely on stability can still have install medias with LTS Kernels such as 6.6 and 6.1. A lot of updates to the graphics stack like Mesa and drivers with this update. Also in Office space we have the latest LibreOffice updates such as Mozilla’s Firefox and Thunderbird. If you emulate computers the latest VirtualBox is included also with this one.

We are looking forward to your feedback when our stable install medias of Manjaro 24.0 Wynsdey got released …

Current Promotions

  • Find out all about our current Gaming Laptop the Hero with Manjaro pre-installed from Spain!
  • Protect your personal data, keep yourself safe with Surfshark VPN: 85% OFF + 2 mo. FREE

Recent News

Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates

  • Kernel updates
    • including linux-firmware updates
  • Core packages
  • Desktop updates
  • Office Updates
  • Graphic related
  • Gaming related
    • inputplumber 0.21.2
    • hhd 2.6.4
    • hhd-ui 2.2.3
    • adjustor 2.1.5
    • HandyGCCS supports now GDF-G2102_F03D_V1.0_240314b MCU firmware
    • gamescope plus got renewed to
    • steam-deckify defaults now to Wayland also on the Plasma 6 session
  • Package Management related
    • pacman got updated to 6.1.0, which includes dropped SyncFirst option
      • all packages got updated, including libpamac. However there seems to be an issue which may freeze the UI of Pamac
    • libpamac gained support to use libalpm internal download engine for downloading files
  • OS Installer
  • Virtualization
    • VirtualBox is now at 7.0.18
    • Wine is updated to 9.8
    • New major release of QEMU 9.0.0
  • Misc
    • We dropped various packages related to unmaintained community editions; i.e, Awesome, Bspwm, Budgie, Deepin, MATE, Openbox, etc.)
    • various Python and Haskell package updates and fixes
    • Python 3.12 rebuilds
    • Kodi updated to 21.0

A list of all package changes can be found here

Additional Info

Python 3.12 info

:information_source: You will need to rebuild any AUR Python packages that install files to site-packages or link to libpython3.11.so. :information_source:

Print a list of of packages that have files in /usr/lib/python3.11/ :

pacman -Qoq /usr/lib/python3.11/

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.11)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.

Use rebuild-detector to see if anything else needs to be rebuilt:

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.313
  • linux54 5.4.275
  • linux510 5.10.216
  • linux515 5.15.158
  • linux61 6.1.90
  • linux66 6.6.30
  • linux68 6.8.9
  • linux69 6.9.0
  • linux61-rt 6.1.83_rt28
  • linux66-rt 6.6.23_rt28
  • linux67-rt 6.7_rt6

Package Changes (Tue May 7 14:51:30 CEST 2024)

  • testing core x86_64: 22 new and 23 removed package(s)
  • testing multilib x86_64: 28 new and 28 removed package(s)
  • testing extra x86_64: 1070 new and 1058 removed package(s)

Overlay Package Changes

  • testing core x86_64: 26 new and 35 removed package(s)
  • testing extra x86_64: 123 new and 129 removed package(s)

A list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2024-05-13

  • IMPORTANT → Linux 6.7 is EOL

    Linux 6.7 is EOL and will - at some point - be removed from the repo.

    If you use Linux 6.7 and Nvidia or inside a virtual machine, it is of great importance, that you install Linux 6.6 to avoid driver problems.

    sudo mhwd-kernel -i linux66
Python interpreter upgrade

If you have a lot of pip/AUR packages to upgrade to Python 3.12, read this.

If you installed python312 from the AUR, you need to uninstall it before running this update.

Qemu: MacOS is not bootable with 9.0

Due to a bug MacOS is not bootable with 9.0: [9.0.0] qemu breaks mac os vm (#2334) · Issues · QEMU / QEMU · GitLab
Workaround: remove virtio-serial and org.qemu.guest_agent.0 from libvirt XML until bug will be fixed.

If you use KDE you better logout of your session and do the update via Pacman or Pamac in tty.

Also I would, before the update:

  • make a Timeshift snapshot if you ain’t got no recent one.
  • ( export content of widgets like your radio stations in Advanced Radio Player or your Podcasts in Kasts or any podcatcher as a backup )
  • make a fresh boot, but before that even:
  • System Settings > Appearance > Global Theme > set to Breath and tick both options for defaults
  • You might go to the hamburger menu in System Settings and look what changes you made away from default by selecting: Highlight Changed Settings and see if you want to make the effort to get back more defaults
  • System Settings > Workspace > Startup and Shutdown: SDDM defaults and Desktop Session: Start with empty session
  • disable all user-installed widgets that are still on your desktop, panels and even lock screen or wallpaper (e.g. Active Blur)
  • Export your custom shortcuts or mouse gestures in SS> Workspace > Shortcuts
  • Reboot, Timeshift snapshot, reboot
  • then do not log in, do the update via tty (CTRL+ALT+F3, same with F2 gets you back)
  • reboot, login, check through System Settings
  • reboot again
  • enjoy 8)


  • look for Plasma 6 replacements for your widgets after the install
  • in case you have Github-installed theming: uninstall the KDE5-version of klassy, install the Plasma 6 version of klassy, maybe reinstall lightly

(greetings, @1efaf7d71a8637c6800a , PS: these are just my thoughts; I didn’t do this update yet!)

How to fix `plasma-firewall` error in System Settings GUI when running `ufw`

Open /usr/lib/kde_ufw_plugin_helper.py and change the first line from #!/usr/bin/python3.11 to #!/usr/bin/python3.12. This fixed the issue for me immediately and makes sense since Manjaro is currently on Python 3.12.

Xfce has inconsistent themes for Qt applications

Qt 6 is now default but some apps are still using Qt 5
To restore the look of QT apps after this update

pamac install kvantum-qt5

Manjaro-settings-manager has light theme instead of dark


DKMS fails for v4l2loopback on 6.8 kernel

DKMS fails for v4l2loopback on 6.8 kernel (#2) · Issues · Arch Linux / Packaging / Packages / v4l2loopback · GitLab

issues with auto-mount of ntfs filesystem using Kernel 6.8

The kernel changed default ntfs driver from FUSE one to ntfs3.
These two are not fully compatible, mainly as far as mount options go. If you have custom mount options in the fstab (or any other application, such as VeraCrypt) they need to be changed.

Mount fails with: Device or resource busy
DMesg reports: Can't open blockdev

Migrate your mount options. For me the changes were:

  • allow_otherumask=000
  • default_permissions → [drop]
  • user_id=1000uid=1000
  • group_id=1000gid=1000


gnome-keyring: ssh component is not included

ssh component is not included (#3) · Issues · Arch Linux / Packaging / Packages / gnome-keyring · GitLab


plymouth update may cause black screens

With a newer version of plymouth than 22.02.122 you may experience an unbootable system with a black screen. This might be due to not having early KMS enabled. If you have an Nvidia GPU you could set nvidia_drm.modeset=1 nvidia_drm.fbdev=1 to the kernel parameters in your bootloader config to avoid the need of KMS. However, with Wayland around the corner, KMS will be needed.

To “fix” the current problem, we have downgraded plymouth once again to have more time to find a proper solution to migrate most of your installations to a working state with newer plymouth versions.

sudo pacman -Syuu

Those who don’t have issues can enjoy the newer version of plymouth.

Directions for adding kms to your system configuration and how you can help troubleshooting by providing some sysinfo, read more → Black Screen with Plymouth - Cause and Solution

polkit update might remove your local modified config

With polkit 124-1 there were changes made to etc/pam.d/polkit-1. So check if you made local changes to the file. See also: https://www.reddit.com/r/archlinux/comments/19bnj0i/comment/kit2v33/

bashrc-manjaro is now merged into bash
  • Yes, replace bashrc-manjaro with bash
  • Please also compare your:
    with the generated
    and retrofit all of your customisations as there was no .pacnew file generated.
  • Same goes for /etc/skel/.bashrc
pacman and pacman-contrib changes

pacman-contrib is now split out from pacman. If you have anything installed that depends on pacman-contrib, update (after you finished the Release Update) with:

sudo pacman -Syu pacman-contrib


Initramfs image can be bigger on 6.7 kernel due to Nvidia GSP Boot firmware

We all known that kernel 6.7 is very feature rich. One of the features is the inclusion of Nvidia’s GSP Boot firmware into Initramfs. However this will increase your image by 150 MB and the fallback image might be 240 MB in size. A way would be to remove kms from mkinitcpio.conf and redo your initramfs images. A discussion regarding that can be found at Arch Gitlab: kms hook increases the initramfs size heavily starting with 6.7 kernel (#238) · Issues · Arch Linux / Mkinitcpio / mkinitcpio · GitLab

To reduce size add fallback_options="-S autodetect -S kms" to /etc/mkinitcpio.d/linux67.preset

Making dbus-broker our default D-Bus daemon

2024-01-09 - Jan Alexander Steffens

We are making dbus-broker our default implementation of D-Bus, for improved performance, reliability and integration with systemd.

For the foreseeable future we will still support the use of dbus-daemon, the previous implementation. Pacman will ask you whether to install dbus-broker-units or dbus-daemon-units. We recommend picking the default.

For a more detailed rationale, please see our RFC 25.

Arch Linux - News: Making dbus-broker our default D-Bus daemon

In some cases, however it is better to keep the legacy way. Here are some examples: Dbus-broker warnings


grub update

grub 2.12 may need manual post install by the user

With GRUB 2.12 out it is recommended to also install grub to your master boot record or EFI partition. On Manjaro grub gets only installed when you install it to your harddrive the first time. Only advanced users also keep their MBR/EFI in-sync as every package update of grub doesn’t update the installation on your MBR/EFI.

Depending on your system hardware and setup this may could cause an unbootable system on rare cases due to incompatibilities between the installed bootloader and configurations. After a grub package update it is advised to run both, installation and regeneration of configuration:

grub-install [plus the needed options depending of been EFI or BIOS]
grub-mkconfig -o /boot/grub/grub.cfg

For more specific information on grub-install, please refer to this guideline: [root tip] [How To] Primer on handling a grub package update

Additional information to that topic can be found here:


Broken Wifi with 6.1.66 and 6.6.5 kernels

Some users report broken Wifi driver support with the latest 6.x kernel series, mostly based on Realtek drivers, either from the AUR or provided by the kernels itself. It is also reported that linux515 and linux67 kernel series don’t have those issues. So if you have a potential Wifi driver problem, consider to install those kernels before updating your system. Older kernels can be found here:

Possible issues reported upstream

The Author of the original patch Johannes Berg had reviewed Léo Lam’s patch by now. So everybody who had tested 6.6.5-3 or 6.1.66-2 should reply to the upstream mailing list with a Tested-by tag as described here: [Stable Update] 2023-12-10 - Kernels, Plasma, Phosh, Systemd, Cinnamon, Gnome, libpamac - #95 by philm


  • IMPORTANT → Linux 6.5 is EOL

    Linux 6.5 is EOL and will be removed from the repo.

    If you use Linux 6.5 and Nvidia or as virtual machine, it is of great importance, that you install Linux 6.6 to avoid driver problems.

    sudo mhwd-kernel -i linux66


Blender 4.0 may fail on AMD GPUs

The current native ALPM package of Blender provided by our mirrors may fail with AMD GPUs. As an alternative you may want to use Blender-Bin from the AUR, flatpak version, snap version or load it directly from Blender. More infos here: 17:4.0.1-2 Segfault on start (#2) · Issues · Arch Linux / Packaging / Packages / blender · GitLab


mkinitcpio needs base hook

With the update of mkinitcpio 37 make sure you have the base hook in your /etc/mkinitcpio.conf file, unless you use systemd hook instead. See also wiki for all hook documentation.


Changes in JDK / JRE 21 packages may require manual intervention

2023-11-02 - Frederik Schwan

We are introducing a change in JDK/JRE packages of our distro. This is triggered from the way a JRE is build in modern versions of Java (>9). We are introducing this change in Java 21.

To sum it up instead of having JDK and JRE packages coexist in the same system we will be making them conflict. The JDK variant package includes the runtime environment to execute Java applications so if one needs compilation and runtime of Java they need only the JDK package in the future. If, on the other hand, they need just runtime of Java then JRE (or jre-headless) will work.

This will (potentially) require a manual user action during upgrade:

  • If you have both JDK and JRE installed you can manually install the JDK with pacman -Sy jdk-openjdk && pacman -Su and this removes the JRE related packages.
  • If you have both JRE and JRE-headless you will need to choose one of them and install it manually since they would conflict each other now.
  • If you only have one of the JDK/JRE/JRE-headless pacman should resolve dependencies normally and no action is needed.

At the moment this is only valid for the upcoming JDK 21 release.

Arch Linux - News: Incoming changes in JDK / JRE 21 packages may require manual intervention


Powerdevil fails in KDE Plasma

In KDE Plasma, Powerdevil fails and energy settings (Power save v Normal v Performance) are unavailable. See:
Powerdevil fails, Energy settings unavailable

Restarting gnome-shell using Alt+F2 and entering R, causes a crash

FS#79884 : [gnome-shell] Restarting gnome-shell using Alt+F2 and entering R, causes a crash

GNOME Extensions that target older GNOME versions will not work in GNOME 45

It is recommended to remove all third-party extensions before updating, then install the compatible versions after updating and rebooting. All Most extensions in the Manjaro repos are already updated.

kpeoplevcard update requires manual intervention

A “newer” version of kpeoplevcard accidently existed, so to install the current version, either update with sudo pacman -Syu kpeoplevcard or sudo pacman -Syuu.

Previous stable update threads:


But it’s Monday!


wire-desktop is causing the following issue:

The old version depended on electron22 which has been moved to AUR. wire-desktop 3.34.3307-2 depends on electron27 which is in the official repos and gets installed fine but after the updates of the pkgs of the official repos electron22 is also rebuild from the AUR, causing a 30GB download.

If you catch this Before running [Stable Update] 2024-05-13 either

  • remove wire-desktop and electron22 before updating with pamac (AUR enabled) and reinstall or
  • set electron22 to ‘ignore’ and after [Stable Update] 2024-05-13 has finished remove it

If you only catch this Whilst running [Stable Update] 2024-05-13 and the official repo’s updates are done and the following line has been shown
A restart is required to apply the changes.
just close the terminal window any time while this download is running:

Cloning chromium-mirror git repo...
receiving objects: 6% 1,50Gib

then remove electron22 pkg and either restart or, if you have other AUR pkgs to build, run the update again so those pkgs get built and then restart.

1 Like

You can probably simply uninstall electron22 as it’s likely not needed anymore.

I noticed that issue too when I updated one of my older systems. It seems outdated electron packages from AUR pile up over time and need to be cleaned up manually. Not sure yet what an automated solution could be to that.


Experiencing a dependency issue with NVIDIA

:: Starting full system upgrade...
:: Replace tepl with extra/libgedit-tepl? [Y/n]
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (550.78-1) breaks dependency 'nvidia-utils=550.67' required by linux67-nvidia

Onboard virtual keyboard starts ok but quits at moving mouse over it.

$ onboard
14:32:40.342 WARNING Config: mousetweaks GSettings schema not found, mousetweaks integration disabled.
Segmentation fault (core dumped)

To fix it open ‘Onboard Settings’ >> ‘Keyboard’ >> ‘Advanced’ and set ‘Input event source’ to ‘GTK’


For me when I go to the download page at manjaro.org, the download is for 23.1.4, not the new version.

1 Like

as usual, ISOs will be ready a bit later than the update

You are a using an EOL 6.7 kernel which doesn’t have newest nvidia driver. Consider downgrading to LTS 6.6 or updating to latest supported 6.8.


I’m gonna hold back installing Plasma 6 for now. Just tried and it broke every customization (but this was to be expected) and has a lot of untranslated terms everywhere. Will wait another 6 months until it’s aged a little bit.

1 Like

Just unplug from the internet to be on a safe side.


14 posts were split to a new topic: Automatic cleaning for the orphans

Well, if you do partial updates, the day KDE Plasma will be built against incompatible dependencies, you’ll be screwed to say the least.

I’ve been on Plasma 6 for two months in Testing and it has worked remarkably well since the beginning. For such a major release with breaking changes, I expected a utter disaster, but the upgrade went very smoothly. Even Plasma on Wayland works surprisingly well despite being relatively new, although it is unfortunately glitching up with some applications.

If you have some third-party extensions, it could be a source of problems.

You might want to use Plasma on X11 for now if you’re experiencing issues with Wayland. It is still available from the login screen (lower-left corner if I remember correctly, you have Plasma (Wayland) and Plasma (X11)). Although it is planned to be unsupported in the future, for now, it could do the job while the Wayland compositor gets more and more updates.


Please - allow the ISO to be rebuild and the web site to update - usually the update is before the ISO release

Well, see here: Testing 24.0 ISOs (#9) · Issues · Release plan / Releases · GitLab


Will do, thanks

Error: Target not found: python-manjaro-sdk

The KDE dialog parameters also look different, e.g. password input, looks like GTK windows …

That is because your last session was Wayland - what is done script wise when you update - is not interfering with your last choice …


The update went smoothly as always, but I had an issue with plasma6 freezing alone all of a sudden (desktop and taskbar not responding and mouse cursor still working and an alt + tab still shows the apps that I’ve opened) on both Wayland and X11, but I removed linux6x-* and it contained linux6x-nvidia I can have a working environment once again, hopefully this’ll help someone that stumbled on a similar issue.
Edit : still facing the same issue :rofl:


From reading the comments here, apparently resetting all KDE settings was expected‽ There should definitely be a warning in the top post!