[Stable Update] 2023-07-10 - Kernels, Plasma, Gnome, LibreOffice, Pipewire, Mozilla, Wine

It’s quite strange - if I run “pamac update” I see a long list of what can be upgraded, but then it doesn’t install anything (without any error message). Same happens with the pamac GUI.


I don’t know how I did it, but after the update I could not boot into my encrypted system. Sparse would not be allowed.

Anyway, I’ll do it again and learn.

But please, where can I find an updated ISO for mate desktop? Is there one on github? The one offered on the website is so old that after installation I have to download the same amount of data again when updating and that’s bad if you only have a mobile connection to the internet.

Translated with DeepL Translate: The world's most accurate translator (free version)

Had to reinstall texlive.

  • Mangohud updating seems to be stuck. A very minor problem.
  • The new pamac UI is not respecting my KDE Plasma theme. All hail adiwata i guess. I know i can downgrade to the old version, but i dont want too. Also getting the tile view back would be nice. So you can have 3 packages next to eachother in one row and not only one.

Otherwise 500 packages updated with no problem and switched to 6.4 kernel. No very obvious problems so far.

Here is the mangohud log

pamac update --force-refresh --aur                                                                              ✔ 
Synchronizing package databases...
Database file for core does not exist.
Database file for extra does not exist.
Database file for community does not exist.
Database file for multilib does not exist.
Refreshing core.db...                                                                                                          
Refreshing extra.db...                                                                                                         
Refreshing community.db...                                                                                                     
Refreshing multilib.db...                                                                                                      
Database file for core does not exist.                                                                                         
Database file for extra does not exist.
Database file for community does not exist.
Database file for multilib does not exist.
Refreshing core.files...                                                                                                       
Refreshing extra.files...                                                                                                      
Refreshing community.files...                                                                                                  
Refreshing multilib.files...                                                                                                   
Refreshing AUR...                                                                                                              
Warning: manjaro-hello: local (0.7.0-6) is newer than extra (0.7.0-5)                                                          
Resolving dependencies...
Checking inter-conflicts...

To upgrade (1):
  mangohud  (  extra  1,3 MB

Total download size: 1,3 MB

Apply transaction ? [y/N] y
==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Authenticating as: yep (ya)
Transaction successfully finished.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Seems archlinux-keyring-20230704-1 was not updated with pamac but pacman did it first.


Thats a dream with a mobile internet only ^^

I think there’s a missing PROVIDES in the openblas package.
Updating via pacman -Syyuu I get (after a small number of conflicts that are irritating but, I think, non-critical):

error: failed to prepare transaction (could not satisfy dependencies)
:: installing openblas (0.3.23-3) breaks dependency 'blas' required by cblas
:: installing openblas (0.3.23-3) breaks dependency 'blas' required by lapack

The currently-installed openblas package (0.3.23-1) does, according to pacman -Qi openblas, provide blas, so I’m assuming this is an oversight.


Fair warning, this:

…from your other post, will download just as much as updating.

If you have an internet use limitation, a point-release might be better. Because Manjaro needs much more internet, for downloading updates, for maintenance.

1 Like

I’m seeing similar weirdness. Pamac updates indicator says 900 and something updates. Log out. Switch to console run ‘sudo shiny-mirrors refresh’ then ‘pamac upgrade’ - only libpamac and Thunderbird updates installed, 4 packages :grinning:

Exit console and log back in, check pamac gui, ‘Everything up to date!’.

Update seems to have ceased to exist…


If you use mangohud, then glfw-x11 and glfw-wayland are in conflict. I had to remove mangohud to solve that issue. wlay depends on glfw-wayland which is part of manjaro-sway repo.

The update was successful. No more issue.

1 Like

Try again later is sensible advice - no alternative anyway with pamac not showing any updates :grinning:

I’m sure they’ll pop up later when my local mirrors sync. But the ‘due to 404 error on every package’ doesn’t seem entirely relevant? There are no updates to 404 because pamac (nor pacman) are not seeing any available updates.

If they’ve not turned up in a couple of days I’ll worry - for now happy to be patient.

I gave me such an error Electron 25, I solved it through an update in the terminal

sudo pacman -Syu


It appaears the repository changes have taken effect with this update…

The one where ‘community’ is retired and everything is moved into ‘extra’.

(as has already occurred on other branches and Arch upstream)

There should probably be some bit added to address or notify about this …

While it falls under normal ‘pacnew’ management … here are the relevant steps and explanations for this particular thing:

Actually though … pacdiff has the -s flag, which can also be used.

pacdiff -s

OK, added it. Hopefully that was the right move :sweat_smile:

1 Like

The 404 is because the packages pamac, or pacman, or whatever, tries to download is not yet available on your mirror.

The update was not installed due to 2 reasons

  1. Database update error
  2. The electron 25 package was not found (although it exists)
    Updating the mirrors did not give anything, the update was carried out in the terminal through

sudo pacman -Syu
But after that I get a database update error in the update manager, while there is no such error in the terminal
I have 2 questions, how to fix this error and how to remove the community repository from the system? Thanks for your creativity!

Is it okay to reinstall it after the update? Sorry i’m kinda new to this.

Hello there,

i have some issues:

Opening Programs takes now a lot of time, some Programs (e.g. Steam) crash on startup.

About my System:

OS: Manjaro Linux x86_64
Kernel: 6.1.38-1-MANJARO
Resolution: 1920x1080, 768x1024
DE: Xfce 4.18
WM: Xfwm4
Terminal: xfce4-terminal
CPU: AMD Ryzen 7 3800X (16) @ 3.900GHz
GPU: NVIDIA GeForce GTX TITAN (Kepler) Driver 470
Memory: 2177MiB / 32030MiB

1 Like