[Stable Update] 2023-07-10 - Kernels, Plasma, Gnome, LibreOffice, Pipewire, Mozilla, Wine

Keeps complaining about “texlive-basic”

EDIT: Worked with using pacman instead of pamac

sudo pacman -Syu

I’m lazy so I normally use GUI

1 Like

Alternatively, try changing the kernel on 6.4 for example

This i tried first, same issues.

I see the same issues now on my Lenovo ThinkPad E485 after the update…

Did you miss the last update and the associated xdg-desktop-portal-gnome issue?

That solved it!

After uninstalling xdg-desktop-portal-gnome everything is fine!

Thank you so much! :smiley:

getting error:-

installing nvidia-utils (535.54.03-1) breaks dependency 'nvidia-utils=530.41.03' required by linux62-nvidia

linux62 not exists :wink: remove it

1 Like

Сorrect theme is used:

$ GTK_THEME=Flat-Remix-GTK-Blue-Dark-Solid pamac-manager 

Wrong theme:

$ pamac-manager 

So kde-gtk-config doesn’t support GTK4?
(Wayland session, if that makes a difference.)

Could’n boot in my crypt Gnome (linux54 5.4.249) environment after update. Got stuck with initramfs error after passphrase.
My solution.
Booted into Manjaro live USB.
Then opened the LUKS filesystem and chrooted into it.
Uncommented gzip in /etc/mkinitpcio.conf


Then updated boot settings

mkinitcpio -P && update-grub

After reboot I was able to use the system. Done the kernel upgrade to “linux510 5.10.186” later on and rolled back the gzip change.

Tuck me all 2 hours, because I had a secound computer for research. Other wise :woozy_face:

Links I used for solving the problem:


It does … but just barely.
You may want to add some symlinks and/or custom gtk.css to ~/.config/gtk-4.0/ etc.
Mines a bit hacked up and still not perfect because of gtk4’s adwaita weirdness.

1 Like

Similar situation, message prompts an issue with electron25 (which is probably an upgrade on the last version as there is no such destination directory)
I’ll come back this evening and check back for a solution. Restarting might help.

Update 1
Ran the update in terminal - it came back with errors regarding duplication.

I had to run the update twice, after a reboot - things seem to be working fine.

Hope you get your box up and running soon.

Update 2 : Libpamac and it’s flatpak plugin were another 2 updates just received, however when applying them and the transaction is completed successfully - why do they still appear as updates yet to be installed.

SDDM 0.20 only gives me black screen after login screen. Tested with 6.4.3-2, 6.3.12-1 and 6.1.38-1. This is with two computers, one laptop and one desktop, both are sporting amdgpu.

I followed the Arch wiki article about SDDM+Wayland, but that didn’t change things, nor setting DisplayServer=x11. After a little poking around, downgrading SDDM to 0.19 let me get back to the desktop.

Nothing super obvious in boot logs either…

The problem is solved. I was able to perform the update using sudo pacman -Syu. This first updated the archlinux-keyring, pamac obviously did not, possibly this is the cause of the error.

1 Like

I have two ‘errors’ on two machines:

 Do you want to skip the above package for this upgrade? [y/N] 
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'zfs-utils=2.1.12' required by linux54-zfs
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing zfs-utils (2.1.12-1) breaks dependency 'zfs-utils=2.1.11' required by linux62-zfs
1 Like

“failed to retrieve some files”

1 Like

Depending on if your mirror has synced yet, it could simply be related to:

Managed to find the answer in the Arch forum.

sudo pacman -Syyuu blas

See: OpenBLAS >= 0.3.23-2 update requires manual intervention. N.B. The other option would have forced removal of lapack inter-alia.

I suggest that this be added to the “Known issues and solutions” section.

Hey all,

I don’t completely understand this message.
Does this mean that the theme simply does not support Gtk4 yet?

According to the theme manager, there is no theme installed that supports gtk4…

QuiteRRS did not start, re-install required

you use gtk4 version if you use gnome :wink: