[Stable Update] 2022-12-20 - Kernels, XFCE 4.18, KDE Frameworks, Kde Gear, Mesa, Plasma-Mobile, Thunderbird, Firefox

Because I wanted to see how HiDPI support is coming along, I installed a version from the shotwell development branch built from the AUR:

❯ pacman -Qi shotwell
Name            : shotwell-git
Version         : 0.31.5.r84.g025d3826-1
Build Date      : za 12 nov 2022 10:51:18 CET

so maybe that is the reason. Thanks!

Backlight control stopped working again when switching to kernel 6.1 on my Intel/Nvidia Legion laptop, has been working since 5.16.

With this update the startup time has increased. Usually my system used to boot in about 2.277 seconds:

Startup finished in 1.123s (kernel) + 595ms (initrd) + 558ms (userspace) = 2.277s 
graphical.target reached after 558ms in userspace

Now it takes about 4 seconds:

Startup finished in 1.212s (kernel) + 706ms (initrd) + 2.125s (userspace) = 4.043s 
graphical.target reached after 2.118s in userspace.

Reported in a dedicated thread:

It is - you need to rebuild it.

Anyone „fixed“ the date / clock format on taskbar xfce?

It’s shows:
instead of
DD. Dec. Time
like before.

There are no presets to set it up like before.

1 Like

I have black screen instead of XFCE panels. .xsession-errors says:

/usr/bin/iceauth:  creating new authority file /run/user/1000/ICEauthority
gpg-agent: a gpg-agent is already running - not starting a new one
xfce4-panel: symbol lookup error: xfce4-panel: undefined symbol: xfce_gdk_device_grab
Thunar: symbol lookup error: Thunar: undefined symbol: xfce_g_file_is_trusted

See UPDATE below!

I have no libxfce4ui-nocsd, but I do have


There are packages depending on them:

~ pacman -Qi libxfce4ui-devel | grep 'Depends On'
Depends On      : libxfce4util>=4.15.6  xfconf  libsm  startup-notification  hicolor-icon-theme  gtk3  libgtop
~ pacman -Qi libxfce4util-devel | grep 'Depends On'                     
Depends On      : glib2

I have replaced dbus-x11 with dbus. Should I replace libxfce4ui-devel and libxfce4util-devel with libxfce4ui and libxfce4util?

I’m just a regular user, so please give clear instructions. Thank you!

UPDATE: I did install standard libxfce4ui and libxfce4util instead of -devel but it did nothing. The same .xsession-errors.

How can I learn where those xfce_gdk_device_grab and xfce_g_file_is_trusted happen?

I also have an error window because of Birdtray:

Fatal error: Sorry, system tray cannot be controlled through this add-on on your operating system.

Log file is written into file /tmp/birdtray-log.txt

and that log file is empty.

UPDATE2: I removed birdtray (a flatpack application), it sped up the loading, but didn’t help otherwise. How should I debug the problem of the absent XFCE panels?

Seems mostly good on my KDE Plasma system, except for the annoyance that when I open a konsole, the journal gets hit with messages saying:

Dec 21 12:02:11 konsole[13113]: kf.xmlgui: Shortcut for action  "" "Show Quick Commands" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
Dec 21 12:02:11 konsole[13113]: kf.xmlgui: Shortcut for action  "" "Show SSH Manager" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.

then every now and then the journal gets spammed with lots of messages saying:

konsole[8999]: QPen::setWidth: Setting a pen width that is out of range

I can’t find anything about these messages with a Web search.

1 Like

choose design then go to time go to format then customize…it’s right there for me
%B %e %H:%M

Had same issue.
Removing lib32-db solved it
pacman -R lib32-db

Hi community! Thanks for all your hard work.

I had extremely glitchy KDE with this version of Mesa. Opening anything would make it glitch a lot. journalctl did not show anything obvious nor any coredumpctl.

Used downgrade to downgrade everything and got it back working properly. In my case it was:

downgrade mesa mesa-vdpau opencl-mesa vulkan-mesa-layers lib32-libva-mesa-driver lib32-mesa lib32-mesa-vdpau libva-mesa-driver 

CPU: AMD Ryzen 9 6900HX
GPU: AMD Radeon 6800M
Kernel: 6.0.14

That also happened to me and I followed the steps from this post:

No, still happening so in my case I reverted again to kernel 5.15.78.

1 Like

The same problem. this guide didn’t work.
Rolled back to a snapshot from a week ago and the update worked perfectly

i set mine as follows:

Right click clock in panel and choose properties

Choose time only and select custom format
Use this as format:
%a, %d %b %Y, %R
Set font size to 9 and font type to Noto Sans Bold

It will look like it was before

Release annoucement of XFCE 4.18: https://www.xfce.org/

1 Like

4 posts were split to a new topic: Update downloaded and installed a part of gnome

hello, ibt=off at linux boot.
Work for me .


I am having an issue when I try to update. I get this error message:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing db (6.2.32-1) breaks dependency ‘db=5.3.28’ required by lib32-db

I see now this has been noted and solved by removing the lib32-db

1 Like

Same thing for me, on Thinkpad T420, iGPU.
I’ll try installing dbus, and reboot and see how it goes.
issue started after updating and switching to kernel 6.1
Yup, iT’s the kernek 6.1 issues, also CPU temps are very high with 6.1