[Stable Update] 2022-12-20 - Kernels, XFCE 4.18, KDE Frameworks, Kde Gear, Mesa, Plasma-Mobile, Thunderbird, Firefox

For me, it was a matter of cleaning up my grub line “GRUB_CMDLINE_LINUX_DEFAULT=”. I removed “acpi_backlight=vendor” and “nvidia.NVreg_RegistryDwords=EnableBrightnessControl=1” and brightness control started working again.

Not sure where you are getting that 6.1 is LTS. It is the current stable mainline kernel. The best place to find all the information you could ever want on the kernel is at Kernel.org. The manjaro team places tags based on how the kernel teams identify the versions. This is also a great place to see the dates that kernels both long term support and otherwise will stop being supported.

The last kernel of the year is normally the next LTS kernel. 6.1 will not be marked as LTS until 6.2 is released and moves from mainline to stable.



The solution that worked for me was this one :

sudo rm -r /etc/pacman.d/gnupg/*
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys

Merry Christmas to all

Solution given by Lemust83 on the Manjaro’s French forum

1 Like

Update worked perfectly, no major issues (except for the new Xfce date/time formatting changes and fonts and similar),
but I’ve stubmled on what seems to be a (small) 6.1 kernel issue (or something changed that I’m unaware of or I’m not handling).

Disabling ‘wakeup on suspend’ for my mouse no longer works.

I’m using the /etc/udev/rules.d/50-wake-on-device.rules and that worked fine until the latest update (today). When I log in into 6.0 kernel all is fine again, so this seems to only be a 6.1 kernel issue (I rechecked the id-s used within rules, nothing changed, so that’s not a problem).

I just thought I should report on it (as something is done differently in the new kernel, I’ve looked for a kernel changelog but not sure, couldn’t find anything relevant).

ACTION=="add", SUBSYSTEM=="usb", DRIVERS=="usb", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c52b", ATTR{power/wakeup}="disabled", ATTR{driver/1-4/power/wakeup}="disabled"
ACTION=="add", SUBSYSTEM=="usb", DRIVERS=="usb", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c534", ATTR{power/wakeup}="disabled", ATTR{driver/1-3/power/wakeup}="disabled"
inxi --admin --verbosity=7 --filter --width
  Kernel: 6.1.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=cce50746-7a68-4930-94cc-bbec21092aa5 ro quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.18.0 tk: Gtk v: 3.24.35 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME X570-P v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 1201
    date: 09/09/2019
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  RAM: total: 31.25 GiB used: 3.69 GiB (11.8%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB
    desc: 2x16 MiB
  Speed (MHz): avg: 2568 high: 3696 min/max: 2200/4208 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3649 2: 2045
    3: 2070 4: 2053 5: 2053 6: 3592 7: 3631 8: 2056 9: 1874 10: 2053 11: 2053
    12: 3696 bogomips: 86277
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sev sev_es sha_ni skinit smap smca smep ssbd sse sse2
    sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext
    tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: ASUSTeK driver: nvidia
    v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2022-12) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 08:00.0
    chip-ID: 10de:1c02 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.6 compositor: xfwm v: 4.18.0 driver: N/A
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x572mm (40.00x22.52")
    s-diag: 1166mm (45.9")
  Monitor-1: HDMI-1 res: 3840x2160 hz: 60 dpi: 61
    size: 1600x900mm (62.99x35.43") diag: 1836mm (72.27") modes: N/A
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: NVIDIA GP106 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 08:00.1 chip-ID: 10de:10f1 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0a:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound API: ALSA v: k6.1.0-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.63 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.82 TiB used: 90.07 GiB (4.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 48.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 3B6Q scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 146.48 GiB size: 143.13 GiB (97.71%)
    used: 90.05 GiB (62.9%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
    label: manjaro-xfce uuid: cce50746-7a68-4930-94cc-bbec21092aa5
  ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%)
    used: 14.1 MiB (5.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: 81B9-0602
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 500 MiB fs: ext4 label: N/A
    uuid: 4e683372-4518-48cf-9713-30c5dee36a9c
  ID-2: /dev/nvme0n1p4 maj-min: 259:4 size: 48.86 GiB fs: ext4
    label: KDE-neon uuid: c4a24ce7-f7e0-4397-ada4-e552875aec59
  ID-3: /dev/nvme0n1p6 maj-min: 259:6 size: 146.48 GiB fs: ext4
    label: linux-mint uuid: c2bb6589-9bdc-4e11-a0f0-ba6033206ca8
  ID-4: /dev/nvme0n1p7 maj-min: 259:7 size: 146.48 GiB fs: ext4 label: eos
    uuid: fae2dc17-41a6-43e5-8b43-65c6fef97300
  ID-5: /dev/sda1 maj-min: 8:1 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-6: /dev/sda2 maj-min: 8:2 size: 931.5 GiB fs: ext4 label: fullbits
    uuid: e3d35fe6-b928-4bca-b3f1-68fb89595fda
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 1-3:3 info: Logitech Unifying Receiver type: Keyboard,Mouse
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c534 class-ID: 0301
  Device-2: 1-4:4 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Hub-3: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 3-0:1 info: Hi-speed hub with single TT ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-6:2 info: ASUSTek AURA LED Controller type: HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 16mA
    chip-ID: 0b05:18f3 class-ID: 0300 serial: <filter>
  Hub-5: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-6: 5-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-7: 6-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 65.0 C mobo: N/A gpu: nvidia temp: 57 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 24%
  Processes: 304 Uptime: 1m wakeups: 4 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
  pkgs: 1277 libs: 387 tools: pamac,paru,yay pm: flatpak pkgs: 0 Shell: Bash
  v: 5.1.16 running-in: alacritty inxi: 3.3.24

Even I’m facing HDMI issues on the 6.1 kernel. 6.0 kernel works though…

A post was split to a new topic: Notifications no appear centered on the desktop

Guys, there is a reason why we provide the older kernel series and not have a rolling update of the linux package like Arch has. Sometimes newer kernel simply don’t work for everyone. Keep the working kernel as your default and maybe test the newer version. Also 6.1 series we provided since RC1 to get early feedback as usual. Seems most only jump on a new series when there is its first stable release and wonder then when regressions happen. It is easy to test when a new series gets released, even with RCs as you won’t break your system. It only might not boot properly, so you go back to the working kernel series.


This is only a temporary solution, look

AMD users are sh… on, the manjaro team is only interested in the well-being of the company.

There are openssl 3.0.7-2 & openssl-1.1 (official repo (core)) + openssl-1.0 (AUR). May I remove the openssl-1.0 AUR? is it gonna conflict between version 1.1 and 1.0? :pray: :pray:

After the update, thunderbird did not start normally. I run

$ thunderbird
Speicherzugriffsfehler (Speicherabzug geschrieben)

which means “Memory access error (memory dump written)”
After a re-install using pamac it works fine.

Shutter is broken since 2022-12-06

My system is Mate Desktop on AMD with internal graphics but others seem to have the same problem, see here: Second 'New Selection' gives the previous window state. · Issue #523 · shutter-project/shutter · GitHub.

When I make a screenshot with shutter it works as expected, but when I try to do a second one the previous screen is displayed again, even when I changed the workspace. The previous screen is shown each time until I completely restart shutter. Then I can do one different screenshot.

After the update, the Smb4k application fails to start. No error, just a quick flash and then it closes. Smb4k was installed from the official repositories.

I updated my other system, and Smb4K starts (and works) like always. Did you try to start it from the terminal to see if it spits out any error messages?

Same question here. openssl-1.0 AUR it’s requesting to update, but it’s failing to compile.

Yes, if nothing depends on it. However, it’s deprecated and insecure.

Check what might require it:

pacman -Qi openssl-1.0 | grep 'Required By\|Optional For'

No. openssl, openssl-1.1 and openssl-1.0 all provide different versions of the same library and can be installed simultaneously.

1 Like

I also run into the same error. Does anyone know what this error is about and if we can ignore it?

Certainly I’ve seen no signs of it actually being a problem 24 hours after upgrading.

Musescore has been updated to 4.0 in this release. Under Wayland, its menus appear in the middle of the screen, instead of attaching to the menu bar as they should. Forcing it to use XWayland by setting the WAYLAND_DISPLAY= environment variable works around this glitch.

I briefly got hit with that Firefox bug where the process would launch but the window wouldn’t show (alternate profile, not the main one). After killing the process, I launched the main profile, launched the alternate profile from it, then cleared the cache in Troubleshooting Mode. I quit and relaunched the alternate profile separately, and the window came back.