[Stable Update] 2022-11-14 - Kernels, GNOME 43.1, Plasma 5.26.3, Systemd 251.8, Firefox 106.0.5, Thunderbird, LXQt

I am also with night light broken after update (on intel though), did you managed to fix it?

Unable to switch to my Creative usb headset after the latest update. It is still detected by the kernel, but it does not show up as a device in volume control any more.

After the update and a reboot, Chrome started rendering “big”–the wrong display scaling was being used. I had spent many hours trying to get scaling to work properly in Manjaro when using Wayland. The SDDM logon screen scaling is a persistent issue. But I was surprised to see Chrome rendering all of a sudden “broken”. Knowing I had a similar issue with Firefox previously, I checked out Firefox. It too, was all of a sudden “broken”–rendering things way too large.

In the case of Firefox, previously, I set a configuration flag in the about:config page. I set layout.css.dpi to 256 (my monitor’s physical DPI) and layout.css.devPixelsPerPx to 2.

I had also tried setting various things in various configuration files. One thing I set was in /etc/environment: GDK_SCALE=2.66.

Ok, so back in Firefox, I reset layout.css.devPixelsPerPx to 1. And boom! Firefox was “fixed”. Ok, this is definitely a scaling issue that’s been “fixed” in one of the updates. Unfortunately, there’s no such flag like that in Chrome.

So, I backed out the GDK_SCALE variable I set in /etc/environment and rebooted. But, upon restart, typing the command echo $GDK_SCALE, I received back 2.00. Where was this being set??? Apparently, this was put in a configuration file in my local home directory–though, I did not set this, and this is why scaling probably never worked the way I thought it should–“my settings” were being overridden by the entry in a local configuration file in my Home directory which I never set! The file is ~/.config/plasma-workspaces/env/10-hidpi.sh, which had export GDK_SCALE='2.00' inside it. So I set that line to export GDK_SCALE='1.00', reboot, and now Chrome was fixed too.

1 Like

libcrypto.so.1.1 breaks grub generation with update-grub failing too…Installing the recommended package fixes it too…

Firefox with graphic card (hardware) acceleration fails to process clicks on some websites. If you run it from the command line you get a message :slight_smile: :

GFX1-]: glxtest: VA-API test failed: process crashed. Please check your VA-API drivers.

Anyone knows how to solve this without disabling hardware acceleration?

1 Like

I have a reoccurring but kind of not properly reproducible issue:

When I use the three finger swipe gesture to switch Desktops on Gnome, sometimes the whole system freezes for a few seconds.
Though it’s not always the reproducible e.g. if I just rebooted my system it mostly works fine.
E.g. I have Xournal++ on desktop 1 and Firefox on desktop 2, after a clean restart the gesture works flawless, but most of the time when I already worked for a few hours or so(possibly switched to standby a couple times) my entire system freezes for at least 5 seconds or so, this is especially annoying when I accidentally trigger the gesture while navigating with my fingers.
The issue persists if I close Xournal++ or/and FF so I dont think it’s entirely their fault/if at all.

My system:
Model: ASUSTeK COMPUTER INC. VivoBook_ASUSLaptop TP420UA_TM420UA
CPU: AMD Ryzen™ 5 5500
GPU: AMD Radeon™ Graphics
RAM: 8,0 GiB
Note: This issue was deffenitly not present before though the Xournal++ Version updated two days prior.

Answering my own question, downgrading xlib seems to be a solution. Haven’t tested it long enough to corroborate but seems legit.

Downgrading to libx11 1.8.1-3 solves this issue

After the update, a monitor that was working before doesn’t get signal. I see it on system settings > display. But when making it active, it blinks looking for signal and gets nothing.

Nvidia Gforce 1060, manjaro KDE (with openboxwm). This is a major issue. The monitor works with another computer fine (so we can discard hardware error). Has anything major changed in how external monitors are being treated?


edited to link to corresponding thread

How you did this?
Firefox here is crashing a lot of times, I want to downgrade the libx11

yay -S downgrade
downgrade libx11

1 Like

The issue regarding libx11 is already in Known issues and solutions

A post was merged into an existing topic: After update, my external monitor doesn’t get signal

My third display (the only one on HDMI - rest are DVI) is recognized during login as it should be, but afterwards only black screen.

Good day, no sound in players, mpv; vlc; Firefox after update. Oddly the only sound I can hear is the Front right and Front left test in audio plasma system settings.

inxi -b output:

System:
  Host: sittingroom Kernel: 6.0.8-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.26.3 Distro: Manjaro Linux
Machine:
  Type: Desktop System: Hewlett-Packard product: HP Compaq Elite 8300 SFF
    v: N/A serial: AUD4040F1N
  Mobo: Hewlett-Packard model: 3397 serial: AUD4040F1N BIOS: Hewlett-Packard
    v: K01 v03.08 date: 04/10/2019
CPU:
  Info: quad core Intel Core i7-3770 [MT MCP] speed (MHz): avg: 2174
    min/max: 1600/3900
Graphics:
  Device-1: Intel IvyBridge GT2 [HD Graphics 4000] driver: i915 v: kernel
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: modesetting
    dri: crocus gpu: i915 resolution: 1920x1080~60Hz
  API: OpenGL v: 4.2 Mesa 22.2.3 renderer: Mesa Intel HD Graphics 4000 (IVB
    GT2)
Network:
  Device-1: Intel 82579LM Gigabit Network driver: e1000e
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
  Device-3: Intel Bluetooth wireless interface type: USB driver: btusb

Pactl info:

Server Name: PulseAudio (on PipeWire 0.3.59)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.platform-snd_aloop.0.analog-stereo
Default Source: alsa_input.platform-snd_aloop.0.analog-stereo
Cookie: 6c2d:431f

4 posts were split to a new topic: Theming inside qbittorrent is a bit messed up

Default Sink for audio playback is set to use ALSA loopback snd_aloop rather than a hardware device

I suggest you change output sink in GUI controls

Or get available sink names

pactl list sinks short

and change default sink:

pactl set-default-sink NAME

Or remove the loopback module if you are not aware of how to use it

sudo modprobe -r snd_aloop

Thanks, nikgnomic.
Went back to audio settings in system settings and found a playback setting had been reversed.
Reselected and all good.
Best wishes

For those having issues with displays going black or other problems on NVIDIA graphics cards, I suspect something could be amiss with the driver in the repository. I found that installing the driver directly from Nvidia’s site resolves the issue (even though the version is the same.)

2 posts were split to a new topic: What will be the next LTS kernel?

Thanks, this looks too high-risk to try.
I’m hoping the next update will fix it.
I have two laptops with nvidia hybrid card, and none of them deals with extermal monitor at all anymore. This is a big problem and reason for me to start looking for alternatives from Manjaro (after 7 years of being a Manjaro fan).

I just bought a desktop to make sure I 1/ get a working machine and 2/ Don’t have to deal with nvidia hybrid shenanigans ever again. My productivity is too valuable to me.