[Stable Update] 2022-11-14 - Kernels, GNOME 43.1, Plasma 5.26.3, Systemd 251.8, Firefox 106.0.5, Thunderbird, LXQt

Hello community,

Another stable branch update with some usual package updates for you.

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Info about GNOME 43

GNOME 43 is here! :partying_face:

New in Manjaro GNOME:

Lonely leftover orphan packages that have been removed from the Arch / Manjaro repositories:

  • adwaita-maia
  • dynamic-wallpaper-editor
  • firefox-gnome-theme-maia
  • gtkhash-nautilus
    (Not compatible with Nautilus 43)
  • manjaro-dynamic-wallpaper
  • manjaro-gdm-tweak
  • nautilus-terminal
    (Not compatible with Nautilus 43 & EOL)

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.265
  • linux54 5.4.224
  • linux510 5.10.154
  • linux515 5.15.78
  • linux519 5.19.17 [EOL]
  • linux60 6.0.8
  • linux61 6.1.0rc4
  • linux515-rt 5.15.76_rt53
  • linux60-rt 6.0.5_rt14

Package changes (Sun Nov 13 18:22:58 CET 2022)

  • testing core x86_64: 7 new and 7 removed package(s)
  • stable community x86_64: 2691 new and 2647 removed package(s)
  • stable core x86_64: 80 new and 79 removed package(s)
  • stable extra x86_64: 1187 new and 1280 removed package(s)
  • stable kde-unstable x86_64: 424 new and 425 removed package(s)
  • stable multilib x86_64: 72 new and 73 removed package(s)

A list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

:information_source: This is a wiki post; please edit as necessary.
:star: Please, consider subscribing to the Stable Updates Announcements RSS feed

Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:

:arrow_right: 2022-11-14

We recommend to install openssl-1.1

Due to the update to openssl 3.0 some things still look for the older LTS version 1.1. You may install openssl-1.1 and maybe lib32-openssl-1.1 packages. However report such issues to us.

Known issues:

  • some SDDM themes might not work
  • dkms might not sign modules properly as header files may still depend on 1.1 version of openssl

Issues reported to Archlinux so far:

FS#76567 : [plasma-framework] 5.99.0 needs a rebuild against openssl 3.0

libx11 1.8.2 causes firefox to freeze

libx11 1.8.2 causes Firefox to freeze, mainly when highlighting text and copying things to the clipboard (e.g. password manager).

Issues reported:

Workaround (UNTESTED - at your own risk!):
Install the AUR Package libx11-firefox-fix

Kernel 6.0: AMDGPU - Screen freezes when waking from hibernation or suspend

Screen doesn't turn on when waking from suspend: Failed to pin framebuffer with error -19 (#2213) · Issues · drm / amd · GitLab

Mesa 22.2.x renders Calamares black on Gnome Development ISOs

For some yet unknown reason Calamares is rendered black on Gnome when Mesa 22.2.x is used. Current workaround is to install 22.1.x series and relogin to the live-session.


Kernel 6.1-rc# might break backlight control on old/weird laptops, please test



signature from "Manjaro Build Server <build_at_manjaro_dot_org>" is unknown trust

Seems our signing key for our Build Server had the 2022-10-28 as expire date set when generated. This is now fixed for chroot builds and fresh as also current existing installs via manjaro-keyring 20221028-4 Simply update your system to get that package, which got pushed to all our branches.

NVIDIA 520.56.06 Color banding and animation issues

Current (not so good) Workaround:

  • Open nvidia-settings
  • Select the problematic monitor under the GPU Tab (e.g. DP-0 - (LG ...))
  • Under Controls, change Depth to 6 bpc (or play with the Dithering Controls)

NVIDIA already replied to the Bug-Report, so there is a good chance that this issue will be fixed with the next NVIDIA driver release.


Various Linux Kernel WLAN security issues (RCE/DOS) found

New Kernel versions are out that fix the RCO and DOS vulnerabilities in the WiFi stack published on Wednesday. They can be exploited over the air, so better update to 6.0.2, 5.19.16, 5.15.74, 5.10.148, or 5.4.218 soon!


Removing python2 from the repositories

2022-09-23 - Jelle van der Waa

Python 2 went end of life January 2020. Since then we have been actively cutting down the number of projects depending on python2 in our repositories, and we have finally been able to drop it from our distribution. If you still have python2 installed on your system consider removing it and any python2 package.

If you still require the python2 package you can keep it around, but please be aware that there will be no security updates. If you need a patched package please consult the AUR, or use an unofficial user repository.*

Arch Linux - News: Removing python2 from the repositories

* Note: Unofficial user repositories are not supported

Nvidia 3060RTX cards may have issues with the 515.76 driver
ceph, ceph-libs and ceph-mgr dropped to the AUR

These packages will most likely be orphaned and can be removed. See:

Arch Linux - Todo: Removal of ceph

Fixed: timeshift-gtk dumping core for some setups

ongoing discussion:
Timeshift-gtk dumps core

Update to timeshift 22.06.5-3

Openh264 2.3.1-1 update might prevent some applications from launching

With the latest openh264 update so-file name changed. Some applications however still expect so.6. As a workaround the following symlink can be used for now.

sudo ln -s /usr/lib/libopenh264.so.2.3.1 /usr/lib/libopenh264.so.6


Changes with Back In Time packages
  • backintime has been renamed to backintime-qt
  • backintime-cli has been renamed to backintime

After replacing backintime-cli with backintime, you will need to install backintime-qt manually if you want the Qt frontend installed again.

electron12, electron13, electron14 & electron16 have been dropped to the AUR

Unsupported Electron packages have been dropped from the official repos to the AUR. They no longer receive security updates and nothing in the repos depend on them.

If you have AUR packages depending on those versions, install the binary version from the AUR to replace them; i.e., electron16-bin.

See FS#75490 - electron12, electron13, electron14, electron16 are unsupported and vulnerable packages

End of Support for 15.x.y and 16.x.y

Electron 15.x.y and 16.x.y has reached end-of-support. As per Electron’s new 8-week cadence, we were supporting the latest four versions of Electron until May 2022. With this Electron 19 release, we’ll return to supporting the latest three major versions, as well as the alpha, beta, and nightly releases.

Release electron v19.0.0 · electron/electron · GitHub

element-desktop dependency error
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (20.0.0-1) breaks dependency 'electron19' required by element-desktop

The upstream package was already flagged out of date (it needs to be rekeyringbuilt against latest electron).

Workaround for now:

sudo pacman -Syy electron electron19 --asdeps
sudo pacman -Su

Title shows stable but it says testing in the description.

Is it stable or testing? Might have missed a word.


copy-paste error! :thinking:

1 Like


After updating I can’t use SSH. I get this error:

OpenSSL version mismatch. Built against 30000070, you have 30100000

I’ve fixed it by removing the “openssl3-git” and “lib32-openssl-1.0” packages, which had no repository associated to them.
I don’t know where these packages came from. :man_shrugging:

1 Like

I’m running kernel 6.0.8, and installing virtualbox-host-dkms can’t sign the compiled module:

==> dkms install --no-depmod vboxhost/7.0.2_OSE -k 6.0.8-1-MANJARO
/usr/lib/modules/6.0.8-1-MANJARO/build/scripts/sign-file: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory

For some reason the module compiled fine for for kernel 5.19.17…

I got around this by installing openssl-1.1, but I’d like to have this fixed… Reinstalling dkms didn’t help.

Edit 1: Weirdly enough, running pacman -F usr/lib/modules/6.0.8-1-MANJARO/build/scripts/sign-file doesn’t yield any results. Just searching for sign-file gives a plenty of linuxNN-headers results, but not linux60-headers

Edit 2: Running pacman -Fy fixed the search result, sorry about that!


it seems my desktop notificaitons related freezing on KDE has gone. All notifications come one by one and no frozen DE.

KDE 5.26.3 saved my ass :laughing:


After the update plasma no longer seems to work for me, my SDDM theme is missing and when i try to log in it remains at the SDDM screen.
On the SDDM screen it shows the error:

The current theme cannot be loaded due to the errors below, please select another theme.

file:///usr/share/sddm/themes/breath/main.qml:26.1. plugin cannot be loaded for module "org.kde.plasma.core": Cannot load library /usr/lib/qt/qml/org/kde/plasma/core/libcorebindingsplugin.so: (libssl.so.1.1 cannot open shared object file: No such file or directory)

Does anybody know what may have caused this?

You may want to install openssl-1.1

1 Like

After this update I’ve been getting this error:

error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory.

It looks like an OpenSSL issue but I would appreciate any ideas on how to fix this.

Oops, @philm just while I was typing. Thanks @philm!

Just updated all seemed okay, until i just tried to “Drop and Drag” a folder/file from Archive Manager to a folder in File manager, It does not work anymore, also tried using “xarchiver” and still drop and drag don’t work.

The only way to unpack something now on Gnome 43 is to move the Archive file to the folder i want it in and then right mouse click and extract here, which then also creatures another folder so once unpacked you need to move the files/folder out of the new folder, then delete the folder now not used.

Drop and Drag works fine from File Manager to File Manager (2 open file manager windows), just will not work from Archive Programs?

UPDATE: It’s a known issue and may never be fixed :weary:, it has been an issue with wayland for 4+ years, but it now effects X Server, which is what i am using (nvidia).

Somebody moved the post to Gnome 3 and wayland, scroll to the bottom to see it’s a newer report for Gnome 43 and GTK4 on X11, Copy and Paste from Archive Manager does not work now either.
Something about GTK4 and DND?, from what i could find out.

1 Like

Ah this worked! I could have sworn 1.1 was already installed, I never saw an update mention removing the package.

Thanks for the help.

Well, openssl got updated to 3.0 series. You can watch this rant video Arch Linux Finally Ships OpenSSL 3: Chaos Ensues - YouTube if you want more info about it. So far I’ve reported the SDDM issue. Workaround is to install openssl-1.1 package.


The openssl-1.1 package has been installed automatically during the upgrade by pamac gui.

1 Like

I have X-Plane complaining about a missing /dev/dsp after the upgrade:
ALSA lib pcm_oss.c:397:(_snd_pcm_oss_open) Cannot open device /dev/dsp.
I am using pipewire.
EDIT: solved within X-Plane configuration: using sound device default instead of pipewire.

As mentioned in the issue that’s been open for four years:

…it will not be fixed until File Roller is ported to GTK 4…

A post was split to a new topic: Firefox keeps completely freezing randomly

Yeah but that was on Wayland, it now effects X11, i read that it will be more then just porting File Roller to GTK4, It’s something to do with DND.

Looks like this has been fixed.