[Stable Update] 2022-07-18 - Kernels, Pipewire, Mesa, Xorg, XWayland, Gnome, KDE Gear, Plamo

Hello community,

Another stable branch update with some usual updates for you.

grafik
Checkout the store for the upcoming weekend (21st - 24th) with free shipping!

  • Some of our Kernels got updated.
  • Plasma Mobile Gear got renewed to 22.06
  • Linux-Firmware got updated
  • Wine is now at 7.13
  • Pipewire got updated to 0.3.55
  • Xorg-Server and XWayland gained needed security fixes
  • More Gnome 42.3 packages got added
  • Regular Haskell and Python updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You get the latest stable releases of Manjaro from CDN77.


Our current supported kernels

  • linux419 4.19.252
  • linux54 5.4.206
  • linux510 5.10.131
  • linux515 5.15.55
  • linux517 5.17.15 (EOL)
  • linux518 5.18.12
  • linux519 5.19-rc7
  • linux515-rt 5.15.49_rt47
  • linux518-rt 5.18.0_rt11

Package Changes (Sun Jul 17 08:54:44 CEST 2022)

  • stable community x86_64: 1242 new and 1231 removed package(s)
  • stable core x86_64: 35 new and 35 removed package(s)
  • stable extra x86_64: 172 new and 172 removed package(s)
  • stable kde-unstable x86_64: 373 new and 372 removed package(s)
  • stable multilib x86_64: 17 new and 17 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

14 Likes

Known issues and solutions

:information_source: This is a wiki post; please edit as necessary.
:star: Please, consider subscribing to the Stable Updates Announcements RSS feed


Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:


:arrow_right: 2022-07-18

wxWidgets 3.2 update may need manual intervention

Packages have been renamed from wxgtk- to wxwidgets-. The GTK2 frontend is no longer provided. If you have wxgtk2 installed, the upgrade will fail with:

In such case, uninstall wxgtk2 first and then proceed with the upgrade.

2022-07-12

Wireplumber 0.4.11 may crash for GDM users

Currently there is an issue with 0.4.11 and GDM crashing on boot-up. More in the upstream bugtracker issue: wireplumber segfault: system boot and could see in my dmesg (#305) · Issues · PipeWire / wireplumber · GitLab

2022-06-12

Akonadi (KMail / Kontact / KOrganizer...) fails to start
touch ~/.local/share/akonadi/db_data/ib_logfile0
akonadictl start
mariadb-upgrade --defaults-file=~/.local/share/akonadi/mysql.conf --socket=/run/user/$(id -u)/akonadi/mysql.socket
Locale file changes

C.UTF8 locale is now included in glibc:

Credits @diabonas for this change. Systemd wants us to include C.UTF8 by default and it seems the locale may be in included by glibc upstream in the future. To fix building and avoid nasty fixing in devtools, we include the locale in the package. See systemd/systemd#23252 (comment) FS#74864 : [systemd] >= 251 breaks devtools' locale

There is a pacsave for /etc/locale.conf as it has been removed from the filesystem package. /etc/locale.conf will automatically be restored if it did not already exist.

There is a pacnew for /etc/locale.gen. Please review it and regenerate your locale if necessary.

2022-05-13

Chromium / Google Chrome cannot save files to most folders (GNOME and Xfce)

This is an upstream bug with the package xdg-desktop-portal-gnome

In the meantime, you can try to remove the package xdg-desktop-portal-gnome (if feasible, without any dependency issues or conflicts), or wait for the bug to be fixed upstream.

Without any xdg-desktop-portal-* packages, Chromium and Google Chrome should correctly detect the environment and present either KDialog (KDE) or GTK file picker (GNOME, Xfce) upon saving and downloading files.

An alternative workaround, for now, is to intentionally click on the filename field, and then press Enter to save / download the file.

GNOME 42: theming and COSMIC packages changes, Bluetooth disabled by default
libkipi: Pamac fails to build the package from AUR
  • libkipi is a deprecated dependency for some KDE applications, and has been moved to AUR.
  • When using Pamac graphically, you can disable the update for libkipi, before removing it from your system.
  • When using Pamac from the terminal, you can proceed the update in multiple steps:
pamac upgrade --no-aur
pamac remove libkipi
pamac upgrade --aur
Timeshift: new rsync snapshots do not show
Wine: cannot be built locally

2022-05-10

QEMU >= 7.0.0 changes split package setup

2022-05-09 - David Runge

With the update to qemu 7.0.0 the package has been turned into a more fine grained split package utilizing meta packages.

  • The qemu package is now virtually provided by the meta packages qemu-base, qemu-desktop and qemu-full.
  • The functionality of qemu prior to 7.0.0 is replaced by qemu-desktop
  • The functionality of qemu-headless is replaced by qemu-base
  • The functionality of qemu-arch-extra and qemu-headless-arch-extra is replaced by qemu-emulators-full
  • The meta package qemu-full provides all QEMU related packages (excluding qemu-guest-agent)

2022-04-15

KeePassXC auto-type does not work

Upgrading KeePassXC from version 2.6.6 to 2.7.0 partially breaks the “auto-type” function. This is fixed upstream in version 2.7.1.

In in the meantime, to have it behave (and work) as it did with version 2.6.6, change the following option:

Tools → Settings → General → Auto-Type → uncheck “Always ask before performing Auto-Type”

Version 2.7.1, which did not make it into this batch of Stable Updates, works correctly, even with the above option enabled.

Desktop Icons (DING) Gnome extention and File Previews stop working due to a crash in sushi.

This has been fixed upstream in sushi version 41.2. To restore functionality you can manually upgrade.

sudo pacman -U https://archive.archlinux.org/packages/s/sushi/sushi-41.2-1-x86_64.pkg.tar.zst
3 Likes

Pamac shows ‘69 available updates’ 526 MB this morning. Expected to see an announcement here, but so far I can not find anything.

Did I miss something?

1 Like

Do you have this update installed?

1 Like

Yes, I think so. E.g. Pipewire vs installed = 03.54 and the update proposed version is 03.55.
Kernel installed = 5.18.10 and proposed = 5.18.12.
I did not change Branch. Only held back an AUR Tenacity update because of wxgtk3 dependency not resolved.

confirm

I can confirm 79 packages available for update (KDE, Stable Branch).

The 2022-07-12 had been done when it was released, so this is new as of today.

Then i suggest to wait a bit till the announcement is made and will also have the wiki with possible fixes/manual interventions that might be required.

2 Likes

I just wanted to post this as well. I am offered 210 upgrades, 16 new, 2 removals.

I am on stable branch according to Switching Branches - Manjaro

I seem to have been offerered software updates with package versions mentioned in this “testing” announcement: [Testing Update] 2022-07-17 - Kernel 5.18, Octopi, Haskell, Python (That’s true for some packages, e.g. linux515 and octopi. But I am offered nodejs 18.5.0-118.6.0-1, too which is not in this testing update).

I am used to wait for a forum announcement (which is a great service, thank you) before proceeding, but it has been now around 5 hours already and I have the feeling this might be a malfunction.

Just out of interest: Can I see the current state of the “stable” branch in Git, e.g. at Packages · GitLab? I am missing a possibility to cross-check package versions for “stable” apart from what pacman / pamac offers me. Sorry, I am still new and trying to understand.

I have installed the update of 18.7.2022 on four computers without any problem.

I saw the update & checked the forum, since there was nothing for 07-18 I assumed I must have missed the 07-12. I checked I had a backup & then applied it. I haven’t noticed any issues.

Lol I updated without realising I should wait for official announcements or something.

Now look at my screen :joy: . Cannot press super button or anything except what opens on that manjaro hello screen. I will try to learn of a way to resolve this XD

Edit:The update only broke the latest kernal 5.19 and I am now safe on 5.15.

2 Likes

You mean the windows on the left hand side ?

Then just disable it by switch the slider launch at start.

I just tried the update and received two show-stopping errors. The first one:
I answered Y to the upgrade and got…

:: Starting full system upgrade...
:: Replace wxgtk-common with extra/wxwidgets-common? [Y/n] 
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing wxgtk-common breaks dependency 'wxgtk-common' required by wxgtk2

So, I started over, answered N this time, then got:

networkmanager-1.38.2-2-x86_64    3.5 MiB   530 KiB/s 00:07 [#################################] 100%
 Total ( 6/47)                   333.4 MiB  1767 KiB/s 03:13 [#################################] 100%
error: failed retrieving file 'networkmanager-1.38.2-2-x86_64.pkg.tar.zst.sig' from mirror.futureweb.be : 
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.
1 Like

The wxgtk-common problem is from changes in Arch. Arch Linux - News: wxWidgets 3.2 update may need manual intervention

Uninstall wxgtk2 first.

2 Likes

I can’t. p7zip-gui is using it, and because of all the “wx…” problems, I added p7zip-gui to “ignore” on updates.

pamac remove wxgtk2
Preparing...
Checking dependencies...
Error: Failed to prepare transaction:
could not satisfy dependencies:
- removing wxgtk2 breaks dependency 'wxgtk2' required by p7zip-gui

The other problem , “from mirror.futureweb.be” is weird because just before updating, I ran fasttrack 10. So, to resolve this one, I checked the Manjaro mirror page, ran mirror --interactive, and everything updated just fine.

Not anymore as of 16.02-6. Remove p7zip-gui and wxgtk2 first, update repository packages only, then reinstall / update your AUR packages.

NOPE! It still works and I’m not going to delete it.

The day of the original p7zip-gui update a few days ago, I did exactly as you recommended, and updated AUR packages, and neither pamac nor yay could find the required “wx…” packages. I even tried it again today with all the new versions of “wx…” files that were not listed on the p7zip-gui AUR page two days ago…same failure on my test machine.

Well, today they will. :wink:

I’ll go back to my test machine and give it a whirl sometime tonight.