[Stable Update] 2022-06-12 - Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire, LibreOffice

Probably something like: pacman -Qoq /usr/share/perl5

amd_pstate error
To confirm: ignoring the error worked here, too, at least on kernel 5.18.3. Back on amd_pstate now. Far, far too lazy to try other kernels right now.

Seeing 590Mhz on cores again is a bit of a relief.

Hmmm… I suspect not. That returns a long list of packages, at least some of which were updated today. And others which were installed from AUR and haven’t been touched for some time (but still work).

I can’t see it helping with modules installed from CPAN either. But thanks for the suggestion.

Ah, never mind. I thought you were looking for packages depending on perl.

Thanks for finding that fix! :+1: :smiley:

A post was split to a new topic: Starring files in Nautilus no longer works

Why would they? I think it would require extraordinary circumstances for a non-LTS kernel to get the “recommended” label.

I see, then it’s my own lack of knowledge about kernel designations.

After this update the below message shows on tty at KDE GUI Shut Down (the word poweroff is replaced by reboot on Restart) when clicking the button in the KDE Application Launcher.

I did some research and I believe this is caused by the updated systemd issuing commands to poweroff and reboot without the --no-wall argument (a new requirement?). Is there a way to correct locally or would it need to be patched upstream?

I do not get the beep from the pc speaker that others are reporting, maybe because I am on a laptop.

^@^@^@
Broadcast message from xxx@xxx-pc (day date time):

The system is going down for poweroff NOW!

_

Kernel missing, please load the kernel first
same here

Cannot boot Manjaro anymore. I’m not linux expert so… Please help!
How do I restore kernels or I how can I restore from Timeshift?
Timeshift made a backup before upgrade.

I fixed it myself. I booted from Manjaro Live USB.
I run Timeshift. It found the last backup before upgrade!!! So I was able to restore it to previews fully working state.
Manjaro and Timeshift are great! So I boot up my system again without the update.

I had done the last update with pacman -Syuu.
This time I made the update with pamac-manager. Update worked ok.
I don’t know why it replaced kernel real time 5.17rt for 5.18rt. It didn’t upgrade 5.17 normal to 5.18.

I’ll try to manually install normal 5.18 kernel with pamac-manager.

1 Like

Two more broken items:

After the update, ffmpeg4.4 came up as an orphan, and I don’t know why. I know Audacity needs this because without it an error message pops up at the start of Audcity. (This may not happen to everyone. I typically go beyond the norm with Audacity)

  • Easy fix, just reinstall ffmpeg4.4.

Gnome-Boxes is now unusable. Any virtual systems created before the update still work fine, but now it will not boot and create a new virtual system. I downloaded and tried 4 different Linux distros. No luck.

I have Manjaro Xfce on another desktop that never had Gnome Boxes installed, so, I installed it just to see what would happen. Same result on a fresh install…It will not boot/create a new virtual box.

after login my desktop stuck at splash screen. here is my journald log

I am waiting to update, but wow, so many broken itens…
I think I will wait a little more… ¯_ (ツ)_/¯

Any news about VirtualBox?
It’s the only thing that I am really concerned in this update

2 Likes

From what I’ve read, the VirtualBox instability issues are due to a kernel regression:

3 Likes

I am using 5.15 LTS and saw some problems with that too… Any way to fix, or it’s better wait?

1 Like

I am temporarily using an earlier version of the 5.15 kernel and VirtualBox kernel modules to avoid the instability issues. If you are not comfortable downgrading or holding packages, it might be better to wait until a patched kernel is released :).

Does anyone know which kernel versions have fixes for the regressions?

1 Like

this is not good ,
this is pacman -Syu or pacman -Syyu

Since you used CPAN you cannot ask your package manager, you have to look for yourself:

$ ls -l /usr/lib/perl5/5.34/*/
1 Like

And the same here, too. Affected VMs are Windows 10 and 11 guests.
Also tested both available 5.x LTS kernels with no difference. Didn’t test higher kernel versions, though.
I uninstalled an re-installed both the VM Extension Pack and the Guest Additions, but to no avail.
I even downgraded VirtualBox to the previous v6.1.32 with the same negative result, which is why I suspect either the kernel updates or the systemd update to cause this trouble.
Unfortunatly my VMs don’t run long enough to take a glimpse of their event logs to gain more insight from that side.

2 Likes

Nice one. Thanks!