[Stable Update] 2022-04-15 - Kernels, Mesa, Nvidia, Budgie, PipeWire, LIbreOffice, KDE Frameworks, Wine

The issue is fixed, you have local issues.

See this: How to solve keyring issues in Manjaro - Tutorials - Manjaro Linux Forum

i already tried exactly that same of your link but it didn’t help. more enough it scrapped the system, after rebooting i went to black screen. restored a backup from yesterday (thanks god i did a backup yesterday) and will wait until the issue is fixed.

Again, the issue is local to you if it’s fixed for others.

Same issue with libvtkfides.so.1 here for VTK application, which imports vtk modules from Python:

  File "/usr/lib/python3.10/site-packages/vtkmodules/all.py", line 106, in <module>
    from .vtkIOFides import *
ImportError: /usr/lib/libvtkfides.so.1: undefined symbol: _ZN6adios25ADIOS9DeclareIOENSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE

An update, where this mismatch is resolved would be really nice.

EDIT: Arch bug-report FS#74317

Hopefully this is also applied to VTK package.

Follow-up: as the error message points to libavutil/imgutils.c, I did some tests and removed the cover image from the offending MP3s tags, now I can import those again in Shotcut without a crash!
So it seems to be a new bug in FFmpeg…

The current element-desktop build is unstable. It crashed multiple times and I had to re-login several times, because it detected session issues.

The flatpak version of element doesn’t have this particular issue.

Apart from that, there is an issue regarding a flickering mouse cursor in Element: spinning at 100% cpu, flickering mouse cursor · Issue #21147 · vector-im/element-web · GitHub, which apparently is a Bug in Electron / Chromium and is supposed to be fixed with Electron 19:

Currently there is nothing you can do, this comment is just for information purpose. Maybe it’s worth updating the element package to v1.10.10 nevertheless, to at least fix some bad crashing issues, else the current work around (for the hard crash) is to use the flatpack version.

Here is the error I get falling the WIKI you provide:

sudo rm -r /etc/pacman.d/gnupg 
rm: cannot remove '/etc/pacman.d/gnupg': Device or resource busy

Not fixed. No help on the WIKI as to fix this problem.

There seems to be something using the directory, are you running another update proces somewhere else?

This command might reveal the process: lsof | grep /etc/pacman.d/gnupg

lsof | grep /etc/pacman.d/gnupg returns nothing.

Howver, skipping the sudo rm -r /etc/pacman.d/gnupg and continuing on to the next step seems to have fixed the problem.

1 Like

A little question, do you recommend to use the new kernel 5.17 if i have a dual boot? I m a little worried that it will break.

There were some nodejs related problems.

I am not sure what caused them, but renaming the /usr/lib/node_modules dir to node_modules.bak solved the problem.

Again there were some warnings…

But everything went okay and update finished.

EDIT (New problem) :

When I booted few minutes ago just before writing this, same problem, like last time happened,

but this time my laptop didn’t go to hibernation. Fixed with same steps as last time. Reinstalled linux516 and linux510, reinstalled grub, updated grub (grub-update).

Would you have installed npm packages system-wide through npm instead of the system package manager?

3 posts were split to a new topic: Shortcuts for screenshot is not working after the update

I installed postcss-cli globally through npm.
Sorry, about the screenshots, the output was so massive, I couldn’t copy them.

And, Another Update regarding this, Like last update, I encountered similar issue, “Boot image not found”,
but this time my laptop did not go to hibernation, instead aforementioned error happened when booting , just before writing this. Solved that just like last time, reinstalled linux516 linux510, reinstalled grub, and updated it grub-update.

Reading this I have to wonder: Did LibreOffice stop crashing on long (novel length) documents? Why I swore off it.

Probably the wrong place to ask, I know. :slight_smile:

Since this update, I have a problem with Déjà Dup:

Message recipient disconnected from message bus without replying

The storage location is a remote Nextcloud server that used to work like a charm.

Any idea to troubleshoot?

Seems like sleeping is still hit or miss. It works only about 70% of the time which makes sleeping extremely unreliable.

Guess sleeping is just one of these things that its just not possible to get working properly on Linux (at least not in my experience, I have never had a laptop where it worked reliably).

8 days later (22-04-29) I finally went to do this upgrade.
After fresh ‘pacman -Syy’, I did ‘pacman -Suuw’
and at the end it got :

error: systemd-libs: signature from "Mark Wagie <mark@manjaro.org>" is unknown trust
:: File /var/cache/pacman/pkg/systemd-libs-250.4-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n

and so on.

Does “the issue is resolved” mean this should not happen?
If so, how did it happen for me?

EDIT: it happened because I used ‘w’ with pacman. Details in this reply

Should there be a note in the wiki post …

Btw, I didn’t delete files,
I ran ‘sudo pacman-key --refresh-keys’
then ran ‘sudo pacman -Suuw’ again, and it verified OK.

On my system, that cached file is dated March 17… which is prior to all the manjaro-ring updates.

$ ls -la /var/cache/pacman/pkg/systemd*
-rw-r--r-- 1 root root 9415279 Feb  8 09:38 /var/cache/pacman/pkg/systemd-250.3-3-x86_64.pkg.tar.zst
-rw-r--r-- 1 root root 9414151 Feb 10 13:03 /var/cache/pacman/pkg/systemd-250.3-4-x86_64.pkg.tar.zst
-rw-r--r-- 1 root root 9424928 Mar 11 10:06 /var/cache/pacman/pkg/systemd-250.4-1-x86_64.pkg.tar.zst
-rw-r--r-- 1 root root 9425072 Mar 17 17:46 /var/cache/pacman/pkg/systemd-250.4-2-x86_64.pkg.tar.zst

It would appear to me that old/cached packages associated to an older key that has now been updated should be removed. As these old/cached packages are sitting in our pacman cache, that’s an issue for us as users to resolve (and I think deletion is a good reaction), not manjaro. That said; I think it would be fair to receive some advise or “best practices” from Manjaro on how to manage this situation.

One easy (although wide sweeping) way to do this (assuming your using KDE) would be to open the the pamac gui and purge the cache; although that could be an issue if you ever wanted to downgrade a package.

I think the command you found is the best solution… purging cached packages that no longer match the keyring (I’m assuming that’s what it does) sounds like a good thing to do. I’m going to look more into pacman -Suuw to see if I should add it to my “post update” tool chest.

1 Like

I’m running 5.17 kernel just fine, but that being said I ALWAYS keep the last 2 working LTS kernels on my system as well so that if the latest kernel won’t boot I can simply reboot and select a different kernel from the grub menu. I’d recommend at a bare minimum to always keep at least 1 other LTS kernel that works with your system so that if for whatever reason the latest stable kernel breaks anything you have a quick and easy way to get working until the issue is resolved.

1 Like