[Stable Update] 2022-01-23 - OpenSearch, Kernels, KDE Software, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

zfs-utils 2.1.2-2 is available in all branches, refresh your mirrors.


Okay, I found the solution. I did the one of the arch fix that @frost19k linked with the /etc/mkinitpcio.conf, create a custom one and generate the initramfs for the 5.16 kernel. And it works well on cold boot !
Thank you for your time !


I’ll have a go after my last meeting of the day

Sad, perhaps, but certainly the result of the wide open nature of Linux, which is not at all sad in my very very humble opinion. but I’ll leave the whys for some other time.

There are several choices for devs who want their apps to have a GUI: on my computer I have app GUIs written in gtk (several versions); QT (also several versions); wxwindows (probably more than one version?); one or more of python’s various GUI libraries or just from scratch; a small collection of pixilang apps whose GUIs are implemented in C by one (extraordinarily talented) multimedia developer; a handful of Java apps that come with one or two themes hard-coded in, so the only way to customize them would be to rewrite the source and recompile it myself; and several others I am surely forgetting or have never encountered.

Since every computer user will install a different set of apps, and the GUIs come from all fifteen million corners of the Linux world, it is not possible for a distro to write a single tool to rule every window decorating scheme.

You could, if you wanted to be able to configure your themes using the smallest number of tools, restrict the apps you use to whatever GUI tools your Desktop Environment supports out of the box. I use Openbox window manager, so don’t know what Gnome or KDE are up to these days, but in most cases the DE/WM theming tools may more may not be integrated with all versions of gtk, and Qt apps still need their own config tool.

So whether this would result in a machine that had all the applications you needed, I cannot say.

My advice is to back up your ~/.config directory early and often, and maybe become familiar with how color is configured: open a color picker (gcolor3, which you may already have installed, can be opened independently from graphics or theming apps) and see how colors work in the digital realm. The more you know, the easier it will be to fix things when they change.

Because things always change, but they change especially quickly in Linux rolling-release distros.

Welcome to our little microcosm of reality, where the trains most definitely do not run on time.

3 posts were split to a new topic: Systemtray bluetooth menu is empty after latest updates

It does not, no. On cold boot the built-in keyboard stops working from the initramfs stage & will not work even after I reach the GUI. However, it does work in GRUB.
This was not the case before the most recent update. Keyboard didn’t work in initramfs but was fine once I got to the GUI. So something has changed.

I have the UM325SA, btw. Maybe it’s a model specific thing? I haven’t been able to find any other solutions - I’m sorry :frowning:

No worries! It was fixed for me as mentioned in one of the earlier posts- had to set some new kernel option. It most likely is some model specific thing, since I didn’t have your issue earlier, and your solution didn’t work either. Just gotta try everything :stuck_out_tongue:

Did you generate an image with that custom mkinitpcio.conf file ?
Creating a /etc/mkinitcpio-custom.conf from the original file but using the arch solution worked for me.
I also overwrote the original 5.16 kernel initramfs file with the new mkinitcpio-custom.conf, and it worked : mkinitcpio --config /etc/mkinitcpio_custom.conf --generate /boot/initramfs-5.16-x86_64.img --kernel 5.16.2-1-MANJARO

I love your username!

I was able to chroot into my borked system and update zfs-utils without a glitch. I was back into my system in minutes.

updating the Python packages took a while but I am now up and running.

thank you for the support, particularly @philm for reverting the changes in zfs-utils.

A post was split to a new topic: Modem-manager-gui segmentation fault

Just wondering: what environment variables do you have for applying the theme to both Qt5 and Qt6 applications?
AFAIK qt5ct and qt6ct both require to be set to QT_QPA_PLATFORMTHEME, which takes a single value…

I saw those &, just for kicks, I tried it out on mine. Seems to work!

As an aside, I believe that on Manjaro the settings go into a file in the /etc/modprobe.d/ directory - rather than the file /etc/modprobe.conf.
I’m sure someone will correct me if I’m wrong or the distinction is irrelevant.

After this update, fish shell overrides the default cursor shape (block) for kitty terminal and sets cursor to beam!?

How do I get the old behavior/cursor back?


Solution: add shell_integration no-cursor to your kitty.conf

(Why is this suddenly needed, and it wasn’t before - no idea)

Since You and @kI3RO are on xfce, I’d like to add my two cents on the metter :slight_smile:
I did not change anything in Kvantum Manager.
I just installed qt6tc and set the background to kvantum, changed font, etc… just like @Strit said in his post above ( waaayy above :slight_smile: ).

From terminal


So nothing is changed.
Hope this clears it for you…


1 Like

update also wiped my qbittorrent settings including my using a proxy which I dont appreciate as I’ve just accidentally exposed my ip.

qt6ct crashes with Segmentation fault when i select qt6gtk2. :frowning_face:
I could try setting directly through the config file, but i don’t want to risk it. I’ll do with qbittorrent-qt5 for the time being, until the paint dries.

To be continued…

Thank you very much! Can now unlock my system again.


Maybe I wasn’t clear enough. Don’t change anything in Kvantum Manager.

In Kvantum Manager I have set only the theme to match my system theme and nothing else.
Current theme KVAdaptaMaiaDark it matches my system theme.

Open qt6tc and in Appearance first tab Style should be kvantum, Standard dialogs should be default or GTK3 your preference! For me both work.
Also set Icon Theme and the others to match your system. Apply and OK.
It works just fine for me for qBittorrent.

Edit qt6gtk2 → I don’t have that package installed.
Edit 2 However qBittorrent matches my system theme ( dark theme ) and works fine for now.

A post was split to a new topic: New Flatpak runtime updates available out of nowhere

Where is it? I can’t find it. Can you provide a full path to that option or a screenshot? There is no “Config->Apearence” anywhere, only “Configure active theme”. No menus or anything alike.