New Flatpak runtime updates available out of nowhere

Few mins ago, i just updated the mirrors and downloaded the new stable release… no error and everything went fine after restart… BUT after im just double check for updates in Pamac, there are 4 new updates available out of nowhere and the really strange move is, all 4 updates are Flatpak, but i never used flatpak besides i download few weeks ago a game but i don’t see any relations to this flatpak updates… whats going on now?

Should i better disable flatpak’s? I have a bad feeling to update this new Packages.

Here some system Infos:

Summary

inxi --admin --verbosity=7 --filter --no-host --width:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "de_DE.UTF-8",
        LC_NAME = "de_DE.UTF-8",
        LC_MONETARY = "de_DE.UTF-8",
        LC_PAPER = "de_DE.UTF-8",
        LC_IDENTIFICATION = "de_DE.UTF-8",
        LC_TELEPHONE = "de_DE.UTF-8",
        LC_MEASUREMENT = "de_DE.UTF-8",
        LC_TIME = "de_DE.UTF-8",
        LC_NUMERIC = "de_DE.UTF-8",
        LANG = "en_DE.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:
  Kernel: 5.15.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/vmlinuz-5.15-x86_64
    root=UUID=eb235aa7-d461-413d-800e-ea57385703fb rw quiet apparmor=1
    security=apparmor resume=UUID=a44dd3c4-f5f1-4587-8934-6f7413d28d4f
    udev.log_priority=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: Z170X-UD3 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: Z170X-UD3-CF v: x.x serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: F23d date: 12/01/2017
Memory:
  RAM: total: 15.58 GiB used: 1.93 GiB (12.4%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: Intel Core i7-6700K bits: 64 type: MT MCP arch: Skylake-S
    family: 6 model-id: 0x5E (94) stepping: 3 microcode: 0xEA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 4503 high: 4511 min/max: 800/4700 scaling:
    driver: intel_pstate governor: performance cores: 1: 4501 2: 4511 3: 4503
    4: 4500 5: 4503 6: 4507 7: 4500 8: 4499 bogomips: 64026
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
    art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c
    flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp
    hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm mca
    mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat
    pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts
    rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1
    sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: NVIDIA TU102 [GeForce RTX 2080 Ti Rev. A] vendor: Micro-Star MSI
    driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
    chip-ID: 10de:1e07 class-ID: 0300
  Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
    loaded: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 122 s-size: 533x302mm (21.0x11.9")
    s-diag: 613mm (24.1")
  Monitor-1: DP-4 res: 2560x1440 dpi: 123 size: 527x296mm (20.7x11.7")
    diag: 604mm (23.8")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170
    class-ID: 0403
  Device-2: NVIDIA TU102 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f7
    class-ID: 0403
  Device-3: Creative Labs Sound Core3D [Sound Blaster Recon3D / Z-Series]
    driver: snd_hda_intel v: kernel bus-ID: 0b:00.0 chip-ID: 1102:0012
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.16-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
Network:
  Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Message: No bluetooth data found.
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 4.57 TiB used: 68.01 GiB (1.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 960 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 2B7QCXE7 temp: 27.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 PRO 1TB
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HDN724030ALE640
    size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: A5E0 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Samsung
    model: Portable SSD T5 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B type: SSD serial: <filter> scheme: MBR
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 88.61 GiB size: 86.72 GiB (97.87%) used: 27.92 GiB (32.2%)
    fs: ext4 dev: /dev/sdc1 maj-min: 8:33 label: N/A
    uuid: eb235aa7-d461-413d-800e-ea57385703fb
  ID-2: /boot raw-size: 200 MiB size: 189.7 MiB (94.84%)
    used: 110.9 MiB (58.5%) fs: ext3 dev: /dev/sdc3 maj-min: 8:35 label: N/A
    uuid: 26eda82e-b403-49b8-abca-202167417020
  ID-3: /home raw-size: 332.03 GiB size: 325.82 GiB (98.13%)
    used: 8.84 GiB (2.7%) fs: ext4 dev: /dev/sdc4 maj-min: 8:36 label: N/A
    uuid: ada4a6a2-bd0a-4652-b386-7c637bba7ee9
  ID-4: /media/temp raw-size: 63.48 GiB size: 62.18 GiB (97.96%)
    used: 31.14 GiB (50.1%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: temp
    uuid: 1e81b7c2-3438-438a-b572-ff8a966a78e1
Swap:
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 2.93 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sdc2 maj-min: 8:34 label: N/A
    uuid: a44dd3c4-f5f1-4587-8934-6f7413d28d4f
Unmounted:
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 442.47 GiB fs: ntfs label: ssm
    uuid: AE7EDC0696B158FD
  ID-2: /dev/sda1 maj-min: 8:1 size: 50 MiB fs: ntfs
    label: System-reserviert uuid: B2286A122869D5BF
  ID-3: /dev/sda2 maj-min: 8:2 size: 293.16 GiB fs: ntfs label: win10
    uuid: 5E60C09860C077F3
  ID-4: /dev/sda3 maj-min: 8:3 size: 515 MiB fs: ntfs label: N/A
    uuid: 20E8D914E8D8E954
  ID-5: /dev/sda4 maj-min: 8:4 size: 585.94 GiB fs: ntfs label: games
    uuid: 165692E31D7ADAF2
  ID-6: /dev/sdb2 maj-min: 8:18 size: 1.57 TiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-7: /dev/sdb3 maj-min: 8:19 size: 1.09 TiB fs: <superuser required>
    label: N/A uuid: N/A
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-13:2 info: A4Tech XL-730K / XL-750BK / XL-755BK Mice
    type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 09da:9090 class-ID: 0301
  Hub-2: 2-0:1 info: Super-speed hub ports: 10 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-5:2 info: Samsung Portable SSD T5 type: Mass Storage
    driver: uas interfaces: 1 rev: 3.1 speed: 5 Gb/s power: 896mA
    chip-ID: 04e8:61f5 class-ID: 0806 serial: <filter>
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-5: 5-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 6-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 34 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 25%
Info:
  Processes: 237 Uptime: 8m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1347 pacman: 1342 lib: 402
  flatpak: 5 Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
5 Likes

To get an overview of what is installed using flatpak use

flatpak list

To get detailed info about a package and the used runtimeenvironment use:

flatpak info [ApplicationId]

As flatpak does remove any unused package by without being asked to to so you need

flatpack uninstall --unused

to cleanup left over dependencies.

3 Likes

flatpak list:

Name                       Application ID                                  Version          Branch       Installation
Beyond All Reason          info.beyondallreason.bar                        1.1351.0.1       stable       system
Freedesktop Platform       org.freedesktop.Platform                        21.08.8          21.08        system
Mesa                       org.freedesktop.Platform.GL.default             21.3.3           21.08        system
nvidia-495-44              org.freedesktop.Platform.GL.nvidia-495-44                        1.4          system
openh264                   org.freedesktop.Platform.openh264               2.1.0            2.0          system

Besides the Flatpak game “Beyond all Reason” i have nothing with Flatpak manually installed on my PC. And this Flatpak updates just showed up, right after my stable release update.

It is not out of sudden. You may have flatpak packages installed. See also here: show all flatpak updates (94ca22ea) · Commits · Applications / libpamac · GitLab

Hi everybody,

Those updates pop up on my laptops too, but if I click on apply pamac-manager asked for my password and then simply reloads the (allegedly) available updates. No other actions are performed.

I think it’s related to the last Manjaro update:

[2022-01-27T09:13:32+0000] [ALPM] upgraded pamac-gtk (10.3.0-2 -> 10.3.0-4)
[2022-01-27T09:13:32+0000] [ALPM] upgraded pamac-cli (10.3.0-2 -> 10.3.0-4)
[2022-01-27T09:13:32+0000] [ALPM] upgraded libpamac-flatpak-plugin (11.2.0-3 -> 11.2.0-4)
[2022-01-27T09:13:32+0000] [ALPM] upgraded libpamac (11.2.0-3 -> 11.2.0-4)

I can confirm with certainty that there are no flatpak updates:
a) the command sudo flatpak update --system results in:

$ sudo flatpak update --system
Looking for updates…
Nothing to do.

Installed flatpaks:

$ flatpak list

Name                                            Application ID                                Version            Branch          Installation
Freedesktop Platform                            org.freedesktop.Platform                      20.08.17           20.08           system
Freedesktop Platform                            org.freedesktop.Platform                      21.08.9            21.08           system
Mesa                                            org.freedesktop.Platform.GL.default           21.1.8             20.08           system
Mesa                                            org.freedesktop.Platform.GL.default           21.3.3             21.08           system
openh264                                        org.freedesktop.Platform.openh264             2.1.0              2.0             system
GNOME Application Platform version 40           org.gnome.Platform                                               40              system
GNOME Application Platform version 41           org.gnome.Platform                                               41              system

Installed flatpak packages:

$ sudo pamac search --installed flatpak
libpamac-flatpak-plugin                                                                                                                 11.2.0-4  extra 
    Flatpak plugin for Pamac
flatpak                                                                                                                                 1.12.3-1  extra 
    Linux application sandboxing and distribution framework (formerly xdg-app)

b) I run almost a dozen Debian Testing KVMs, and none of them claims that there are any flatpak updates.

c) Even after removing unused flatpak packages pamac-manager still claims that there are updates:

$ sudo flatpak uninstall --unused

        ID                                           Branch          Op
 1. [-] org.freedesktop.Platform.GL.default          20.08           r
 2. [-] org.freedesktop.Platform                     20.08           r
 3. [-] org.freedesktop.Platform.Locale              20.08           r
 4. [-] org.gnome.Platform                           40              r
 5. [-] org.gnome.Platform.Locale                    40              r
$ sudo flatpak list
Name                                            Application ID                                Version           Branch           Installation
AnyDesk                                         com.anydesk.Anydesk                           6.1.1             stable           system
Freedesktop Platform                            org.freedesktop.Platform                      21.08.9           21.08            system
Mesa                                            org.freedesktop.Platform.GL.default           21.3.3            21.08            system
openh264                                        org.freedesktop.Platform.openh264             2.1.0             2.0              system
Cheese                                          org.gnome.Cheese                              3.38.0            stable           system
GNOME Application Platform version 41           org.gnome.Platform                                              41               system
$ sudo flatpak update --system
Looking for updates…
Nothing to do.

Pamac-Manager:

Any ideas? @philm ?

1 Like

Same problem here. In my case these are the packages listed in pamac:
KDE Application Platform org.kde.Platform 5.15 flathub system
KDE Application Platform org.kde.Platform 5.15-21.08 flathub system

By the way I cannot understand why I have two org.kde.Platform installed ::

@laska.bozzolo They are different versions. Different apps are built on different versions. This is not unusual, even with traditional package manager installers.

I also had this issue with two KDE platform packages turning up repeatedly in Pamac GUI no matter what I did, but as suggested above by @a-sassermann

flatpak uninstall --unused

Removed those and now Pamac GUI reports all updates are installed - what hasn’t updated is the Pamac updates notifier in my manjaro Gnome status area. I’m sure it will catch up eventually :wink:

I tried

flatpak uninstall --unused

but I get “Nothing unused to uninstall”

As I wrote in my post that makes no difference at all. Maybe pamac-manager has a different caching mechanism? There is no problem with pamac.

Doing flatpak uninstall --unused removed these packages in pamac for me.

I had same issue running sudo pacman -Syu fixed it for me. Cli reported nothing to do and then mysterious flatpak updates in pamac disappeared

Hi sawdoctor,

I ran sudo pacman -Syu

$ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do

and then

$ sudo flatpak update --system
Looking for updates…
Nothing to do.

But it made no difference in pamac-manager (the GUI not the CLI). The CLI command pamac has no flatpak or snap integration, at least I haven’t found it yet but I made be wrong on that.

The GUI (pamac-manager) still shows two flatpak updates.

Interestingly on another laptop, also running Manjaro-Xfce stable, there isn’t any issue with pamac-manager. But I can’t find any differences between the laptops; both running as KVM hosts; same configuration; even the hardware is the same (both are Tuxedo Pulse1 Gen15), the only difference is that one has 64GB RAM and 2TB storage, and the other has 32GB RAM and 1TB storage. The former has the issue.

Strange, maybe refresh database in pamac gui? There’s definitely no updates but it was annoying me seeing the red icon all the time

I did refresh the DB in pamac-manager; I also updated my mirrors; but that also made no difference. I’m lost…very strange behavior.

I downloaded the updates (and i had to download/install the freedesktop.Platform nvidia driver twice) after @philm replied that this updates can’t show up out of nowhere i though its the best way to blind go through the update process :innocent:

Anyways i have to add, that pamac no longer shows updates now after updating the flatpaks.

But you guys may proofed me wrong… i just hope i don’t downloaded compromised files (maybe a security leak?) inside manjaro/pamac? :cold_face:

That’s interesting, because I tried to apply the (alleged) updates too, but in my case pamac-manager did not do any updates but showed the updates again.

yeah same… i had to repeat this steps two or three times again to finally finish it.

I just did it 15 times, I think; could be more, pamac-manager shows Transaction successfully or so and then check for updates, and shows me the flatpak updates again. There isn’t anything to update in my flatpak installation. I can’t help to believe that there is something wrong with pamac-manager since the last update. It seems not to have any influence on the CLI, hence it’s currently just annoying to have that dot on the tray icon.

In my case too… I tried to apply several times, but pamac didn’t do anything and showed the updates again and again ::
Annoying

I don’t know if it will help but the last time I had an issue with an update I changed the mirrors from United States to Worldwide refreshed and everything updated.After the updates I switched back and haven’t had any issues.