[Stable Update] 2021-12-10 - Kernels, Systemd, LibreOffice, Plasma, Browser, Thunderbird

Oh my, I’m detail-oriented but forgot this link, so thanks! In this topic, they recommended installing breeze-gtk package, which worked nicely here. As related to the depreciation of breath2, papirus icon is complete and fancy, and combined with arc color (plasma style) is my go to. I like breeze, but IMHO the icon pack is too dark and the icon for some applications is missing. The plasma style is thin for my screen (1920 x 1080).

Can you try using kernel 5.14 (if you have it still) or 5.10? Looks like 5.15 has some problems even on other distributions that will be resolved on 5.16,one of them is bluetooth not working (its happening to me as well).

did you try manually mounting to see if it works, i.e.;

# mount -t ntfs3 /dev/sda2 /mnt/Varasto

i’ve reverted back to using ntfs-3g, looks like there are still some kinks that needs to be worked on. from what little i understood the new driver is meant to imitate options provided by ntfs-3g on the new driver for interoperability, but some are not implemented as well on ntfs3 yet.

Desktop Background keeps changing to default every update. Especially on the SDDM background login, that resets seemingly at random. Plus power options screen (ctrl+alt+del) blur is showing as just black. Other than that it went seamlessly

Well, there are a couple of thing to try out. If your network is up and running, doing a pacman sync

pacman -Syy

and then reinstalling sudo, the kernel (perhaps a slightly newer one than 5.10) via

mhwd-kernel -i linux515

(which takes care of updating grub) and dependencies that are suggested and seeing if that helps to boot the system again.

Then there are tricks like this to try and rescue a broken install when your feel unsure of which packages are broken from your adventures:
Reinstall All Packages with Pacman on Arch Linux

1 Like

To all people using nVidia Drivers and getting issues with the login manager not loading (system hanging on “Starting Hostname”) I think the issue are the nvidia drivers not working anymore

What I did was obviously go to TTY with Alt+F2 and login, then “sudo systemctl disable lightdm” (or “sudo systemctl disable gdm” whichever you are using), and reboot

That only lead to go directly into login from terminal, then try “startx” and you get a “(EE) Not screens (EE)” found, so instead of looking a lot into xorg stuff I moved to

Then I checked the drivers with:
inxi -G
mhwd -l

Following it I made the system to search for drivers and install them (without uninstalling the others previously, I know it wasn’t “optimal” but whatever, I wasn’t in the mood)

sudo mhwd -a pci nonfree 0300

The system then checked, downloaded, installed them, rebuild the config, and reboot, but since I disabled the login screen manager I went directly into TTY again and log in from there, BUT this time when I executed “startx” it DID WORK

After going into the DE I opened a console and “sudo systemctl enable lightdm” (or “sudo systemctl enable gdm” whichever you are using), and reboot

Finally everything worked fine but TBH it wasn’t a nice experience, I know it could be my fault for not checking the drivers before updating but damn… I read “STABLE” and trusted like nothing could go wrong. I think the system should check this sort of things before updating and warning you if you have something set that won’t work instead because if a standard user have this issue there is no way he is going to solve it alone.
By no means I am trying to blame the devs but mostly give my feedback of things that can be improved in future upgrades to prevent this broken stuff for a standard user, or at least if there is something really important like graphic drivers going to be useless to warn it properly

1 Like

same result, not working. only way is to use ntfs not ntfs3. using uuid or path gives same results. i think the fuse uses ntfs-3g and ntfs in fstab does the same. so in the end i have access to ntfs partition but only with the older driver. :sunny: at least that and not complete failure!

Even Gardiner Bryant (a.k.a The Linux Gamer) was using an EOL kernel in a video he was talking about why he likes Manjaro. He also mentions he only updates his kernel only for driver support for new hardware. But I don’t think it’s a good practice, especially when you’re not using an LTS or a supported kernel. It may lead to security vulnerabilities I guess. So I agree it may be good to add some text like “unsupported” next to the name of the kernel.

It was suggested earlier also:


My Laptop did update without Problems.
My Desktop did not show GUI after the Update.

I do have a solution for one problem (meant no GUI)

:white_check_mark: solution : Every Update breaks my configuration solved by the forum :smiling_face_with_three_hearts:

and a temporary workaround, but not yet a solution for the other:

workaroud : :scream: Module nouveau: unknown symbol in module :crazy_face:

1 Like

Lighting LEDs are not the sign that the PC still responds to keyboard.

To understand does the PC hangs or not, better to switch NumLock / ScrollLock / CapsLock on and off to see does PC answers to that requests by changing the LED light of keyboard. If LED light not changes, then PC does not respond to keyboard (but sometimes simple re-plug is a pill for this).

May be it is able to find journactl messages related to this effect?

Not good. Hangs solid or PC’s port (where you plugged the keyboard) hanged.
If to re-plug the keyboard, then no reaction if to press keys which should change a LED lights?

Need to DuckDuckGo every suspected line of journactl to start to investigate the issue relations closely.

I apologize, did not mean to offend anyone.

1 Like

I apologize, sir, did not mean to offend anyone.

1 Like

Again with the i18n issue in Firefox.
I checked the version of the language pack used, and i was still the one prior to the update… even though the pack in the packages is the correct version. Digging a bit in the configuration files, i found another language pack put here – likely from a time i tried to fix it long ago. Removing that pack, reinstalling the package, and rebooting Firefox this the trick.

After update I had a problem with optimus-manager (more here) and I couldn’t switch from integrated to nvidia, when I try to get status:

$optimus-manager --status                                                                                                                                                                                        
ERROR: cannot check the active card (should be "nvidia"). Reason: Cannot run glxinfo: /bin/sh: line 1: glxinfo: command not found

Something went wrong during the last GPU setup...
Log at /var/log/optimus-manager/switch/switch-20211211T224731.log
Cannot execute command because of previous errors.

Log switch-20211211T224731.log show this:

$cat /var/log/optimus-manager/switch/switch-20211211T224731.log
[19] INFO: # Xorg pre-start hook
[19] INFO: Previous state was: {'type': 'pending_pre_xorg_start', 'requested_mode': 'nvidia', 'current_mode': None}
[19] INFO: Requested mode is: nvidia
[675] INFO: Available modules: ['nouveau', 'nvidia', 'nvidia_drm', 'nvidia_modeset', 'nvidia_uvm']
[676] INFO: Unloading modules ['nouveau'] (if loaded)
[682] INFO: switching=none, nothing to do
[715] INFO: Loading module nvidia
[1017] INFO: Loading module nvidia_drm
[2802] INFO: Writing to /etc/X11/xorg.conf.d/10-optimus-manager.conf
[2802] INFO: Writing state {'type': 'pending_post_xorg_start', 'switch_id': '20211211T224731', 'requested_mode': 'nvidia'}
[2802] INFO: Xorg pre-start hook completed successfully.
[7] INFO: # Xorg post-start hook
[7] INFO: Running xrandr commands
[405] INFO: Running /etc/optimus-manager/xsetup-nvidia.sh
[451] INFO: Writing state {'type': 'done', 'switch_id': '20211211T224731', 'current_mode': 'nvidia'}
[452] INFO: Xorg post-start hook completed successfully.
[14] INFO: # Pre-suspend hook
[15] INFO: Previous state was: {'type': 'done', 'switch_id': '20211211T224731', 'current_mode': 'nvidia'}
[18] INFO: Switching option: none
[18] INFO: Nothing to do
[18] INFO: Writing state {'type': 'pending_post_resume', 'switch_id': '20211211T224731', 'current_mode': 'nvidia'}
[18] INFO: Pre-suspend hook completed successfully.
[16] INFO: # Post-resume hook
[16] INFO: Previous state was: {'type': 'pending_post_resume', 'switch_id': '20211211T224731', 'current_mode': 'nvidia'}
[19] INFO: Nothing to do
[19] INFO: Writing state {'type': 'done', 'switch_id': '20211211T224731', 'current_mode': 'nvidia'}
[20] INFO: Post-resume hook completed successfully.

There was a problem to get status and assign mode dynamically.

To solve problem, at least temporary I create a conf file to indicate optimus-manager switch to nvidia:

  1. Copy default config file:
    cp /usr/share/optimus-manager.conf /etc/optimus-manager/optimus-manager.conf

  2. On file optimus-manager.conf change startup_mode and startup_auto_battery_mode and assign “nvidia”

  1. Restart your Manjaro.

Continue enjoying Manjaro and your second monitor :sunglasses:

I take issue with the rework of Breath themes. The update removed the Breath theme for Plasma which has dark panels/widgets but white text and icons (and not the stupid grey).

How do I get that plasma theme back?

Use Breeze theme if you prefer white text more.

Add/Remove software title bar now looks like this

All other windows looks good

check Known issues and solutions post (# 2):
the KDE Plasma shows visual graphical errors section.

1 Like