Cannot unlock blank primary and external screens in xfce 21.1.6

My notebook is HP 14-ck0023TU and the ultrawide external monitor is LG 29WK600-W.
Screenshot_2021-11-15_07-01-23
After 1 minute, both screens were locked and blank.
But I can’t unlock it for both screens are blank.
Help me please.

Don’t you get the login prompt when typing or moving the mouse?

1 Like

No.
Both screens are blank and black.
The only one way that can be done is switch off the notebook :cry:.

I spotted this while searching earlier. Some found a few workarounds.

1 Like

I tried by using live USB. This problem occurs on distros based on RedHat(Fedora) and Arch(Manjaro & Endeavor). On the other hand, all distros based on Ubuntu(Ubuntu, Linux Mint, POPOS, Zorin, Deepin, etc.) can wake up normally.

I had to move from Fedora 34 to Linux Mint 20.2 for I love bottom panel which comes by default. But LM is not fast as Fedora. One of my friends suggested Manjaro and convinced that Manjaro is fast and neat.

I really wonder why all distros based on Ubuntu can.
And Manjaro works so well if there is no external monitor.

I think that’s because Ubuntu and its derivatives aren’t as cutting edge as Fedora and Arch/Manjaro, so they don’t have the issue… yet.
Though i say this, i don’t have it either. :man_shrugging:

1 Like
  1. I previously forgot to notice the keyboard then I tried Manjaro GNOME 21.1.5 and XFCE 21.1.6 live USB again.
    I found that even though both screens were black, but keyboard was still active.
    Num Lock and Caps Lock could be switched on and off.
    How could I use keyboard to wake Manjaro up :thinking: ?

  2. From this post and another post, can you please teach me how to do it for it is very difficult for me as an ordinary user :cold_face: ?

You make the change in the xflock4 script

Rather than modifying the script directly, Xfce allows to set a custom lock command, which is then used by xflock4.

  1. You can first check that the current value is as described there. No return value means it is not defined.
xfconf-query -c xfce4-session -p /general/LockCommand
  1. Replace the value with the suggested custom command. If it wasn’t defined, you may need to create the entry by adding --create:
xfconf-query -c xfce4-session -p /general/LockCommand -t string -s "dm-tool switch-to-greeter"

These steps can alternatively be done graphically.

I tried using this and locked the screen. However, it shows the. “This screen is locked” message and had to switch to TTY2 and use this command:

$ loginctl unlock-sessions

Not sure what to look for to determine the cause to know where to submit it.