[Stable Update] 2021-09-24 - Kernels, LibreOffice, Browsers, Pipewire, RHVoice, KDE Frameworks, Mesa

Hmm, is that at all related to pamac showing manjaro-release 21.1.4-1.0… but $ cat /etc/lsb-release indicates


Perhaps I was not very clear.
I applied the Stable Update 2021-09-24 when it was released sometime on Friday evening. That was a major update - so about 200 odd files - didn’t pay attention to the exact number. And yes I am aware it’s a rolling release, but I was surprised to see a notification today (Sunday afternoon 26th September) stating that there were another 200 updates available. I just found it unusual as the update app pamac only showed 6 applications.

I have just turned on my computer this evening (Sun26 19:00) and currently I don’t see a notification. Well not yet anyway.

This computer was used temporarily on Saturday and I did not see any notifications (so it’s not a reboot issue)

Update : time is now 20.07 and the notification icon has returned - pamac was earlier only showing 6 apps as I had Software Mode enabled - with that unflagged the rest of the apps are visible - but I’m still concerned as to whether I need to run the update again (don’t know if it is an issue but I encrypted my drive)

Quick mention that I fixed my Xbox One S controller, eventually, by removing the device from the known Bluetooth devices list and then pairing it again. A simple fix after I downgraded firmware, kernel and tried a whole bunch of other things… Oh well, who cares about gaming on weekends, right?



After the update my laptop has had an issue with pressing the m key periodically, but today it is constantly pressed to the point where my laptop is useless. Don’t know if it’s stemming from the same issue, but my touchpad is not reacting either, thinking it’s the constant pressing of the m key that is the reason.

Anyone has a fix for this?

Too bad new NVIDIA driver didn’t make it to this update. I understand it has bug with G-SYNC, but I think there is more people gaming on Linux who need memory leak fix (especially on low memory GPUs like 2060 with only 6GB), than gamers with G-SYNC. Maybe there is a way to have two latest driver versions in repo - from previous update and a new one?

With this update installed, my GUI (XFCE) won´t start any more.
Lightdm says xorg failed.
The logfile of xorg shows, that nouvea is not recognized.
But lsmod shows it is loaded.

I tried this also with an USB-Install. Even there it will not boot into XFCE if it is updated to latest xorg :frowning:
Should i downgrade xorg ??? Or schould i roll back and wait ?

This is written from my laptop because my pc has no GUI at the moment.
I did a manual Rollback and do have a GUI again. But i need help solving this problem in support forum

With the update, menus across the board are broken in firefox. File menu, extension toolbars, right click on a website, etc. Instead, only an up arrow/down arrow shows up

I’m running KDE + wayland + native wayland on firefox (MOZ_ENABLE_WAYLAND=1). Will update the thread if I figure out more

Workaround (not sure what resolved the issue)
MOZ_ENABLE_WAYLAND=0 firefox → menus work
Downgrade firefox sudo pacman -U https://archive.archlinux.org/packages/f/firefox/firefox-91.0.2-1-x86_64.pkg.tar.zst → Menus work
Upgrade firefox → Menus work.

So I’m not sure what fixed it exactly. Maybe there was something bad in the firefox profile which self-healed after these steps. However, the issue did span reboots before trying the remediation efforts

It doesn’t work like that. If you want the latest NVIDIA driver sooner, switch to the testing or unstable branch.

After the libreoffice 7.2.1-2 update, the export of pdfs only exports a blank empty pdf without data.

Print to file is also not working.
This command is also only producing a blank pdf.

libreoffice --headless --convert-to pdf  myfile.odt

Switching from fresh to still also did nothing for me.
For now I installed the libreoffice snap, which is working fine.

It’s not just that G-Sync breaks with the latest driver, but that if a person loads up after the update and they have a G-Sync display, they can be stuck in a situation where they can’t boot into their Manjaro install.

If you want to test the NVIDIA driver, feel free to switch to the testing branch as mentioned, but since the NVIDIA driver is not stable, it does not belong in the stable branch.

1 Like

After this update, my system is acting totally weird.

I have Manjaro since February 2019, and everything is always been good.

But since this update I firstly encountered this issue:

Then I also noticed that mpv (has been updated from 1:0.33.1-2 to 1:0.33.1-3) after a while of playing, will freeze all the system: luckily I can go to TTY2 and there executing systemctl reboot.
But I am upset… I had a rock solid system, but since this update, has become unreliable…

EDIT: I downgraded mpv, but the issue persists: after a while (about five minutes of playing) the system completely freeze…


I switch from stable branch to testing branch:

sudo pacman-mirrors --api --set-branch testing
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu
[2021-09-27T22:27:49+0200] [PACMAN] Running 'pacman -Syyu'
[2021-09-27T22:27:49+0200] [PACMAN] synchronizing package lists
[2021-09-27T22:27:50+0200] [PACMAN] starting full system upgrade
[2021-09-27T22:28:06+0200] [ALPM] transaction started
[2021-09-27T22:28:06+0200] [ALPM] upgraded libxnvctrl (470.63.01-1 -> 470.74-1)
[2021-09-27T22:28:06+0200] [ALPM] upgraded manjaro-release (21.1.4-1.0 -> 21.1.5-1)
[2021-09-27T22:28:06+0200] [ALPM] upgraded matcha-gtk-theme (20210823-1 -> 20210924-1)
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] 
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] Firefox theme
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] See /usr/share/doc/matcha-gtk-theme/firefox/README.md
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] 
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] Gedit theme
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] See /usr/share/doc/matcha-gtk-theme/gedit/README.md
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] 
[2021-09-27T22:28:06+0200] [ALPM] upgraded mhwd-nvidia (470.63.01-1 -> 470.74-1)
[2021-09-27T22:28:06+0200] [ALPM] transaction completed
[2021-09-27T22:28:07+0200] [ALPM] running '30-systemd-update.hook'...
[2021-09-27T22:28:07+0200] [ALPM] running 'rebuild-detector.hook'...

(libxnvctrl ?? Is for nVidia, but on my system there is no nVidia, only Intel).

What happened:

The system freezed again for few seconds (about 15 seconds), then become responsive again.
In the Journal log I don’t see (or I am not able to search about) nothing about.

I’ll update this message: I am not totally sure of what is happening.

EDIT 3: nothing to do: I was playing again using mpv and the system freeze again.

EDIT 4: I discovered that when the system freeze, instead of doing systemctl reboot, I can execute pkill -KILL -u $myusername and the system will become usable again. But this is a workaround; shouldn’t happen.

EDIT 5: I currently using smplayer (tried various times, also for more than an hour of playing) and the system freeze doesn’t occured; the funny thing is that smplayer using mpv as video backend.

Does the snap have the same libreoffice version?

What happens if you reset Libreoffice (non-snap) to default settings?

rockin’ an old kernel there? you probably have reasons, but patches only go so far?

Old system here: Ivy Bridge - (kernel 4.14 LTS).
During these years I tried newer kernels but doesn’t play good here (eg: slow boot and no suspend-to-ram).

Otherwise good update, but for some reason my XFCE audio mixer volume meters stopped functioning. And I have no clue how to fix those.

Hi, minor issue. After updating the other day, all of the fonts turned into squares. I rebooted and all turned back to normal. That is except for one of my mail programs which is a snap program.
I’m not sure what caused the issue in the first place so am at a loss as to how to fix it in the snap program that it is still affecting.
I can use the program but if I minimize the program to the taskbar and then click on the icon the menu that comes up appears as Squares in place of letters. Also when opening a certain menu in the program to select a location on the computer it too is all squares.
Does anyone have any idea what caused this and if so a solution? Was there a font that was replaced and thus needed a reboot and that has not been replaced on the snap program?

Hello !
Same thing here, and after reboot fonts are normal.
I dont use snaps, so all programs have normal fonts.
This is the first time i see that.

I don’t use a lot of snaps but I am currently using 2. One of them has no issue at all. The other is the only program that still has the squares.

After the update KMail won’t start with error “The Akonadi personal information management service is not operational”.

❯ akonadictl start                                                                                                                                                         [127]
org.kde.pim.akonadictl: Starting Akonadi Server...
org.kde.pim.akonadictl:    done.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
org.kde.pim.akonadiserver: Starting up the Akonadi Server...                                                                                                                     

❯ org.kde.pim.akonadiserver: database server stopped unexpectedly                                                                                                               
org.kde.pim.akonadiserver: Database process exited unexpectedly during initial connection!
org.kde.pim.akonadiserver: executable: "/usr/bin/mysqld"
org.kde.pim.akonadiserver: arguments: ("--defaults-file=/home/user/.local/share/akonadi/mysql.conf", "--datadir=/home/user/.local/share/akonadi/db_data/", "--socket=/run/user/1000/akonadi/mysql.socket", "--pid-file=/run/user/1000/akonadi/mysql.pid")
org.kde.pim.akonadiserver: stdout: ""
org.kde.pim.akonadiserver: stderr: "2021-09-28 12:38:43 0 [Note] /usr/bin/mysqld (server 10.6.4-MariaDB) starting as process 189459 ...\n"
org.kde.pim.akonadiserver: exit code: 1
org.kde.pim.akonadiserver: process error: "Unknown error"
org.kde.pim.akonadiserver: Shutting down AkonadiServer...
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally...

This update has solved two of my issues:

  • Problems with keys when updating - I can update the system again.
  • When using kernels 5.., exactly every second reboot resulted in a black screen, but I could login by typing the password blindly. Now I’m using 5.10.68-1 and the problem’s gone.

Now I’ve been experiencing a minor issue:

  • As I don’t like the native resolution of my laptop (I need a bit bigger letters), I use a custom screen resolution, which I set via the graphical tool (XFCE); however, this setting is lost whenever I reboot.