[Stable Update] 2021-07-13 - Kernels, Plasma 5.22, Cinnamon 5, Gnome 40, LibreOffice, Mesa, Nvidia, Pamac

Thanks. I’d seen that forum post earlier but wasn’t sure if it was still up to date, given that it predates Nvidia’s announcement of proper Wayland support. If people have used the steps described in that thread to get a good working setup with the current stable release, I’ll give it a shot.

I actually updated it in the last day or two. :wink:

Just curious. Are you planning to replace Xorg with Wayland?

And I used it right after and can confirm everything is working as it should. Thanks @Yochanan :ok_hand:t2:

A comment on the Overview screen search in Gnome Shell 40:

Using the Gnome 40 shell, there is a problem with the search behavior in Overview. If I type ‘g’ I get some results with the first highlighted. I can press enter to open it. To select one of the other results, I should be able to use arrow keys to change the selection box to another choice. That doesn’t work - it used to in shell 3.38. Now, you have to use the mouse to click on an alternate selection to open it.

I then looked at Fedora Gnome 34 and the arrow keys do work as described, so something is wrong here with the Manjaro implementation?

UPDATE: I found that the cause of this problem is having Dash-to-Dock enabled. When I disable that extension, the functionality of the arrow keys within the search results is restored.

UPDATE 2: Jul 16: This problem with the arrow keys is now gone. :slightly_smiling_face:

Hi! First of all. Happy anniversary, Manjaro! Thank you for the effort and dedication to the system and trying to provide an excellent quality of experience at all possible levels.

And now. The update got stuck in the process marked by the bar, but outside of it all normal. I use GNOME 40. I have installed iio-sensor-proxy . The only problem that for the moment I have noticed is that the automatic screen rotation does not work in Wayland (it does in Xorg, but it was strange since the first times I was playing around the option did appear in Wayland, I think … But for the moment it only appears now in the Xorg session). It’s kind of strange. Since the Xorg is not very touch-friendly to say …

At the moment, and outside of that, everything feels very polished and I’m happy about the long wait. Greetings!

1 Like

Both pacman and pamac do not resume after showing the following issues (after checking for data conflicts):
Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
linux-firmware: /usr/lib/firmware/rtl_bt/rtl8761b_config.bin existiert im Dateisystem (gehört zu rtl8761b-fw)
linux-firmware: /usr/lib/firmware/rtl_bt/rtl8761b_fw.bin existiert im Dateisystem (gehört zu rtl8761b-fw)

Do I have to delete those files? Is that driver part of the updated Kernel now? I am on 5.12.16-1 right now.

It seems like that firmware is now part of linux-firmware package, so you should remove the rtl8761b-fw package.

2 Likes

Hello all,

The update did not go as smooth as usual. After the update was finished, the system became very sluggish. So decided to do a reboot and it came back to the login screen. However fingerprint login or password login never did anything. Had to wait for a long time and it just comes back to the password field to enter it again. Tried to go to tty but after I put in my username, it again took a very long time only to get a response of ^@ whatever that means :rofl:

So I tried to reboot and edit my grub config by adding the 3 to the linux line so it would boot directly into tty. The same happened here, after I enter my username it just sits only to come back with the ^@.

Next try was to boot from a live USB stick and use chroot. So I chrooted into the system, forgot that in the option list 0 === 1 and you have to select 1 for option 0 :face_with_hand_over_mouth:. There I checked the logs but did not see anything specific. What came to mind was that I did not see the notice that I could use the fingerprint reader when I tried to login before. So I decided to remove all the lines with auth sufficient pam_fprintd.so in all the pam.d files where I had added them. Rebooted and behold I was able to login.

Just need to check now what is going on with the fingerprint reader and fix that. This is on a Dell XPS 17 9700.

2 Likes

My update didn’t go so well, I’m getting a crash when loading pamac-manager that says “pamac-manager: symbol lookup error: pamac-manager: undefined symbol: hdy_flap_set_reveal_flap, version LIBHANDY_1_0”

I tried to check on my libhandy1 installation but got some bizarre results. Pamac can’t reinstall it because it’s not found (not anywhere, ancient-packages lists it), and if I go to remove it theres some components dependent on it, including pamac-manager, manjaro-hello, etc. I tried installing libhandy from the extra repo but it conflicts with libhandy1 so my understanding at the moment is that if i uninstall libhandy1, pamac-manager will be dependent on a nonexistent package, which just can’t be right… I’ve refreshed my mirrors, run pacman -Syyuu, restarted, and just about everything else i can think of but I’m not sure where to go from here.

I’m currently on 5.13.1-3-MANJARO x86_64 with Cinnamon 5.0.4

sudo pacman -Rdd libhandy1 && sudo pacman -Syu libhandy

FYI, libhandy1 was an AUR package before the extra repo package updated.

3 Likes

Brilliant. I had install libfprint attempting to get my dell fingerprint reader working. Not supported, but removed libfprintd and libfprint-tod-git… and Boom! Fixed. I think you should get the “solution” for this!

thank you so much, i think the nodeps is exactly what i was looking for. I’ve been leaning on pamac for too long I guess

Thx!
Removing the rtl8761b-fw firmware did the trick.

1 Like

Removed fprintd stuff I had installed playing with the fingerprint reader. Removed it and all good.
thanks @rolandd

Bug, probably not related with this update specifically, but it did not resolved it anyway:
On my system I got these udev rules (/etc/udev/rules.d/90-mhwd-prime-powermanagement.rules):

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"

    # Remove NVIDIA USB Type-C UCSI devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"

    # Remove NVIDIA Audio devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"

    # Enable runtime PM for NVIDIA VGA/3D controller devices on driver bind
    ACTION=="bind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030000", TEST=="power/control", ATTR{power/control}="auto"
    ACTION=="bind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030200", TEST=="power/control", ATTR{power/control}="auto"

    # Disable runtime PM for NVIDIA VGA/3D controller devices on driver unbind
    ACTION=="unbind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030000", TEST=="power/control", ATTR{power/control}="on"
    ACTION=="unbind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030200", TEST=="power/control", ATTR{power/control}="on"

(I couldn’t find out from which package it came from, so I suppose that the installer put it there when I installed Manjaro)

It was there becase of few bugs (Chapter 22. PCI-Express Runtime D3 (RTD3) Power Management) that needed to disable some features of the card for power management reasons. The point is that, now, the first three rules can be removed if you have installed the last driver version and run a kernel version >= 5.5 (and it’s important to do that because, otherwise, fundamental features like audio over hdmi will NOT work)

1 Like

Hi people!
First of all. Congratulations! :partying_face: :birthday:
Another dash-to-dock’s user here waiting for support. Meanwhile using dash-to-panel on the top which is also quite beautiful but I would rather the manjaro legacy layout.

Same problem here!

This update bumped nvidia driver from 465xx to 470xx and, well, my Guild Wars 2 under Lutris freezes the game window and then whole system to the point I need to kill X server. To my knowledge there’s no way to downgrade to the previous version of driver in an easy way.

Update crashed OS, it gets past grub but then gets stuck on the screen after that shows the BIOS logo. No command line available to see what is going on, just freezes, any thoughts?