[Stable Update] 2021-07-13 - Kernels, Plasma 5.22, Cinnamon 5, Gnome 40, LibreOffice, Mesa, Nvidia, Pamac

sudo pacman -Rdd libhandy1 && sudo pacman -Syu libhandy

FYI, libhandy1 was an AUR package before the extra repo package updated.

3 Likes

Brilliant. I had install libfprint attempting to get my dell fingerprint reader working. Not supported, but removed libfprintd and libfprint-tod-git… and Boom! Fixed. I think you should get the “solution” for this!

thank you so much, i think the nodeps is exactly what i was looking for. I’ve been leaning on pamac for too long I guess

Thx!
Removing the rtl8761b-fw firmware did the trick.

1 Like

Removed fprintd stuff I had installed playing with the fingerprint reader. Removed it and all good.
thanks @rolandd

Bug, probably not related with this update specifically, but it did not resolved it anyway:
On my system I got these udev rules (/etc/udev/rules.d/90-mhwd-prime-powermanagement.rules):

    # Remove NVIDIA USB xHCI Host Controller devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1"

    # Remove NVIDIA USB Type-C UCSI devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1"

    # Remove NVIDIA Audio devices, if present
    ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"

    # Enable runtime PM for NVIDIA VGA/3D controller devices on driver bind
    ACTION=="bind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030000", TEST=="power/control", ATTR{power/control}="auto"
    ACTION=="bind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030200", TEST=="power/control", ATTR{power/control}="auto"

    # Disable runtime PM for NVIDIA VGA/3D controller devices on driver unbind
    ACTION=="unbind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030000", TEST=="power/control", ATTR{power/control}="on"
    ACTION=="unbind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030200", TEST=="power/control", ATTR{power/control}="on"

(I couldn’t find out from which package it came from, so I suppose that the installer put it there when I installed Manjaro)

It was there becase of few bugs (Chapter 22. PCI-Express Runtime D3 (RTD3) Power Management) that needed to disable some features of the card for power management reasons. The point is that, now, the first three rules can be removed if you have installed the last driver version and run a kernel version >= 5.5 (and it’s important to do that because, otherwise, fundamental features like audio over hdmi will NOT work)

1 Like

Hi people!
First of all. Congratulations! :partying_face: :birthday:
Another dash-to-dock’s user here waiting for support. Meanwhile using dash-to-panel on the top which is also quite beautiful but I would rather the manjaro legacy layout.

Same problem here!

This update bumped nvidia driver from 465xx to 470xx and, well, my Guild Wars 2 under Lutris freezes the game window and then whole system to the point I need to kill X server. To my knowledge there’s no way to downgrade to the previous version of driver in an easy way.

Update crashed OS, it gets past grub but then gets stuck on the screen after that shows the BIOS logo. No command line available to see what is going on, just freezes, any thoughts?

I don’t know how Lutris or the game itself renders its stuff so maybe/probably/likely related to

I just have to say it!

You guys are legends!!!

A 2.3 GB update on two PCs and no problem whatsoever,
Thank you once again Manjaro Team!

Don’t know why, but I am impressed by small things in UI I already managed to notice - KDE settings launch screen is much more useful now and Pamac has this side panel which I love! And… it is not just the the former drop down menus from before – at least it seems so.

Thank you once again for giving me a happy experience using a rolling distribution.

I get this weird shadow on the edge of my panel on the right side of the screen. Is this intended? I wonder if there’s a way to disable it as I don’t find it nice-looking. If I try to put the panel at the bottom of the screen instead there is no shadow.

Wow, I love this too! Was never a fan of the drop down menu. So this side panel is enabled on my system too.

More changes I noticed: I don’t remember if the version numbering was visible in the list of programs there, but now it pops out very clear. Also the file size is displayed. In the settings popup window of Pamac, the AUR, Flatpak and Snap are listed in a single tab now, which makes more sense to group them.

I also noticed: Pamac is really the best graphical software manager!

Btw. One cherry on top moment was that now there is a tab for dependencies in the package/program description page.

:: Starting full system upgrade…
:: Replace pamac-common with extra/libpamac? [Y/n]
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: installing pacman (6.0.0-1) breaks dependency ‘pacman<5.3’ required by package-query

SOLVED: Remove package-query then attempt reinstall update.

1 Like

Happy birthday Manjaro! I’m really enjoying this Linux distro and I would like to thank each and everyone of the people who spent their time providing this amazing tool for everyone of us!

I’m a Gnome Manjaro user, albeit not a very experienced one. I think my update went smoothly but I have something bothering me. When I rebooted my system I was presented with an overly dark theme. I guess that this new update comes with Gnome 40. I try to change themes with Teaks but they are or very light or very dark. Does anyone has any insights on this?

I had (well still have) the same problem, fortunately I was able to switch to terminal (alt +f2, or alt+ctrl+f2, sorry I am not sure) and use timeshift to restore system. If you have timeshift all you have to do is run is as root with option restore, chose appropriate backup and then confirm default options.
This doesn’t solve the problem with the update, I think the issue is with nvidia drivers.

try pamac upgrade