[Stable Update] 2021-06-14 - Kernels, Browsers, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire, Haskell

After this update, I get the following error on every reboot/shutdown:

[FAILED]: Failed unmounting Temporary Directory (/tmp).

The system shuts down regularly, though.

After a quick check at the journal, this is what I get:

19:35:07 systemd[1]: systemd-tmpfiles-setup.service: Deactivated successfully.
19:35:07 systemd[1]: Stopped Create Volatile Files and Directories.
19:35:07 systemd[1]: Stopped target Local File Systems.
19:35:07 systemd[1]: Unmounting /boot/efi...
19:35:07 systemd[1]: Unmounting /home...
19:35:07 systemd[1]: Unmounting Temporary Directory (/tmp)...
19:35:07 umount[2597]: umount: /tmp: target is busy.
19:35:07 systemd[1]: boot-efi.mount: Deactivated successfully.
19:35:07 systemd[1]: Unmounted /boot/efi.
19:35:07 systemd[1]: tmp.mount: Mount process exited, code=exited, status=32/n/a
19:35:07 systemd[1]: Failed unmounting Temporary Directory (/tmp).
19:35:07 kernel: fbcon: Taking over console
19:35:07 kernel: Console: switching to colour frame buffer device 240x67
19:35:07 systemd[1]: Stopped target Swap.
19:35:07 systemd[1]: Deactivating swap /dev/disk/by-id/nvme-Samsung_SSD_980_PRO_1TB_S5GXNF0NC35518H-part1...
19:35:07 systemd[1]: systemd-fsck@dev-disk-by\x2duuid-1D53\x2dE902.service: Deactivated successfully.
19:35:07 systemd[1]: Stopped File System Check on /dev/disk/by-uuid/1D53-E902.
19:35:07 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-fsck@dev-disk-by\x2duuid-1D53\x2dE902 comm="system>
19:35:07 audit: BPF prog-id=9 op=UNLOAD
19:35:07 systemd[1]: dev-disk-by\x2dpath-pci\x2d0000:03:00.0\x2dnvme\x2d1\x2dpart1.swap: Deactivated successfully.
19:35:07 systemd[1]: Deactivated swap /dev/disk/by-path/pci-0000:03:00.0-nvme-1-part1.
19:35:07 systemd[1]: dev-disk-by\x2did-nvme\x2dSamsung_SSD_980_PRO_1TB_S5GXNF0NC35518H-part1.
19:35:07 systemd[1]: dev-disk-by\x2did-nvme\x2deui.002538bc01b0a830\x2dpart1.swap: Deactivated successfully.
19:35:07 systemd[1]: Deactivated swap /dev/disk/by-id/nvme-eui.002538bc01b0a830-part1.
19:35:07 systemd[1]: dev-disk-by\x2dpartuuid-5f3f1a03\x2d5c75\x2d2448\x2d9e80\x2df1b018656d04.swap: Deactivated successfully.
19:35:07 systemd[1]: Deactivated swap /dev/disk/by-partuuid/5f3f1a03-5c75-2448-9e80-f1b018656d04.
19:35:07 systemd[1]: dev-nvme0n1p1.swap: Deactivated successfully.
19:35:07 systemd[1]: Deactivated swap /dev/nvme0n1p1.
19:35:07 systemd[1]: dev-disk-by\x2duuid-a8990893\x2d435c\x2d4b5c\x2db57e\x2d0b0dc56f5649.swap: Deactivated successfully.
19:35:07 systemd[1]: Deactivated swap /dev/disk/by-uuid/a8990893-435c-4b5c-b57e-0b0dc56f5649.
19:35:08 systemd[1]: home.mount: Deactivated successfully.
19:35:08 audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-fsck@dev-disk-by\x2duuid-c1917749\x2d2a19\x2d4c7b\>
19:35:08 systemd[1]: Unmounted /home.
19:35:08 systemd[1]: Reached target Unmount All Filesystems.
19:35:08 systemd[1]: systemd-fsck@dev-disk-by\x2duuid-c1917749\x2d2a19\x2d4c7b\x2d9b5c\x2d6c7a7157a736.service: Deactivated successfully.
19:35:08 systemd[1]: Stopped File System Check on /dev/disk/by-uuid/c1917749-2a19-4c7b-9b5c-6c7a7157a736.
19:35:08 systemd[1]: Removed slice system-systemd\x2dfsck.slice.
19:35:08 systemd[1]: Stopped target Local File Systems (Pre).
19:35:08 systemd[1]: Stopping Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling...
19:35:08 systemd[1]: systemd-tmpfiles-setup-dev.service: Deactivated successfully.

A couple of things that sound strange to me: i) systemd reports “Reached target Unmount All Filesystems” even if unmounting /tmp has failed; ii) the service systemd-tmpfiles-setup-dev.service is deactivated after attempting to unmount /tmp.

Anyone else encountering this issue? Is this something I can safely ignore?

As always, thanks to the Manjaro Team for the great work, and to the Forum for the support. :love_you_gesture:

The last update damage my system badly. I’m posting my solution if someone has similar problems:

During the update process all packages after systemd-sysvcompat were not installed correctly. /var/log/pacman.log looks like this:

[2021-06-14T19:58:19+0200] [ALPM] upgraded systemd-sysvcompat (247.7-1 -> 248.3-2)
[2021-06-14^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^      @^@^@^@^@^@^@^@^@^@^@^@^@^@

I had to use pacman -Qkk to find the damaged packages, clear the dependencies and reinstall the package manually. It took some time but the system is back, stable and with all packages working properly.

I don’t know whats happened there exactly. Maybe someone can enlighten me. THX.

Great question. If I remember correctly, Manjaro LXDE and LXQt always were community editions. I suspect that enthusiasm fizzled in one way or another.

not an enlightenment but it seems this issue is fixed:
19:26 upgraded systemd-sysvcompat (247.7-1 → 248.3-3)
19:29 finished without any issues(really!!!, and no gnome issues, too).
(upgraded Ornara 21.0.5 → 21.0.7, gnome, kernel 5.4, nvidia 460.80-1 → 465.31-1)

your system applied this
19:58 systemd-sysvcompat (247.7-1 → 248.3-2)
20:22 wow, it took 24 minutes to damage parts of your system.

I install manjaro on external USB SSD, it working find. But last week I upgrade the system from 21.0.6 to 21.0.7, then reboot, system boot failed:

mount: /new_root: no filesystem type specified.
You are now being dropped into an emergency shell
sh: can't access tty; job control turned off
[rootfs ]#

In emergency shell, the USB SSD not found:

[rootfs ]# lsblk
NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINTS
sdb                                             8:16   1  28.6G  0 disk  
├─sdb1                                          8:17   1   2.9G  0 part  
└─sdb2                                          8:18   1     4M  0 part 

from bootable USB iso, the USB SSD found:

# lsblk
NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINTS
sda                                             8:0    0 931.5G  0 disk   
├─sda1                                          8:1    0   200M  0 part  /boot/efi
├─sda2                                          8:2    0 464.9G  0 part   
└─sda3                                          8:3    0 466.3G  0 part   
 └─luks-bufara                               254:0    0 466.3G  0 crypt /
sdb                                             8:16   1  28.6G  0 disk  
├─sdb1                                          8:17   1   2.9G  0 part  
└─sdb2                                          8:18   1     4M  0 part  

I tried many methods to resolve it, changing the parameters in /etc/default/grub, /etc/mkinitcpio.conf, using grub-install to reinstall grub, etc., but nothing worked.

I decided to downgrade the kernel back to 5.10.41-1 and rebooted the system, wow! It worked, the system booted successfully.

I compared the dmesg logs of 5.10.41-1 and 5.10.42-1, found that:
5.10.41-1 contain the log of detect the USB SSD, like below:

# dmesg
[    1.488559] usb 4-1: new SuperSpeedPlus Gen 2 USB device number 2 using xhci_hcd
[    1.516106] usb 4-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[    1.516108] usb 4-1: Product: Portable SSD T5
[    1.516109] usb 4-1: Manufacturer: Samsung
[    1.521592] usbcore: registered new interface driver usb-storage
[    1.526816] scsi host1: uas
[    1.526848] usbcore: registered new interface driver uas
[    1.527449] scsi 1:0:0:0: Direct-Access     Samsung  Portable SSD T5  0    PQ: 0 ANSI: 6
[    1.529242] sd 1:0:0:0: [sda] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)
[    1.529316] sd 1:0:0:0: [sda] Write Protect is off
[    1.529317] sd 1:0:0:0: [sda] Mode Sense: 43 00 00 00
[    1.529480] sd 1:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    1.529676] sd 1:0:0:0: [sda] Optimal transfer size 33553920 bytes
[    1.588304]  sda: sda1 sda2 sda3

but 5.10.42-1 have not.

So I think that is the reason cause the problem.

I don’t know if 5.12 and 5.4 have the same problem. To confirm this, I decided to test it. I will feedback the rest result.

I tested the kernel 5.4, the version 5.4.124-1 has the same problem, and after downgrade to 5.4.123-1, the problem gone.

For kernel 5.12, I just can confirm that 5.12.9-1 have the same problem, but I can’t downgrade to previous version to test cause I haven’t installed previous version of 5.12.

Also I don’t known whether other kernel version have the same problem.

1 Like

Update at 21.0.7 gone without problem: thanks Manjaro’s Team :clap: :clap:

So apparently downgrade now completely ignores DOWNGRADE_FROM_ALA

Can we stop with the hand-holding, please? @nightmare-2021

$ sudo downgrade downgrade ← chew on that irony

@LA-MJ My workflow, was here (before I used BTRFS): switch branch to testing > downgrade xyz pkg > switch back to stable

but back to your question

$ sudo pacman -Ss downgrade
community/downgrade 10.0.0-1 [Installiert]
    Bash script for downgrading one or more packages to a version in your cache
    or the A.L.A.

Patch for Stable was updated for latest version of downgrade

diff -rupN a/downgrade b/downgrade
--- a/downgrade	2017-08-26 17:30:08.000000000 +0200
+++ b/downgrade	2018-10-14 22:01:09.884286776 +0200
@@ -460,7 +460,16 @@ PACMAN="pacman"
+# Disable A.L.A. only in stable branch 
+if [ ! "$(pacman-mirrors -aG)" == stable ] ; then 
+  echo 
+  echo "Downgrading from A.L.A. is disabled on the stable branch. To override this behavior, set DOWNGRADE_FROM_ALA to 1 ."
+  echo "See https://archived-wiki.manjaro.org/index.php?title=Using_Downgrade  for more details."
+  echo

Test result:

$ sudo downgrade <PACKAGE>
Downgrading from A.L.A. is disabled on the stable branch. To override this behavior, set DOWNGRADE_FROM_ALA to 1 .
See https://archived-wiki.manjaro.org/index.php?title=Using_Downgrade  for more details.

Unable to downgrade <PACKAGE>

that was my point, the patch is either buggy or outrageous

@LA-MJ can you post your output if you do:

sudo downgrade <PACKAGE>


A post was split to a new topic: A problem with file search in Dolphin

So everything worked for me, but the previous 2 weeks of awesome performance by dropping Firefox and moving to Firefox ESR, is now ruined. Even typing this is lagging. Scrolling reddit, FB etc, lagging. PC is practically unusable in Firefox now :confused:
Guessing it’s an Nvidia issue?

Here is a bit of random idea. Run nvidia-settings once and close it without changing anything. On my system with specific settings, it lags horribly, until I just open and close nvidia-settings. I even have it in my startup when booting into the system.

I have absolutely no idea why this is and what is happening there. And it could be very well that it does not help, but give it a shot.

I sometimes get a black screen when cold booting. Only cold booting.

Thinking of downgrading and locking the nvidia driver for the foreseeable future, since nvidia seems to be too incompetent to get their sh*t together. I already ignore it on Windows 10 too.

Regarding my missing microphone:

There have been several other topics about this issue in the last days.
The problem is fixed in the next testing update.I switched to testing and my mic came back.
If you don’t want to use testing, wait for the next stable update or try to find out which update caused the problem and downgrade the responsible package.

What’s still not working properly is suspend and resume on any kernel >5.10 (or >5.11.6).

For anyone looking for a fix for missing microphones after latest stable update, but unwilling to switch to testing branch, look here:

Note that in case you still have the “original” Manjaro packages in your pacman cache, using them might be a better option.

With a ThinkPad T14 Gen1 AMD: Internal microphone was not recognized anymore. Switched to testing branch, where it works as expected.

2 posts were split to a new topic: Sublime-text key is unknown

Is there a difference between Manjaro packages and Archlinux ones? Afaik for the same given version of a package there shouldn’t be a difference? (Might be wrong here).