[Stable Update] 2021-06-14 - Kernels, Browsers, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire, Haskell

Actually, the case shows that one who know less must use pacman instead of pamac. Pamac automatized the process and honestly now I don’t know what it did and it would be hard to fix for me when things gone bad. Pacman provides me to do only what I know and understand, otherwise I won’t touch anything to remain safe.
In the case, I tried pacman, my knowledge was not enough to solve the problem, so I came to forum to understand what is wrong. In another scenario, the automatic procedure may cause a mess which I cannot solve, even define.

1 Like

Another excellent stable update. Thank you, everyone. No issues in LXQt on a Ryzen CPU and AMD GPU with the various graphics driver updates, Linux updates, and all the rest.

Question: At what point in the development cycle is it normal for Manjaro’s build of Linux to contain the usual patches, e.g. Fsync? 5.13-rc4 and now -rc5 lack such creature comforts and are (predictably) more ‘raw’ than the 5.12 stable Linux series.

Hi, I just got an update notification for systemd 248.3-3 from 248.3-2. Is this a part of this update?
Edit: A few days ago, I got the update for 247 → 248

Anyone know why the LXQT community edition was removed from the downloads ?
At last LXQT 0.17 solved the multiple sudo admins policykit issue and yet the edition is gone.

I was curious and I tested all LTS kernels on my old DELL E6500 after the systemd fixes with Plasma.

5.10 OK
5.4 OK
4.19 OK

4.14 crash and kernel panic, no x

4.9 mouse cursor on blank screen , crash, kernel panic after slow load of Plasma

4.4 “proc: unrcognized mount option hidepid=invisible or missing value”
mouse cursor on blank screen , no SDDM screen

Noticed this error : “cgroup: cgroup2: unknown option “nsdelegate, memory_recursiveprot””
Power management could not be started.

Not only did the update go without a hitch, but it also fixed my Bluetooth earphone dropouts problem! Thanks Manjaro team!

Ref: Dropouts with bluetooth earphones

I’m still struggeling with this change from pulseaudio to pipewire. pulseffects does not work, pulseeffects sink has no function ans so forth. i could get audio to run but it fails periodically. i read dozens of wiki, threads here, searching the internet but i could not find any tutorial or troubleshooting that gave a solution. it’s chaotic

My first manjaro kde update with my new [Clevo NL51LU 15.6-inch Metal Design] from laptopwithlinux.

Update works fine without any issue.

Thank you

Anybody else have a problem with DNS over HTTPS on Firefox?

I actually first noticed this after stable update 2021-06-06 although could have been introduced earlier…

Firefox DoH is not working since at least version 89

I was getting this issue using ‘pacman -Syu’:

Used ‘pamac update’ as recommended and updated successfully.

I am using an installation that I started with the last official Manjaro LXQt stable branch .iso from earlier this year (Downloading File /lxqt/20.2.1 - Manjaro ISO Archive - OSDN). That .iso is growing stale and might not update smoothly any more, but you do have a few options. (1) @Jim.B generously takes the time to design and build nice, up-to-date LXQt stable .isos that include (2) (unlike current official releases) the most up-to-date version of the Manjaro Architect, thereby offering either a sensible LXQt preset installation via Calamares or limitless installation customization via the Architect: SbK Lxqt 21.0.5 Further (3), it looks like LXQt is making a comeback, as we do have some unstable branch .isos available in OSDN: Downloading File /lxqt/21.0.3 - Manjaro ISO Archive - OSDN I think that you should be able to switch to the stable or testing branch after installation.

1 Like

Right now I got 3 kernels installed, I have timeshift creating daily backups, and lastly if I’m going to update I also do full disk backup(system disk) using clonezilla. But so far since my last clean installed, I didnt’ got a chance to use to restore those backups. :smiley:

1 Like

You can check if service is available

resolvectl status

if not, enable it

systemctl enable --now systemd-resolved

I had a small problem, the login process took around 20s after the update. I used
systemd-analyze blame and it looked like user@1000 took about 25s. Then I checked the process with systemctl status user@1000 and there was this line:

pulseaudio[1161]: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)

That means this is a bluetooth issue. I don’t need bluetooth therefore I disabled it and that solved it for me.

Hope they are fixed now: [xfce] update shasums (97b1f65e) · Commits · WEB / manjaro.org · GitLab

1 Like

Why have you downgraded python-wxpython from 4.1.1-1 to 1: version in last update off June 14?

updated using pamac as recommended, no issues booting. However, it appears that the software i use to set my wallpaper (nitrogen) is broken after the update. Not the end of the world, as I can just use feh to accomplish the same task.

Thanks, I also installed from manjaro-lxqt-20.0-200423-linux56.iso downloaded earlier this year , just wondered why it’s no longer maintained and offered .

Because FS#70908

Open nitrogen in the terminal to see what are the errors.