[Stable Update] 2021-06-14 - Kernels, Browsers, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire, Haskell

See here: [kde] update checksums (fbea59f9) · Commits · WEB / manjaro.org · GitLab

Interesting update. Besides the canberra issue which was easily resolved with
pamac upgrade
everything else works flawlessly. I’m using KDE with kernel 5.10 on a laptop with a NVIDIA 960M card. No issues with the NVIDIA driver also.

Thank you manjaro team for an excellent distro, and all your hard work.

I have Manjaro as a virtualbox guest on a windows host.

I just did an update for the last 3 stable updates.
Now, I cannot see my shared folders on the host.

Can someone help solve the problem?

Following the messages from the boot:

systemctl status systemd-modules-load.service
 systemd-modules-load.service - Load Kernel Modules
     Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static)
     Active: failed (Result: exit-code) since Wed 2021-06-16 11:32:02 IDT; 53s ago
       Docs: man:systemd-modules-load.service(8)
    Process: 409 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
   Main PID: 409 (code=exited, status=1/FAILURE)
        CPU: 4ms

Jun 16 11:32:02 leafHost systemd[1]: Starting Load Kernel Modules...
Jun 16 11:32:02 leafHost systemd-modules-load[409]: Failed to insert module 'vboxsf': Exec format error
Jun 16 11:32:02 leafHost systemd-modules-load[409]: Failed to insert module 'vboxsf': Exec format error
Jun 16 11:32:02 leafHost systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
Jun 16 11:32:02 leafHost systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
Jun 16 11:32:02 leafHost systemd[1]: Failed to start Load Kernel Modules.

Hi all!

I have 1 minor issue after the update: not able to switch to laptop speakers/microphone when headphones are plugged in. Everything switches fine once the headphones are unplugged.

And finally, my monitor speakers were picked up by the system after this update, and I’m now able to play sound through HDMI - awesome :ok_hand:

I’m running manjaro KDE on an amd laptop with hybrid graphics cards (Nvidia).

I suspect the latest snapshot must have introduced a major issue that’s causing boot to freeze when some hard drives are listed in fstab. I explained the problem in detail here:

It started happening after a systemd update. However I run the kernel 5.x series, with both 5.11 and 5.12 doing it… the issue described above is said to be related to 4.19 alone. Could there be more to that problem than is known? Will wait for that patch to be reverted then try again in next stable.

The Xfce ones are still wrong.

I’m looking at this: [xfce/kde] update shasums (9a1fedf0) · Commits · WEB / manjaro.org · GitLab

Between this update and the recent small one to systemd, my microphone went MIA.
It’s not showing up in the volume applet anymore and no applications seem to be able to access it.

(Lenovo ideapad 5 14 ARE05 with Ryzen4600U)

After some checks:

This problem occurred with kernel 5.4
I just tried kernel 5.10 and problem just gone.

Seems like linux54-virtualbox-guest-modules does not work for kernel 5.4 but does work for 5.10

Well another update from the stable branch failed for me. Just like every single other update in the last year (serious).

I tried updating with Sudo pacman --Syyu then with sudo pamac upgrade and then from the GUI Pamac.

Checking integrity...                                                                      [302/302]
Error: adobe-source-han-sans-cn-fonts: signature from "Felix Yan <felixonmars@archlinux.org>" is unknown trust
Error: adobe-source-han-sans-jp-fonts: signature from "Felix Yan <felixonmars@archlinux.org>" is unknown trust
Error: adobe-source-han-sans-kr-fonts: signature from "Felix Yan <felixonmars@archlinux.org>" is unknown trust
Error: linux-api-headers: signature from "Giancarlo Razzolini (grazzolini) <grazzolini@archlinux.org>" is unknown trust
Error: glibc: signature from "Giancarlo Razzolini (grazzolini) <grazzolini@archlinux.org>" is unknown trust

… list goes on

Error: Failed to commit transaction: invalid or corrupted package (PGP signature):

Any idea what is going on and how to fix it? Or do I need to do fresh reinstall again?

Thanks for any suggestions.

guest and host are 2 different things: the former is used inside a virtualbox vm ( the guest), the latter on the machine running virtualbox and the vm on it (the host).

@Monro : There is no linux54-virtualbox-guest-modules package and linux54 itself does not provide VIRTUALBOX-GUEST-MODULES as opposed to linux510 (which does):

$ pacman -Si linux54
Provides        : linux=5.4.125
$ pacman -Si linux510
1 Like

since 8 days virtualbox guest are ONLY in linux510 package and more, but if we have less nothing ?

  • From this post:

you could try these commands:

sudo pacman -Sy archlinux-keyring manjaro-keyring
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
sudo pacman -Syu

Refreshing keys would solve your first issue too.

Thank you. I will try these and post an update.

No it’s not.

The guest modules are part of the normal kernel package.

The host-modules are only needed for machines that host / run guest machines (as the name already suggests).

linux54 does not have the vboxsf module. It’s only available from version 5.6 onwards:


You can still install the missing module from the VirtualBoxGuestAdditions CD image.
Note that you need package dkms to so that the additions can build the modules…

I haven’t seen it, sorry for the inconvenience, my :brain: needs to be water cooled :hot_face:

I deleted the post to not cause further confusion

Please see the installed components in the screenshot.

Anyway, I did have shared folders before the update and did not, after.
I don’t know what happened, but its for the devs to investigate.

Your installed package must be an old package no longer present in the repositories:

I was on the same boat as you. My dmesg also complained about vboxsf, but sharing still worked just fine.

I had those guest modules installed too and I removed them because of what’s already been said (they’re for the guest, not the host). I don’t know about pamac but in octopi they show up listed as being from the AUR.

Errors disappeared, and through it all sharing never stopped working, whatever little sense that makes.

Yepp, it was removed in May and got removed form stable with the previous update 2021-06-07:


1 Like

THANK YOU, @gan ! Running those commands fixed the issue and I was able to update the system. Rebooted and everything works.