[Stable Update] 2021-04-18 - Kernels, Mesa, Wine, Plasma5, KDE Frameworks, LibreOffice, Bluez

this question is for the developers, I do not know this

Found the problem, for me it was AMDVLK 2021.Q2.1 that was broken. When uninstalled everything is working with RADV. Now it is Wine 6.6 that mess up with controler in game, can’t use the mouse or gamepad, but it seems to be a known issue.

1 Like

Same problem here :

I’m experiencing the same issue. Where the activities view gets stuck and you can’t get out of it. I can close down apps and even launch new ones, log out etc. but you can’t interact with any application because it is stuck in Activities view. Not exactly sure what the entire “trigger” is because it doesn’t do it 100% of the time which I’m sure is how it made it’s way to stable.

I found this link where others where experiencing the same issue:

There are also several reporting freezing. It’s kind of to be expected as gnome 40 is a major change in the gnome workflow so it’s not surprising it has broken lots of extensions. That’s just the way it goes sometimes. Only thing to do is isolate the extension and then work with the extension’s author/contributors to hopefully get them working soon.

I did find that I could switch to a different TTY (Ctrl-Alt-F3) and then type the following to disable the extensions to at least allow me to get back into my system without having to restart after activities hijacks the system.

gsettings set org.gnome.shell disable-user-extensions true

Then you can either re-enable them either through the extensions app or using the following command:

gsettings set org.gnome.shell disable-user-extensions false

After log in I had a black screen, nothing could be done.

Now everything works, thank you :slight_smile:

Simply disable all extensions and use as Gnome it is designed for. Only supported extensions are those included in gnome-extensions, which are maintained by upstream directly. Since our Gnome edition holds some not yet compatible extensions, we have to hold back our shell update. However 40 shell can already been tested in our unstable branch …

2 Likes

Because I do not use Timeshift or similar because ATM I lack enough disk space for such backup strategy.

Buying and installing new disk(s) for it, means reinstalling the OS and migrating the data, which will likely cost more effort and time (which I do not have ATM) than just waiting till regressions are fixed and upgrading later.

Also I discovered another regression in the previous update:

  • Windows apps on wine do not start at all, had to downgrade to wine 5.4
  • Magic Lamp of Desktop Effects / Compiz does not work as in somehow it does the fold effect.

I run Manjaro Cinnamon in virtualbox since a longer time but with the latest update cycle, 3D acceleration does not work anymore. Booting into desktop, the entire screen is white. Once I uncheck the 3D acceleration checkbox in virtualbox settings of the my VM, the desktop is fine again but I get a popup saying that running in software rendering mode which could cause higher CPU load.
The same issues happens when I boot the latest Manjaro Cinnamon Live CD ISO but the XFCE Live ISO is fine though.
Hence, some Cinnamon specific updates brake the DE in virtualbox.
I already tried many different settings in virtualbox manager but without success.

Virtualbox version 6.1.20 with extension pack 6.1.20

I use that too, but on unstable branch disable 3D acceleration as workaround

I know, but disabling 3D acceleration does not fix the issue - it’s just a workaround.
The issue still persists because it was working before and even the Live CD ISO does not work.

Hey ZarcX thank you very much! this fixed steam and lutris completely for me.
is there any dev that could explain this ? why does unintalling AMDVLK help?

I am running Kernel 5.12 rc7 and a RX 580

thank you very much for your answer, but i tried that and it didn´t work for me.
I followed ZarcXs advise to unistall AMDVLK. that fixed everything for me-steam games launch again

1 Like

Glad it helped! :grinning:

… or just use a DE that does not require extensions to be fully functional, Manjaro has some of them in store :wink: … this would be a more sustainable solution. Either use GNOME vanilla, or use something else.

2 Likes

networkmanager-openvpn was updated from 1.8.12 to 1.8.14. Now VPN connections fail with the following errors:

кві 22 21:59:24 verba nm-openvpn[50064]: Options error: --cert fails with '': No such file or directory (errno=2)
кві 22 21:59:24 verba nm-openvpn[50064]: WARNING: cannot stat file '': No such file or directory (errno=2)
кві 22 21:59:24 verba nm-openvpn[50064]: Options error: --key fails with '': No such file or directory (errno=2)
кві 22 21:59:24 verba nm-openvpn[50064]: Options error: Please correct these errors.

Those two properties are indeed empty in the configuration file, i.e.

cert=
key=

However, I did not need them previously. I tried removing these properties directly from the configuration file but that did not help. As a temporary solution, I had to downgrade to 1.8.12 to make VPN work.

I do not know much about openvpn. Perhaps the user certificate and key are now required?

Yeah it is working like charm but the latest gdm 40 has a weird bug.
The manjaro-gdm-theme has black cutouts on top left and top right in the GNOME lock screen.

1 Like

Hey @thepete, this might be a temporary workaround to that problem: Square borders on dock Gnome 40 - #4 by Syzygianinfern0

Using other themes didn’t work for me and I prefer the vanilla look 'n feel

Try changing the theme, I do not use Matcha Theme personally, I saw this here:(Square borders on dock Gnome 40 - #4 by Syzygianinfern0)

Are you saying that updating to kernel 5.11 fixed this problem?

If GRUB is going into recovery mode, how are you booting into your OS?

Hi,
Two minor problems on linux510 I have experienced after the upgrade.
The well know one that wine not running exe files on Wine, which could be solved by downgrading the package.
The other is that xfreerdp does not work well as in linux54, I could not be able to connect a remote server and I experienced that the machine freezes and I had to shutdown with the power button.
BTW Manjaro is a beautiful kind of beast.
Regards