[Stable Update] 2021-04-28 - Kernels, Wine, Ruby, JDK, KDE-Dev, Mesa 21.0.3, KDE Apps 21.04, Python, Haskell, Mate 1.24.2, Virtualbox, Thunderbird

Can you please post the link of the issue at the VBox Forum as well?

Error updating packages, rubY files exist

Dont know how to scroll up in tty, im using tty because x server wont start so i tried updating

This error is general … more information about the problem is on next lines.

Often it can be mix of Virtual Box and Extension Pack versions … but it’s just a blind hint :eyeglasses:

It might be a slippery slope. Don’t know if you use KDE or gnome, but when I started getting error messages like that, removing db.lck, running pacman-mirrors or turning to pamac for updates inside GUI, things went horribly wrong along the way and my system eventually crushed. See the solution post here for the close-to-fool-proof way to go about updating. Pacman and TTY are your friends!


got issues, mainly with firefox and akonadi. Both crash on launch. Call from a terminal for firefox log a bus error, with core dumped. Coredumpctl show same errors for Firefox, Akonadi, Whatsapp-linux, and Midori, with a signal, and always the same stacktrace (for lines 0 to 5) from coredumpctl info :

Stack trace of thread 8194:
#0 0x00007f4aea656153 memset (ld-linux-x86-64.so.2 + 0x24153)
#1 0x00007f4aea63a40a _dl_map_object_from_fd (ld-linux-x86-64.so.2 + 0x840a)
#2 0x00007f4aea63b82d _dl_map_object (ld-linux-x86-64.so.2 + 0x982d)
#3 0x00007f4aea645f6c dl_open_worker (ld-linux-x86-64.so.2 + 0x13f6c)
#4 0x00007f4aea20db38 _dl_catch_exception (libc.so.6 + 0x139b38)
#5 0x00007f4aea645ade _dl_open (ld-linux-x86-64.so.2 + 0x13ade)
#6 0x00007f4aea5df34c n/a (libdl.so.2 + 0x234c)
lines 1-26

It’s far away from my competence to debug this kind of errors…

I have the same issue after EVERY major Manjaro update. (never happens during normal reboot)

It tries to mount and unmount disks in circles. The system never reboots after update – I am forced to turn it off physically.

LOG is here.

system info:
RAZER Blade 15 (2018)
dual boot with Win 10
GNOME 40.0.0

It worked for me with a very similar problem a couple weeks ago.

1 Like

Thank you for the warning, I always used pacman and tty, but if it does not work, there is not much else I could do. Unfortunately, I did not check if db.lck was there before using pamac, but I think it would have blocked pamac as well, so the problem lay somewhere else.

And if pamac is so bad, I don’t understand why it is still bundled with Manjaro, also since it lost half of its AUR functionality since version 10.

I just hope that the next Manjaro upgrade will fix the audio/video issues.

1 Like

Pamac is not that bad because it was able to deal with the remain lock after your reboot and perform the upgrade. A thing that pacman was not able to do.

1 Like

I had a very very small issue. Same as last time, after pamac download all packages it freezes there. Then I hit cancel, close pamac, re do upgrade and everything went smooth (of course the packages were not downloaded again).

Out of curiosity, how long did you wait for pamac, before deciding it was frozen?

I ask because I’ve made the same assumption in the past, when it sometimes just takes a minute or two after downloading all packages to continue with upgrades – I think that it’s decompressing the packages when this happens (a visual indication of this would be helpful, but it’s a minor nitpick).

Still, glad you were able to successfully update. :slight_smile:

@Anthony I’ve had much more success with pamac (in run-level 3) than pacman, personally, or at least I’ve borked my system a lot less often. LoL

I see this behavior to on older machines that take a little longer to do the integrity check, it looks like hanging, that is not the case, pamac is verifying the downloaded packages, there is no visual indication and can take a while.

Have some patience, check cpu/io usage to see if there is activity, it depends on the speed of your machine.

I am also experiencing a simular issue with VirtualBox 6.1.20 (Guest Additions 6.1.20).
On my linux host with windows guest I have distorted audio on my linux host after a couple of minutes running the guest.
Can you link to the forum or bug report on the VirtualBox site?

Edit: for now I seem to have fixed it by disabling audio in the windows vm guest settings. (I dont require audio from the VM but this is ofc not a solution for everyone)

1 Like

I also have an issue installing the update. No matter how I try it I always end up getting

  • unable to satisfy dependency ‘vte3>=0.64.0’ required by gnome-terminal

doesnt seem like anyone else has a similar problem so I might just be me not getting it also =)

SOLVED: just created new vm and used old disk, nothing else helped

2 posts were split to a new topic: OBS Studio: Failed to start recording

I seem to be having an intermittent problem here, sometimes it occurs and other times it does not. I am running gnome desktop on my laptop. When i press the super key, the currently active activities all show up, but then when i click on one nothing happens, it does not let me exit the activities view or change my current desktop on the RHS. Can someone please help with this

I believe it is still an issue with dash to dock extension (or possibly another one but in my case I only run 4 extensions and dash to dock is the only one that modifies the desktop behavior). For me I ran the following commands and I haven’t been able to get it to cause the issue again. (As a side note so you don’t have to reboot your system if it does occur again you can switch to a different TTY (CTRL-ALT-F3) for example log in and run this command to get control of your desktop back.

Type the following to disable the extensions to at least allow me to get back into my system without having to restart after activities hijacks the system.

gsettings set org.gnome.shell disable-user-extensions true

Then you can either re-enable them either through the extensions app or using the following command:

gsettings set org.gnome.shell disable-user-extensions false

Here is a link to my original post about this as for me it occurred during the last update. I’m not sure what has changed on my system other than running the above commands on my system but I haven’t been able to get the activities to “hijack” my system anymore.

1 Like

I think one of the extensions is not supported and still active after updating the system. By disabling all user added extensions, the broken one won’t get reenabled.