[Stable Update] 2021-04-18 - Kernels, Mesa, Wine, Plasma5, KDE Frameworks, LibreOffice, Bluez

Some boards are recommending downgrading back to the older MESA versions.

I have seen this command listed to do it on one of the boards, but haven’t tried it. Maybe someone who understands PACMAN better than I do can comment on whether this works or is a good idea:

"Going back to
$ pacman -Q | grep mesa
mesa 20.3.4-3

solved the issue."

Well i do not know if it is this update especially but i have an annoying issue with Framerates in Browsers now.

Firefox and chromium now drop A LOT of frames during 1440p Video playback ( basically every second frame is dropped). It is way less on 720p but still some frames dropped.

Did the kernel built in AMD drivers change? I’m using right now an old crappy HD 5350 passiv cooled card as my VEGA 64 is actually used by my brother as right now prices for grafics cards are through the roof. I thought this old card should at least support browsing :(.

Hi @Algo,

I think for this issue you should start a new thread.

For that thread, provide the output of:

inxi --admin --verbosity=7 --filter --no-host --width

I suspect it’s a hardware limitation. Especially since you say it’s better at a lower resolution. And that might not make sense, unless you keep in mind that for a 1080p video your graphics card has to render that along with the rest of your desktop, so it’s not just the video, but your normal screen(s) and the video.

@Mirdarthos OK i’ll do that … but it worked just fine not long ago with the same hardware, but perhaps somebody has a hint or i have to live with it till graphics cards are affordable again.

Sadly, I think this is the way to go…yeah, it’s sad, I know.

Well i’m not really satisfied with that as it seemed to work just fine … perhaps i try to downgrade the Kernel e.g. use 5.9 or 5.10 instaed of 5.11

That is rather a wonderful idea, yes! Do that and check.

The same is happening on my laptop for Google Chrome

If you’re going to downgrade Kernel, I recommend you the 5.10 once it is an LTS one. At least you’ll receive bug fixes and some mostly peripheral hardware upgrades till late 2022, I believe.

Permit me to add another minor glitch and the solution for it. From this upgrade on, Firefox doesn’t automatically upgrade the language package. You can correct it by opening the preferences, going to language and appearance and downloading your language support from there. You’ll need to do it again for today’s Firefox 88 update.

After this update the system is unusable (in my case). Gnome randomly freezes or gets stuck in running apps view (I have no idea how it is called. The view after Super key press). I did a fresh install because I have seen it is a new release, but I am experiencing the same issues.
I’m running dual display setup. Manjaro is installed on ThinkPad E595 with Ryzen 7 3700u.
Kernel 5.10
I have no idea what info should I write here.

1 Like

The ‘Dash To panel’ extension has a bug, it doesn’t work very well with the touchscreen. The system freezes when two applications are executed one after the other via the taskbar (for example: Terminal and the text editor). With ‘Dash to Dock’ extension, it is perfect.

I thought my issue was with the updates from Gnome 40 apps, but it isn’t. Mea culpa. I have done all the latest updates (including Gnome 40 apps), and I have not encountered any problems (no system freezes) on my 2-in-1 laptop.

No new issues, but previous ones persist:

Trash icon/popup menu in XFCE 4.16.6 out of sync with its contents.

“Control features” of Bluetooth earphones (start/stop when they are touched or adjusted) lock out USB keyboard until earphones are shut off by putting them in their case.

The former has been fixed in XFCE 4.16.7, and manually deleting from Trash is the workaround. The latter is so specific, I don’t know where to look it up.

Thanks for the update!

For the ones asking: Firefox went from my previously chosen Portuguese language (Pt-pt) to the US English one. I had to manually chose the Portuguese language there again.

I had to downgrade spyder too, using:

sudo downgrade spyder
sudo downgrade python-spyder-kernels

(the first from 5.0.0 to 4.2.5 and the second from 2.0.1 to 1.10.2)

Otherwise, got the error message:

No QCoreApplication instance found. Application patches not applied. You have to call load_stylesheet function after instantiation of QApplication to take effect. 
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/spyder/app/mainwindow.py", line 2146, in create_window
  File "/usr/lib/python3.9/site-packages/spyder/app/mainwindow.py", line 810, in setup
    CONF.set('help', 'css_path', css_path)
UnboundLocalError: local variable 'css_path' referenced before assignment

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/spyder", line 33, in <module>
    sys.exit(load_entry_point('spyder==5.0.0', 'gui_scripts', 'spyder')())
  File "/usr/lib/python3.9/site-packages/spyder/app/start.py", line 213, in main
    mainwindow.main(options, args)
  File "/usr/lib/python3.9/site-packages/spyder/app/mainwindow.py", line 2293, in main
    mainwindow = create_window(app, splash, options, args)
  File "/usr/lib/python3.9/site-packages/spyder/app/mainwindow.py", line 2148, in create_window
    if main.console is not None:
  File "/usr/lib/python3.9/site-packages/spyder/app/mainwindow.py", line 1159, in __getattr__
    return self.get_plugin(self._INTERNAL_PLUGINS_MAPPING[attr])
  File "/usr/lib/python3.9/site-packages/spyder/app/mainwindow.py", line 168, in get_plugin
    raise SpyderAPIError('Plugin "{}" not found!'.format(plugin_name))
spyder.api.exceptions.SpyderAPIError: Plugin "internal_console" not found!
1 Like

Can’t effectively login after update to 21.0.2 on Gnome

After updating to Manjaro 21.0.2 Ornara on Gnome I could login but only to get a frozen screen with an unmovable mouse cursor and unusable keyboard. I had to resolve to using the reset button to reboot but the behavior was persistent.
Since this happend after logging in I figured I might try to login as another user. From the graphical login screen I switched to the second console (ctrl + alt + F2) created a testuser there, switched back to the graphical login screen and tried logging in as the testuser I just had created. That didn’t work either, I got returned to the graphical login screen after a few seconds, but was then able to login with my normal user account.
In hindsight I guess creating the testuser was probably not what did the trick but login in at the text console probably fixed something in my homefolder, not sure about that.

Have you tried using the 5.11.14 kernel? I assume you have an integrated AMD GPU; I have a very similar notebook (E495, same CPU) and something very similar happened to me after April 9th’s update (only that I’m using KDE instead of GNOME).

I wrote a post at this forum and I think I solved it by doing a kernel upgrade there. My guess is that a very recent commit at 5.11 kernel solved some page fault overflows (which was a very common error in my case, and may be in yours). You can read the whole post if you want to, or contribute with your experience! Maybe someone else can help you there. But TL;DR try using the 5.11.14 kernel, hopefully it helps you.

I’m figuring you mean Gnome, instead of Manjaro. :wink:


Why wait? Why not do a Timeshift snapshot, give it a go, and find out you’re in the 95% that had no issues (maybe more - most folks don’t post if they have no issues…).

This update went well for me, and I’ve got a faster and smoother desktop than before - the 5.11 kernel helped with that I think.

I only use a program with “wine-staging” “foobar2000” In portable mode, it was not working, I renamed the .wine folder in my /home to .wine-1, started foobar2000.exe, wine started creating another config folder (.wine) and now is working again.