[Stable Update] 2021-04-09 - Kernels, Systemd, Gnome 40 Apps, Mesa 21.0.1, Kernels, Browsers

It’s not required for cmake itself, only the GUI–hence why it’s optional. :wink:

Thanks for the new stable update. After restart, log-out and log-in all extensions were disabled. I tried to enable them via Installed Extensions - GNOME Shell Extensions without effect. Then I started the “Gnome Extensions” application were the “general” switch in the upper right of the title bar was “disabled”! By manually enabling it again all extensions successfully came back.

No major issues, but I lost audio after rebooting until I unplugged and plugged back in my audio devices (headphones and stereo receiver). Luckily the solution for me was that simple!

1 Like

Thank you, it worked with the pacman command, no idea why pamac had to act up.

Have a look at my previous post in Stable-Staging this morning.

No audio device found after pipewire was updated to 1:0.3.24-1.

This helps me:
sudo cp /etc/pipewire/media-session.d/media-session.conf.pacnew /etc/pipewire/media-session.d/media-session.conf

And i also copying this:
sudo cp /etc/pipewire/media-session.d/alsa-monitor.conf.pacnew /etc/pipewire/media-session.d/alsa-monitor.conf

Don’t forget to reboot your system after made this changes.
This is the fastest solution to reactivate your sound.
But it needs some exploration what is the difference between the new .conf.pacnew and the old .conf.


Updated today my Manjaro KDE @ x86 (i7-8750H), with errors :

  • “Failed to start Load Kernel Modules” at boot;
  • many softwares like Google Chrome, Firefox, Opera, Thunderbird, Telegram, etc, don’t open at all, showing (in Terminal) the error “/usr/lib/libpangoft2-1.0.so.0: undefined smbol: sysprof_clock”.

Second issue was solved by downgrading “pango” from v1.48.3 to v1.48.2 :
$ sudo pacman -U /var/cache/pacman/pkg/pango-1:1.48.2-1-x86_64.pkg.tar.zst

Updated a few hours ago.
I get this error every time i run almost anything in Wine:
X Error of failed request: GLXBadFBConfig
Major opcode of failed request: 152 (GLX)
Minor opcode of failed request: 0 ()
Serial number of failed request: 394
Current serial number in output stream: 394
It’s a Mesa 21 thing, i know the override command, but i’m waiting for a permanent fix.


Somehow it solved my issue with Bluetooth after the update as well Bluetooth Driver Problem :slight_smile:

Kudos to devs! :beer:

Pipewire does no more switch automatically to my wired headphones whenever I plug them in, it continues to play audio on the speakers and I have to switch them manually from the applet. However, when I unplug them, it is actually able to automatically switch back on speakers, no manual intervention in this case.

This used to work until this update, anyone having the same problem?
For what is worth, I’m using Plasma, I don’t know if the problem comes from Pipewire or plasma-pa that may be forcing this behavior

Is anyone having the same issue?

I am running the Gnome version. But there are no issues as such. I am able to switch multiple audio input and output.

Maybe try restarting the services related to Pipewire?

This update reintroduced the issues with wake from suspend/sleep for me (Laptop based on Ryzen 5 4600 with Vega8 iGPU) - most likely it’s down to Linux 5.11.10.

When I try to wake the laptop from suspend, all I see is a garbled screen. Eventually I might get a blank wallpaper + mousepointer, but nothing else. Switching to a different tty does not work either. Only solution is a forced reboot.

This issue was present with 5.11.2, then fixed in 5.11.6, now it seems back. :confused:
Guess I’ll either have to downgrade, or go back to 5.10-series.

Getting a lot of 503 errors, and a REALLY slow download speed, from SourceForge (~200 kB/s).

I’d much prefer a torrent, or a return to using OSDN – why’d Manjaro stop using the latter, anyway?

Thanks for your reply, sadly the problem persists. I also tried restarting my laptop as I feared I was missing one of the may systemd services, but nothing.

It may be a regression tho:

Hello everyone, I have the KDE desktop, saw the update this morning so I downloaded the updates and installed all with no problem, but after restarting then log in to my user, I see the desktop kinda unresponsive, with some lag while using dolphin, I’m currently using the kernel 5.10, intel core i7 with intel-nVidia graphic drivers. I don’t know what’s making to slow the performance of my desktop, but it’s something with this new update because yesterday, everything was normal and working nice, so if anyone has noted something similar with the new update, please share your solution. I’m considering to use another stable kernel, I also have the 5.4 LTS installed, but if there’s another solution to this, please help me.

This is still Gnome 3.38, it was just summer of the Gnome Apps that were upgraded to 40.


Pulseeffects stopped working

Please click the ► at the beginning of this line to view this solution


pamac install manjaro-pipewire
pamac install gst-plugin-pipewire


pamac install pulseeffects-legacy

pulseeffects-legacy does not depend on Pipewire and does not require removal of PulseAudio packages

this is what I did to get my audio back

Since this update (or maybe the last update), my shutdowns take a long time. It used to be that when I shutdown, it would take 5 seconds or so, but now it takes up to a whole minute. Boot is still very fast, something like 5 seconds.

Is there a way I can see some logs of what’s happening in the shutdown ?

bluetooth vulnerable :frowning: does this update fix it or we rather have to disable BT entirely for time being?

edit: nvm. seems it’s old news and already patched… still not sure it’s backported to older kernels and one should use 5.10+ with BT?

That article says it was patched in october last year, along with the release of the 5.10 kernel.